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Use the following table as a guide to locate information about each QuicKeys Action.

e this QuicKeys Action... If you want to automate these tasks...

Advanced Text Tools

See page 59 for more information.

Reformat a block of text to remove unwanted line breaks and spaces. 

Change a block of text to title case, uppercase, or lowercase. 

Remove quote marks from an E-mail message that was forwarded to you.

CD/DVD

See page 127 for more information.

Play, pause, stop, eject, or skip to the next track on your audio CD or DVD.

Check Spelling

See page 64 for more information.

Check the spelling of words in any document.

Choose Printer

See page 133 for more information.

Switch your default printer.

Dial-Up Networking

See page 135 for more information.

Connect to or disconnect from a dial-up networking service.

File Handler 

See page 75 for more information.

Set the file extension for a group of files.

Move a group of files to another directory or drive.

Folders

See page 84 for more information.

Switch to another directory when you are opening or saving a file or when you

Instant E-mail Action

See page 141 for more information.

Send an E-mail that contains attachments to a friend.
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Network Drives

See page 135 for more information.

Connect to or disconnect from a network volume.

Open

See page 87 for more information.

Open programs, control panels, documents, or other types of files.

Quick Type

See page 62 for more information.

Type long words or phrases using abbreviations specified in a user-created glossar

QuicKeys Clipbook

See page 100 for more information.

Control QuicKeys’ version of the system Clipboard.

QuicKeys Controller

See page 55 for more information.

Open/Close the QuicKeys Editor.

Show the QuicKeys QuickReference Card.

Enable/Disable QuicKeys hot keys and timers.

Control QuicKeys recording.

Recent Files

See page 90 for more information.

Search for files modified within a specified amount of time.

Screen Capture

See page 121 for more information.

Take a screen shot of the selected window or the desktop and outputs the image to
location.

Screen Saver

See page 123 for more information.

Start or stop your selected screen saver.

is QuicKeys Action... If you want to automate these tasks...



ix

• • • •

e monitor.

nformation.

Us
Screen Settings

See page 125 for more information.

Change your screen settings when attaching your laptop computer to a full-siz

Select Menu

See page 107 for more information.

Select an item from a menu without using your mouse.

Set Audio Volume

See page 130 for more information.

Adjust the various audio devices on your computer.

Set System Clock

See page 110 for more information.

Set your system clock based on your input or based on specified time server i

Special Characters

See page 66 for more information.

Type symbols or international characters.

System Specials

See page 113 for more information.

Empty your Recycle Bin.

Lock your computer.

Log off your computer.

Restart/shutdown your computer.

Set your computer to standby.

Restart Windows.

Toolbar

See page 37 for more information.

Create QuicKeys toolbars that provide quick access to your QuicKeys Actions.

e this QuicKeys Action... If you want to automate these tasks...



• • • •

tasks.

Use th
x
Graphical Table of Contents

Type Date/Time

See page 68 for more information.

Type the date and time in a specific format.

Type Keystroke

See page 115 for more information.

Reassign hot keys built into the programs you use so they make sense to you.

Type Text

See page 71 for more information.

Type text you specify.

Web Launcher

See page 144 for more information.

Open a specified URL in your default Web browser.

Open selected text as a URL.

Display a list of Netscape Bookmarks or Internet Explorer Favorites.

Window Handler

See page 116 for more information.

Manipulate all windows, active windows, and specified windows.

Zip Files

See page 92 for more information.

Compress, decompress, and verify Zip files.

Sequence (only available from the 
Create menu)

See page 153 for more information.

Display the Sequence Editor, which you can use to combine Actions and recorded 

is QuicKeys Action... If you want to automate these tasks...
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 •
COME TO QUICKEYS

cKeys® for Windows® is software that lets you create 
om keyboard actions, menu commands, and toolbars so 
 can perform routine tasks with a single mouse click, a 
stroke, or a key combination. These tasks are referred to as 
ons. QuicKeys Actions are similar to macros, except that 
 are much easier to create.

reate a QuicKeys Action, all you have to do is define the 
 you want to perform in the QuicKeys Setup Wizard. You 
t then choose to replace the task, or series of tasks, with a 
le trigger, such as a hot key, a QuicKeys toolbar, or a 

ktop shortcut. QuicKeys automates common computer 
s that include anything from opening folders you 
uently use to logging into your favorite database 
gram.

cKeys provides you with a powerful and versatile 
rding function that is ideal for automating lengthy or 
plex tasks. Tell QuicKeys to watch your Actions on the 

 and it can then play those actions back whenever you 
t. These recorded actions are called Sequences, and they 

 mimic virtually anything you do on your computer.

cKeys toolbars work much like the toolbars you use in 
r other programs, except that you call the shots with 
cKeys toolbars. You specify what each toolbar button 
s, which icon is used, and when the toolbars are displayed. 
ther words, QuicKeys toolbars give you complete control. 
, like the recording feature, toolbars save you time by 
ing your interaction with your computer more efficient.

However you choose to use it, QuicKeys rep
solutions that make it indispensable for assig
unrewarding and repetitive tasks to the com
the computer user.

WHAT QUICKEYS CAN DO FOR Y
Think of something you do on a daily basis. 
whatever task you thought of can probably b
QuicKeys. For example, if you frequently sw
printers on your network, QuicKeys can do t
a single hot key. Changing your printer with
rather than navigating through numerous pr
saves you time and frustration.

QuicKeys can also assist you with multi-step
example, if your job requires that you routin
graphics from one format to another, have Q
you. Just direct QuicKeys to watch and recor
and then assign QuicKeys a trigger that will t
repeat your actions. You will learn more abo
Chapter 3, but for now just think of triggers 
keystroke that communicates to QuicKeys th
start a specific task.

When you select the trigger, QuicKeys will no
the steps required to change your graphics, b
quickly and accurately. Humans are prone to
however, you can do a job right once, QuicK
it thousands of times with no mistakes.
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Toolbar Action 
-used Actions at 
ake any 
 savings in time and frustration is easy to measure. The 
 advantage of QuicKeys, however, is intangible. After you 
all QuicKeys, your computer work flows more smoothly. 
ead of working in one program and then spending 
able time searching for another, programs and data 

ear and disappear automatically as they are needed. The 
arate parts of your computer merge in a way that makes 
e to you so you can finally complete a day’s work in a 
’s time. How many other programs do you know of that 
add such value to your computing experience?

’S NEW IN QUICKEYS 2.0
cKeys 2.0 offers many new features and key 
rovements that will provide you with even more ways to 
your work done quickly and efficiently.

CTIONS

creen Capture: Take screen shots of your entire screen or 
n active window using a Screen Capture Action. You can 
hen save the captured image to a file, the Windows 
lipboard, the QuicKeys Clipbook, or you can print it.

creen Saver: Control your screen saver with a Screen 
aver Action. You can use QuicKeys to select a screen saver 
r to turn your screen saver on and off.

et System Clock: Change your system clock to a time you 
rovide or to a time designated on a specified time server.

ip Files: Compress files, extract compressed files, add to 
ompressed files, and validate compressed files with the 
ew Zip Files Action.

uick Type: Specify typed abbreviations for long words, 
ames, or phrases. Build a glossary of the words you use 
nd then choose which characters you want to represent 
hose long words or names. 

heck Spelling: Check the spelling of a selected block of 
ext in virtually any document.

• Mouse Position: Specify where you want 
a QuicKeys trigger so you can keep your 
keyboard.

NEW SEQUENCE ACTIONS

• Select Items in List: Select an item in a dr
inserting a step in your Sequence that che
list controls. You can direct QuicKeys to c
by text.

• Select Items in Dropdown List: Select an
dropdown list by inserting a step in your
checks for specific combo box controls.

• Switch Tabs: Switch tabs in a Sequence u

• Wait for User Input: Wait for user input, 
keystroke or a mouse click, before procee
Sequence. 

• Check Condition: Verify that a specific co
before proceeding to the next step of the s

• QuicKeys Event Logger: Write out events
NT and Windows 2000 System Event log 
Windows 98.

TOOLBARS
Residing primarily off-screen, new Pop Out 
out” when your mouse moves near them. Th
Dockable toolbars that use the Auto-hide fea
you can have multiple Pop Out toolbars on on
screen and you can choose the orientation an
toolbar.

Another improvement made to QuicKeys too
availability of defined and recent Actions in 
Menu buttons. Now you can have frequently
the tip of your fingertips without having to m
adjustments within QuicKeys.
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DITIONAL IMPROVEMENTS

• QuicKeys Editor: The QuicKeys Editor offers 
improvements in the interface as well as in functionality. 
The My Keyboard, My Toolbars, and My Actions views 
each offer a tab that enables you to look at all of your 
Actions or all of your toolbars, regardless of scope. Plus, 
when you scope an Action to a particular application, that 
application appears at the top of the scope menu next time 
you create an Action. Finally, you can now edit Action 
names directly in QuicKeys Editor Action list. 

• System Specials: Use the System Specials Action to lock 
your Windows NT or 2000 computer, or to empty the 
Recycle Bin.

• Window Handler: Restore the last minimized window; 
center the active window; set active window size; 
maximize, restore, or center specified windows; and set the 
window size for specified windows using the Window 
Handler options.

• File Handler: Set file and folder attributes to read-only, 
hidden, system, archived, or to a specific date and/or time. 
You can also display the Windows “Open With” dialog so 
you can choose which program opens the selected file. 
Choose among new options that support the use of 
wildcards, skip sub-folders, and move selected files/
folders to the Recycle Bin rather than immediately deleting 
them.

• QuicKeys Clipbook: Use the “Clear all” option in the 
Clipbook Editor to clear all your clips. You can also specify 
the name of the file you want added to your paste, copy, or 
delete functions.

• Folders: Create a new folder with the Folders Action.

• Sequences: Like the QuicKeys Edito
offers improvements in both the inte
functionality. New in the interface ar
make it much easier to edit your Seq
just click the Folders button in the Se
a Folders action to your Sequence.

In terms of functionality, version 2.0 
useful enhancements. You can edit Se
directly in Sequence Editor list. Plus,
menu, you can record a single Action
of the updated playback palette, whi
Sequence name and step number. Th
also has a handy new “Stop and open
opens the Sequence Editor.

• Printing: Click the Print option in th
the Sequence Editor to print Action s
steps, respectively.

• QuicKeys Tips: Create Actions direct
Tips window at startup.

• Update Checking: Use the Check for
option in the QuicKeys Editor Help m
have the latest version of QuicKeys.

ABOUT THIS USER MANUAL
Read this section to learn how the QuicK
organized and to become acquainted wi
used in this manual. Knowing how the m
help you use it more efficiently.

ORGANIZATION
Each chapter of this manual first describ
section and its benefit to you. Then, each
instructions for setting up and using the
section ends with information about the
the dialogs or wizards discussed in that 
Guide.
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ns.

le Monday 
.S. Central Time. 
d by:
hapter 1: Introduces you to QuicKeys and provides 
nformation about using the manual and contacting the 

akers of QuicKeys.

hapter 2: Lists the system requirements, provides 
nstallation instructions and information about the 
uickStart Wizard.

hapter 3: Introduces you to the different components of 
uicKeys and provides an overview of the process of 

reating QuicKeys Actions. This chapter is very 
nformative for users who are new to the QuicKeys 
oftware.

hapter 4: Introduces you to toolbars and provides 
nstructions for using them.

hapter 5-Chapter 12: Provides information about the 
eatures and benefits of each individual QuicKeys Action, 
s well instructions for using those Actions.

hapter 13: Introduces you to sequences and provides 
nstructions for using them.

ppendix a: Provides tips for using QuicKeys and 
olutions for problems you may encounter while using 
uicKeys.

ppendix b: Provides instructions for creating custom 
cons that can be used in QuicKeys toolbars.

ppendix c: Provides an illustration of the QuicKeys 
rchitecture.

ppendix d: Provides a list of hot keys that QuicKeys 
annot use.

PTIONS
 documentation assumes you are familiar with the 
dows operating system and hardware. If you need 
stance with standard Windows procedures, consult the 
ne Windows Help that’s available from the Start menu on 
r taskbar. 

CONVENTIONS

• Helvetica Bold Condensed font indicates menu
buttons, and active dialog text that is refe
instructions. Example: Go to the File menu

• A right-arrow character (>) indicates the h
menu and submenu options.

• A ❖  symbol indicates a note that provide
information about the topic being covered

• A ▲ symbol indicates an important statem
special attention.

CONTACTING CE SOFTWARE
If you have questions about QuicKeys that a
in the manual, use this section to learn how t
Software.

TECHNICAL SUPPORT
CE Software offers online, fax, and telephone
the Technical Support Web page at http://www.h
information about the various support optio

Contact Information
The Technical Support Department is availab
through Friday from 8:00 A.M. to 5:00 P.M. U
CE Software Technical Support can be reache

• Phone: 515-221-1803

• Fax: 515-221-1806

• Web page: http://www.help.cesoft.com

• E-mail: ceonline@cesoft.com
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Before You Call
Check the following Web sites for technical information:

• Have you checked the QuicKeys Web site for updates and 
product information at http://www.cesoft.com

• Have you checked the CE Software Technical Support Web 
page or newsgroups at http://www.help.cesoft.com

When You Call
To help our Technical Support team assist you as quickly as 
possible, please have the following information available 
when you speak with, or write to, a Technical Advisor:

• Product name and version (e.g. QuicKeys 2.0)

• Computer type and model (e.g. Pentium 2 333 Mhz)

• Operating system and version (e.g. Windows 98)

ODUCT FEEDBACK
What do you think of QuicKeys? We want to know and we 
encourage you to submit your ideas to feedback@cesoft.com so 
we can consider them for the next version of QuicKeys.

ER GUIDE FEEDBACK
We also welcome feedback about the documentation that 
accompanies QuicKeys. Please E-mail us at manuals@cesoft.com 
with your comments and suggestions.

The most current version of this manual is available online at 
http://www.cesoft.com/ and can be viewed with Adobe® Acrobat 
Reader 3.0 or greater. Visit http://www.adobe.com/ to download a 
free copy of Acrobat Reader.

LES AND CUSTOMER SERVICE 
CE Software’s sales and customer service staff can answer 
your questions about product availability, upgrades, product 
prices, damaged disks, customer registration, and general 
policies. 

Contact Information
The CE Software Customer Service depa
Monday through Friday from 8:00 A.M.
Central Time. If you have a question abo
product, please have your serial number
For customers outside the U.S., please co
distributor.

• Phone: Domestic orders 800-523-7638

• International orders: 515-221-1801

• Fax: International and Domestic orde

• Online: http://www.cesoft.com/

Ownership Transfer
If you transfer ownership of a CE Softw
E-mail us at sales@cesoft.com or send a lett
name, serial number, your name, and th
and address to:

CE Software, Inc.
Attn: Ownership Transfer
P.O. Box 65580
West Des Moines, IA 50265 U.S.A.

Change of Address
If you change your address, please E-ma
or send a letter indicating your old and 

CE Software, Inc.
Attn: Change of Address
P.O. Box 65580
West Des Moines, IA 50265 U.S.A.



6 Chapter 1
Welcome to QuicKeys

• • • •



CHA

• • • • •
INST

The
Qui
Qui
cha

REQU
The
inst

• I
g

• P

• I

• 1

• O

• A

• S

INST
If yo
whi
adm

1. R
i

2. R
Y
s

n Key in the 
mpany name is 

e to install 
ars.

sh. The Startup 
 the QuicKeys 
 installation.

the QuicKeys 
ly started. The 
ickStart Wizard 
o set up a variety 
e advantage of 
ickStart Wizard, 

u want to 
 Wizard will 
mate the tasks 
s edit the tasks 
PTER 2

 •
ALLING AND STARTING QUICKEYS

 steps involved in setting up QuicKeys include installing 
cKeys on your hard disk, completing the questions in the 
ckStart Wizard, and starting the QuicKeys Editor. This 
pter explains how to accomplish these tasks.

IREMENTS
 minimum requirements your computer must meet to 
all and operate this product include:

ntel compatible PC running Windows 98 or NT 4.0 or 
reater

ersonal computer with a Pentium or equivalent processor

nternet Explorer 4.0 or greater

6 MB of RAM (32 MB recommended)

ne CD-ROM drive

t least 20 MB of available hard disk space

VGA 800x600 monitor

❖ Certain features are enhanced by an Internet 
connection

ALLING QUICKEYS
u are using Windows NT, installation must take place 

le logged in as an administrator or as a user with 
inistrative rights.

ead the wizard dialog that appears when you start 
nstallation and click Next.

ead the terms of the Software License Agreement. Click 
es if you agree with the terms and want to install the 
oftware.

3. Read the Readme file and click Next.

4. Type your Name, Company, and Activatio
appropriate boxes and click Next. (Your co
not required.)

5. Choose the directory where you would lik
QuicKeys and click Next. A status bar appe

6. Read the final wizard dialog and click Fini
QuicKeys Engine is selected by default so
Engine is running when you complete the

AFTER INSTALLATION
When you complete the installation wizard, 
Engine and QuicKeys Editor are automatical
first time the QuicKeys Editor opens, the Qu
appears. The QuickStart Wizard is designed t
of common QuicKeys Actions so you can tak
QuicKeys immediately. Before you use the Qu
spend a few minutes thinking about what yo
automate on your computer. The QuickStart
likely provide an opportunity for you to auto
you have in mind. Remember, you can alway
you set up with the QuickStart Wizard later.
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Card.

00 characters) of 
 with the 

e toolbar that 
 

en there are not 
 the only time 
iately after 
 after completing 
 Editor. To learn 
. To learn how to 
izard, use the 
O USE YOUR NEW ACTIONS
 can trigger the Actions created by the QuickStart Wizard 

electing the hot key you assigned to your new Actions.

electing an Action from the QuicKeys menu. 

 of these methods is discussed in “Triggering Actions” on 
e 25, but this section provides instructions for using the 
ckReference Card to trigger your Actions.

 THE QUICKREFERENCE CARD
rigger your new Actions using the QuickReference 
d:

lick the close box to close the QuicKeys Editor.

f you chose to print the QuickReference Card, refer to 
our printout right now and select one of the hot keys 

isted on it. Your computer should complete the Action 
escribed in the Action column of your printed 
uickReference card.

If you chose not to print the QuickReference Card, press 
Shift+Control+Space to display the QuickReference Card on 
your screen. Click one of the Actions listed in the Quick-
Reference Card to trigger it. See page 34 for more infor-
mation on the QuickReference Card.

 ABOUT THE QUICKSTART WIZARD
w are some quick facts about the QuickStart Wizard you 
completed.

he QuickStart Wizard only displays when there are no 
ctions created or when you select Run QuickStart Wizard from 

he Help menu.

f you want to edit an Action you created in the QuickStart 
izard, double-click the Action in the My Actions tab of the 
uicKeys Editor.

• By default, all Actions created with the Q
are universal in scope. This means that yo
Actions in any of the programs you have o
for more information on Action Scope.

• The list of programs presented to you in t
Wizard is populated by the programs ava
menu. If you want to open a program tha
page 87 for information on the Open Acti

• By default, all Actions created with the Q
are listed in the My Actions tab of the QuicK
the QuicKeys menu. See Figure 1 for an il
QuicKeys menu.

• If you want to trigger your Actions with h
than selecting them from the QuicKeys m
printed QuickReference Card for a list of 
automatically assigned to the Actions. See
more information on the QuickReference 

• You can type up to 10 KB (more than 10,0
text when you set up the Type Text Action
QuickStart Wizard.

• The QuickStart Wizard creates a Dockabl
displays QuicKeys Action Menu buttons.

STARTING QUICKEYS
Since the QuickStart Wizard only appears wh
any QuicKeys Actions created, it’s likely that
you will see the QuickStart Wizard is immed
installation. When QuicKeys is started again
the QuickStart Wizard, you see the QuicKeys
more about the QuicKeys Editor, see page 12
start QuicKeys without the assistance of a w
following instructions:
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To open the QuicKeys Editor:

1. Right-click the QuicKeys icon. It is located in the status 
area of the taskbar (commonly known as the tray).

2. Select Open QuicKeys Editor from the QuicKeys menu. The 
QuicKeys Editor appears. See page 12 for more 
information on the QuicKeys Editor.

ECK FOR QUICKEYS UPDATES
When you select Check for QuicKeys updates from the QuicKeys 
Editor Help menu, QuicKeys connects to CE Software using 
TCP/IP. If your version of QuicKeys is not current, an alert is 
displayed telling you how to get the newest version of 
QuicKeys. You can choose to go to CE Software’s Web site 
immediately or you can choose to be reminded of the update 
in “X” days.

If you are unable to connect to CE Software, the attempt will 
time out. A connection failure may occur if you have no 
Internet connection configured, if you have problems with 
your dial-up service, or if CE Software’s server is not 
available.

URE 1: By default, you can open the QuicKeys menu from the 
dows taskbar. The QuicKeys menu is located in the status area of the 
bar.
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PTER 3

 •
KEYS OVERVIEW

 chapter explains how to use QuicKeys and provides an 
rview of the QuicKeys architecture. Reading this chapter 
 acquaint you with the capabilities of QuicKeys so you can 
 full advantage of the software’s power and flexibility. 

KEYS ACTIONS AND SEQUENCES
cKeys Actions and Sequences are the foundation of the 
cKeys program. QuicKeys Actions automate simple one-
 tasks, such as choosing a network printer. QuicKeys 
ences automate multi-step tasks, such as starting a 
base program, searching for a specific item, or printing 
the selected database records. Actions can be built using 
p Wizards or the Action Properties dialog. Sequences are 
t using a collection of Actions that can be assembled 
ually or by using the QuicKeys recording feature. The 
rding feature enables QuicKeys to “watch” what you are 
g and repeat your actions.

TING ACTIONS AND SEQUENCES
bably the single most important factor involved in using 
cKeys is understanding the concept behind its usage. 
cKeys is a powerful software tool you can use to automate 
r computer. It’s a tool, however, that is only as effective as 
 make it. Once you install QuicKeys, you need to make a 
tal note of the tedious, routine tasks you perform on your 
puter and earmark those tasks for some attention from 
cKeys. Each time you think of something that QuicKeys 
ld make easier for you, create an Action or Sequence that 
mates that task or series of tasks.

When you create a QuicKeys Action or Sequ
choose the trigger that launches it. In other w
to specify the “signal” that tells QuicKeys wh
Action or Sequence. For example, if you wan
open a database program and enter the curre
you need to let QuicKeys know when to beg
hot key (such as F5), or a number of other av
triggers (such as toolbars, the QuicKeys men
triggers) to communicate with QuicKeys tha
begin this Sequence. It’s kind of like having a
assistant inside your computer that understan
triggers you choose.

That’s all there is to using QuicKeys: thinkin
automate, creating QuicKeys Actions or Sequ
replace those tasks, and triggering the tasks. 
spend a few minutes telling QuicKeys what 
from that point on you save hours, days, ma
with the Action or Sequence that only took y
minutes to set up. It’s a pretty good return fo
investment of time. In fact, after using QuicK
weeks, you will probably be amazed when y
much of your day was once spent searching 
rearranging windows on your desktop, or cl
options in countless windows.
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KEYS COMPONENTS
 of understanding any piece of software is understanding 
ifferent components. Understanding the parts of 
cKeys will familiarize you with the logic behind the 
cKeys architecture, making it easier to find things and use 
software more efficiently. 

cKeys is composed of three main elements: the QuicKeys 
or, the QuicKeys Engine, and QuicKeys Actions. This 
ion familiarizes you with each of these components.

❖ For a diagram of the QuicKeys architecture, see 
page 179.

EYS EDITOR
n you select QuicKeys from the Start menu, the QuicKeys 
or appears. It is your control center for creating, editing, 
 deleting Actions. There are four separate tabs available in 
QuicKeys Editor that each serve a different purpose: the 
 Wizards tab, the My Keyboard tab, the My Toolbars tab, and the 
ctions tab. 

The QuicKeys Editor Tabs

Use the Setup Wizards tab as a starting p
setting up Actions with the Setup Wizard.

Create, edit, and delete toolbars from the 
My Toolbars tab.
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uided through the 
 automate the task 
sor is positioned over 
nd, a hot help 

b to be guided through 
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 the Wizard window 
ges depending upon 
p of Setup Wizards 
d.
The Setup Wizards Tab
When you first start QuicKeys, you see a
displays the Setup Wizards tab as the frontm
the buttons in the Setup Wizards tab to be g
process of setting up an Action that will
described on the button. When your cur
an Action button for more than one seco
description of the Action appears.

Use the My Keyboard tab to quickly add or change 
hot key triggers for existing Actions.

View all your QuicKeys Actions and their properties from the 
My Actions tab. This illustration uses the Details view, but you 
can also select the Large Icons, Small Icons, or List views 
from the View menu. FIGURE 2: Click a button in the Setup Wizards ta

the process of creating, editing, and deleting Acti

Click the drop-down 
arrow to display a list 
of Setup Wizard 
viewing options.

The text of
label chan
which grou
is displaye
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from the Universal 
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FIGURE
your Ac
you can
more in

Hot ke
by clic
key co
pressi
combi
 My Keyboard Tab
n you click the My Keyboard tab, you see a diagram of your 
oard along with a tabbed Action Sets pane. Raised keys 
e Keyboard Layout pane indicate the keys that QuicKeys 
rrently using as triggers. Click a raised key to display the 
on it triggers on the right side of the window. See 
re 3.

Drag and drop Actions from the Action Sets p
Keyboard Layout buttons to assign or reassig
When you release the mouse, the menu show
appears. Use the menu to choose modifier ke
pressed simultaneously with the selected Ke
key. 

For example, if you drag a Type Text Action 
tab to the F8 key, the modifier menu appears.
(None), pressing F8 alone will trigger the Type
you select Ctrl+Alt+Shift, you must press Ctrl+Alt+
the Type Text Action.

❖ You can also access the modifier ke
right-clicking an Action listed in th
My Keyboard tab and selecting the Mo

 3: Use the My Keyboard tab to assign hot key triggers to 
tions. The standard keyboard layout is shown here, but 
 also specify a laptop keyboard layout. See page 30 for 
formation.

The selected key 
displays in the Key 
area, along with the 
Actions that use that 
key.

Modifier keys used in 
combination with the 
selected key display 
in the Key area.

ys can be edited 
king in the Hot 
lumn and 
ng a different key 
nation.

FIGURE 4: The modifier menu
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Right-click an Action in the Action Sets pane to create a new 
Action; cut, copy, paste, or delete Actions; select all options; 
change the way the Action list is displayed; display properties 
or advanced options; or clear the hot key for the selected 
Action. See Figure 5 for an illustration of this context menu.

Right-click the Actions listed in the Key area to delete a 
selected Action from the Set, to display the Properties and 
Advanced options, to clear the selected hot key, or to select 
Modifiers for the selected Action.

The My Toolbars Tab
When you click the My Toolbars tab, you ca
toolbars. Toolbars are graphical represen
tasks on the computer. Most programs p
perform a specific function, such as prin
the Print icon. QuicKeys toolbars are dif
because you specify the appearance and
toolbar.

Toolbars are a valuable asset if you have
QuicKeys Actions. They provide a quick
triggering your Actions. You don’t have
key and you don’t have to fill up your Q
use toolbars to trigger at least some of y

URE 5: Right-click an Action in the Action Sets pane of the My 
board tab to display the context menu.

URE 6: Right-click an Action in the Key area of the My Keyboard tab 
isplay the above menu.
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n be identified by a 
n or timer icon.
n you click the toolbar name in the My Toolbars tab of the 
cKeys Editor, all the Actions that reside on that toolbar 
lay in the Toolbar Buttons pane.

ight-click a toolbar in the My Toolbars tab to create a new 
oolbar, create a new toolbar button, display the Toolbar 
utton Wizard, hide the toolbar, delete the toolbar, or 
isplay the toolbar’s properties.

ight-click in the Toolbar Buttons pane to create a new 
utton, display the Toolbar Button Wizard, or delete the 
elected toolbar button.

• Double-click a toolbar to display the toolb
Properties dialog.

• See Chapter 4 on page 37 for more detaile
about toolbars.

The My Actions Tab
When you click the My Actions tab, all of your A
the default Details view. This tab is useful whe
view and edit all the Actions you created fro
window.

 7: Use the My Toolbars tab to create, edit, and delete QuicKeys 

 column 
g to choose how 
olbars are 

When you select a toolbar, 
the buttons placed on that 
toolbar display in the Toolbar 
Buttons pane.

FIGURE 8: Use the My Actions tab to view, create, or e

There is a different tab 
for each Action Scope 
you have specified.

Double-click an 
Action to edit it.

Actions t
triggered
QuicKeys
trigger ca
menu ico
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 My Actions tab.

Double-click a 
Sequence step to 
edit it.
• Double-click an Action in the My Actions tab to display a 
Setup Wizard or an Action Properties dialog where you 
can edit the Action.

• Right-click an Action to create a new Action; cut, copy, 
paste, or delete Actions; select all options; change the way 
the Action list is displayed; display properties or advanced 
options; or clear the hot key for the selected Action.

• Drag-and-drop an Action from one tab to another to edit 
the Action scope.

Sequence Editor
You can open the Sequence Editor by selecting Sequence in the 
Create menu. The Sequence Editor enables you to consolidate 
Actions into a more complex Action, so it’s likely you may not 
choose to use the Sequence Editor until you are comfortable 
creating QuicKeys Actions. A Sequence is a collection of 
Actions that completes a multi-step task. For example, you 
can create a Sequence that launches your E-mail application, 
types your user name and password, and clicks OK in the 
appropriate dialog. The Sequence would contain four 
separate Actions that are individually only capable of 
completing a single task until they are combined into a 
Sequence.

If the Sequence does not execute success
displays the Step ID number where the 
difficulty.

The Sequence Editor allows you to edit 
Sequence. There are three different meth
Sequence Editor:

• Record a Sequence and the Sequence
automatically when you are done rec
for more information on recording.

• Select Sequence from the Create menu.

• Double-click a Sequence listed in the

FIGURE 9: The Sequence Editor

Add steps to your 
Sequence using the 
options in the Create 
menu or the Action 
toolbar.

Move the insertion line 
to specify where you 
want the new Action or 
Sequence tool 
inserted.
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visit CE 

the Plug-in 
see the Actions that 
EYS ENGINE
 QuicKeys Engine is a background program that is 
ssary for the QuicKeys Editor to function. Most of the 
 you don’t need to pay any attention to the Engine 
use it’s started whenever you turn on your computer. 
ever, if you ever turn off the QuicKeys Engine, it’s 

ortant to know how to turn it back on because your 
ons won’t work without it.

n you install QuicKeys, a shortcut to the QuicKeys 
ine is placed in the Startup Items folder. The only time you 
 need to exit the QuicKeys Engine is when you install new 
rams that require you exit all programs. In such a 

ation, you can right-click the QuicKeys icon located on the 
bar and choose Exit to quit the Engine. Use one of the 
wing methods to restart the Engine:

estart your computer 

elect Programs>QuicKeys>QuicKeys on the Start menu

QUICKEYS PLUG-INS
A plug-in is a software component that adds
QuicKeys. There are several plug-ins availab
Each plug-in can be turned on or off individu
party plug-ins can easily be added to QuicKe
flexible architecture.

If you want more information about turning
off, see page 18. If you are interested in exten
of QuicKeys by creating your own plug-ins, 
Software’s Web site at http://www.cesoft.com/.

FIGURE 10: You can manage QuicKeys Plug-ins from 
Manager window. When you click the + icon, you can 
are included in that category.
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 Editor does not have 
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QuicKeys Editor.

s Editor and the 

Windows taskbar to 
ICKEYS MENU
By default, a QuicKeys icon appears on your taskbar after 
installation. When you right-click that icon, the QuicKeys 
menu appears. In the QuicKeys menu you can:

DING ACTIONS
You can add Actions to the QuicKeys menu by selecting the 
Include in QuicKeys menu check box in the Setup Wizard or in the 
General tab of the Action Properties dialog. The hot keys 
assigned to each Action also appear in the QuicKeys menu 
unless you have cleared the option to Show hot keys in QuicKeys 
menu in the Options dialog. See page 30 for more information.

• Toolbars submenu—Views or create

• Abort Sequence—Stops the playback

• Start/Stop Recording—Records a ne
recording.

• Record One Action—Creates a singl
recording your computer movement
your Action, the Action Properties di
Action you performed. The QuicKeys
to be open to use this recording optio

• Open QuicKeys Editor—Opens the 

• Exit QuicKeys—Closes the QuicKey
QuicKeys Engine.

• Trigger QuicKeys 
Actions

• Create toolbars

• Start/Stop recording 
a Sequence

• Open the QuicKeys 
About box

• Open toolbars • Open the QuicKeys 
Editor

• Exit QuicKeys • Abort the playback 
of a sequence

FIGURE 11: Right-click the QuicKeys icon in the 
display the QuicKeys menu.
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heck For Update—Checks CE Software’s Web site for 
nformation about QuicKeys updates and upgrades. If 
here is a new update, you can choose to open the Web site 
r you can choose to be reminded about the update again 

n “X” days.

bout QuicKeys—Displays the QuicKeys About box, 
here you can browse registration and system 

nformation, CE Software credits, and relevant Web sites.

e QuicKeys icon or QuicKeys hot keys are not displayed 
our taskbar, check to make sure the Show icon in taskbar and 
 hot keys in QuicKeys menu options are selected. You can view 
e items by selecting Options from the QuicKeys Editor View 
u.

G QUICKEYS
re are two rudimentary steps involved in using the 
cKeys program: setting up Actions or Sequences and 
ering Actions. This section provides general information 
t this process. For information on specific Actions, see the 

esponding chapter in this manual. For example, 
pter 13 discusses “Building Sequences” in detail.

FIGURE 12: The process of setting up QuicKeys involv
Actions and triggering Actions.

Click a Setup Wizard button in 
the Setup Wizards tab.

Set the options you want to 
use in the Setup Wizard. Make 
sure you set the trigger (such 
as a hot key) you want to use 
to activate the Action.

Click Finish when you reach 
the end of the Setup Wizard. 
(Your Action is saved as soon 
as you click the Finish button.)

Select the trigger you 
specified to activate the 
Action. QuicKeys reacts to the 
trigger and completes the task 
immediately.

Setting Up Actions

Triggering Actions
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EATING QUICKEYS ACTIONS
When you create a QuicKeys Action, you can use the Setup 
Wizard (shown in Figure 13) or the Action Properties dialog 
(shown in Figure 14) to specify how the Action behaves. The 
Setup Wizard is used by default because it prompts you for 
information in a step-by-step fashion. If you are a more 
advanced user, you can turn off the Setup Wizard in the 
QuicKeys Editor Options dialog and instead use the Action 
Properties dialog. (See page 30 for more information on the 
Options dialog.) The Action Properties dialog presents all the 
setup options for an Action in a single dialog.

Whichever method you use to create QuicKeys Actions is 
completely dependent upon your comfort level with 
QuicKeys.

Using the Setup Wizard
When you begin using QuicKeys, you w
Setup Wizard because it provides the m
creating QuicKeys. You simply click an A
Setup Wizards tab and a series of wizard di
through the process of setting up or edit
Action.

Using the Action Properties Dial
When you are more comfortable with Qu
to use a more direct approach to create a
can select a Action from the Create menu 
Properties dialog. Action Properties are 
specify for each QuicKeys Action you w
Action-specific options are presented to 
when you use the Setup Wizard to creat
these same options are presented in a sin
use the Action Properties dialog to creat
Actions.

FIGURE 13: The Introduction page of the Setup W
you click a button in the Setup Wizards tab.
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FIGURE
appears 
eral—Supply the name of the Action and the hot key that 
ers it in this tab. You can also select the Include in QuicKeys 
 check box to list the Action in the QuicKeys menu or click 

Clear hot key button to clear the contents of the hot key field.

ou must use the Clear hot key button to clear the hot key 
 because the Delete and Backspace keys cannot delete a hot 

Toolbars—Click the Toolbars Tab to select the 
you want this Action displayed.

Action Scope—Specify the range of operatio
In other words, choose whether the Action w
or whether it can only be triggered from the 
specific program, or from a particular hardw
Figure 17.

• Universal—Universal is selected by default
you create. Use Universal when you want to
trigger the Action at any time, regardless 
you are in or whether or not the desktop 

❖ Buttons on toolbars are always Uni

 14: The Action Properties dialog for the Web Launcher Action 
when you select Create>Internet Tools>Web Launcher. 

FIGURE 15: The Action Properties General tab.

FIGURE 16: The Action Properties Toolbars tab
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uicKeys examines the 
ine whether or not it 
process is illustrated 

ab If you have already 
on appears at the top of 
• Desktop—Select Desktop when you only need to trigger the 
Action from the desktop. This option is useful for your 
toolbars. When toolbars are assigned Desktop scope, they 
appear whenever the desktop is active.

• Program—When you select Program, a Program drop-down 
list appears where you can choose the program in which 
you want to use the Action. Click the Browse button and 
navigate to the program you want to use if the program is 
not listed in the drop-down list. This scope option is useful 
if you have several Actions you only need to use within a 
program, such as Microsoft Access.

• Hardware Profile—A hardware profile is a set of 
instructions specified within your operating system that 
tell your computer which devices to start when you turn 
on your computer. In other words, hardware profiles 
enable you to categorize QuicKeys Actions under different 
hardware identities. 

For example, you can set up the F5 key as the QuicKeys hot 
key that tells your portable computer to switch to Standby 
mode when your computer is using a Docked Hardware 
Profile. Additionally, you can use the F5 key within the 
Undocked Hardware Profile scope to shut down your 
computer when your computer is undocked. The same hot 
key works differently depending upon the “state” of your 
computer.

When you trigger a QuicKeys Action, Q
Action Scope you set in order to determ
should trigger the Action. This decision 
in Figure 18.

FIGURE 17: The Action Properties Action Scope t
scoped an Action to an application, that applicati
the scope list.
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 unique for each 

FIGURE
specific S

e Web Launcher 
re is no limit on the number of Action scopes you can 
ify, but if you have a set of Actions for each program you 
 you may have too many tabs for the QuicKeys Editor to 
lay. If this happens, small arrows appear on the right side 
e QuicKeys Editor. Click the arrows to scroll through the 
f Action Scope tabs.

elete a particular Action Scope tab, delete or reassign the 
e for each of the Actions in that tab. Then, close and 
en the QuicKeys Editor. When the QuicKeys Editor 

ears, the Action Scope tab you chose is no longer 
layed.

Timed Triggers—Choose a specific time you
to be triggered. By default, there is no timed 

Action-Specific Properties—The Action Prop
contains an Action-specific properties pane that is
QuicKeys Action. 

 18: This diagram illustrates Action Scope priority from the most 
cope selection to the least specific Action Scope option.

QuicKeys 
trigger

Desktop 
Scope

Program-specific Scope

Hardware Profile Scope

Universal Scope

FIGURE 19: The Action Properties Timed Triggers tab

FIGURE 20: The Action-specific properties pane for th
Action
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 of the Setup Wizard.

FIG

ion Properties dialog or 
IGGERING ACTIONS
QuicKeys provides a variety of ways to trigger Actions so you 
can use the methods that make sense to you. QuicKeys makes 
customizing the way you work easy.

You can use any or all of the following triggers for each 
QuicKeys Action:

• Hot key—The key(s) on the keyboard used to trigger your 
QuicKeys Actions.

• Toolbars—The collection of QuicKeys buttons that enable 
you to simply point and click to open files or folders, 
trigger Actions, or display QuicKeys Action menus.

• Timed triggers—The specific date/time, time of day, or 
repeating interval when QuicKeys Actions are 
automatically triggered.

• QuicKeys menu—The menu that appears when you right-
click the QuicKeys icon in the taskbar. Trigger Actions by 
selecting them from the QuicKeys menu.

• QuickReference Card—Launch the QuickReference Card 
and click an Action listed in the QuickReference Card 
window.

• Shortcut on desktop—Drag-and-drop an Action to the 
desktop or Start menu to create a Windows shortcut to the 
Action. This option is useful for Actions you use 
frequently. See Figure 21 for an illustration of a desktop 
shortcut.

You can set your triggers in the various 
Properties dialog or in the Triggers page

URE 21: A Windows shortcut to a QuicKeys Sequence

FIGURE 22: Specify QuicKeys triggers in the Act
the Setup Wizard.
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FIGURE

 upper part of the 
GING QUICKEYS
 section discusses standard procedures, such as printing 
 saving QuicKeys Actions. It also provides information on 
ing individual Actions on and off, resolving hot key 
icts, and importing/exporting Actions.

ING ACTIONS
u want to print a list of your Actions, select Print from the 
enu. The same Action list is printed regardless of which 

cKeys Editor tab is in the foreground. The following 
rmation is printed:

ction names

ction descriptions

ot keys assigned to Actions

hether or not Actions are displayed in the QuicKeys 
enu.

ING ACTIONS
ename an Action, open the QuicKeys Editor and select the 
on you want to rename. Click the Action name a second 
 to display a blinking text cursor. Then, make your 
ges to the Action name and press the Enter key.

SAVING ACTIONS
Your Actions are automatically saved whene
Finish in the Setup Wizard or click OK in the A
dialog. However, if you create a Sequence, yo
to save your changes to the Sequence.

CLEARING HOT KEYS
When you no longer want a hot key assigned
click the Clear hot key button in the Action Prop

Do not try to clear your hot keys with the Del
keys because QuicKeys will begin to use tho
triggers.

ENABLING/DISABLING ACTIONS
If you find that you do not have a need for so
installed with QuicKeys, you can turn those 
they no longer display in the QuicKeys Edito
you use a PC that does not have a sound card
use your CD-ROM drive for audio CDs, you
need any of the multimedia Actions, such as
Audio Volume.

To enable/disable Actions:

1. Select View>Plug-ins.

 23: The File menu

FIGURE 24: The Clear hot key button is located in the
Action Properties dialog
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FIG
Act
2. In the QuicKeys Plug-in Manager dialog, click the + and - 
icons to expand and collapse the various Action categories.

3. Select the Actions or Action categories you no longer wish 
to view and click the Disable button.

4. Click Close when you are finished.

5. Look at the My Actions tab of the QuicKeys Editor. The 
Actions you turned off in the Plug-in Manager are no 
longer displayed.

SOLVING HOT KEY CONFLICTS
Hot key conflicts occur when a hot key in one Action Set 
conflicts with a hot key in another set or a hot key that is built 
into another program. For example, let’s say the F5 hot key is 
assigned to two Actions. One hot key opens Photoshop and is 
universal in scope. The other hot key changes the layout of a 
document and can only be triggered in a specific database 
program. What happens when you press F5?

QuicKeys follows rules of priority to res
When the same hot key is used for sever
resulting Action depends upon where th
following hierarchy:

A. Program-specific hot keys
B. Universal hot keys
C. Hot keys defined by a parti

Applying this information to the above 
database program is open, F5 formats a d
the database program is not the active p
Photoshop.

If you don’t want to change assigned ho
conflicts, you can either use the QuicKey
your hot keys on/off for a brief period o
substitute QuicKeys hot keys for the hot
into the programs you use.

Enable/Disable Hot Keys
If hot key conflicts only occur in program
infrequently, the best way to avoid them
QuicKeys hot keys on and off using the 
Action. This feature enables you to briefl
hot key while you work in a program th
keys. When you are finished working in
turn QuicKeys hot keys back on.

For example, you may want to disable Q
while working in Microsoft® Excel™ if Ex
insert cells, but you have directed QuicK
change selected text to italics.

URE 25: Use the Plug-in Manager to enable or disable plug-ins and 
ions.
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 easiest way to enable or disable hot keys is by using the 
cKeys Controller Action Menu button that was 
matically placed on your QuicKeys toolbar when you 

alled QuicKeys. However, if you edited the toolbar and 
 button is no longer available to you, use the following 
ructions to set up this Action.

urn QuicKeys hot keys on and off using the Setup 
ard:

tart QuicKeys.

elect the Setup Wizards tab.

lick the QuicKeys Controller button.

ead the introduction page and click Next.

5. Select Create a new Action and click Next.

6. Select Set status of QuicKeys and click Next.

7. Select Toggle status and click Next.

8. A name is automatically assigned to the A
use the assigned Action name or type a di

9. Select the Assign hot key check box and click

10.Click in the Hot key box and press the F11 k

11. Click Next.

12.Click Finish.

Now simply press F11 to turn QuicKeys hot k

 26: You can disable hot keys and timers from the QuicKeys 
er Action menu located in your QuicKeys toolbar.

FIGURE 27: The Setup Wizard for QuicKeys Controlle
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Reassigning Built-in Program Hot Keys
If hot key conflicts occur in programs you use on a daily basis, 
you need to change either the hot keys QuicKeys assigned or 
the hot keys (or shortcuts) your programs use. You can change 
your QuicKeys hot keys simply by going through the 
QuicKeys Setup Wizard and pressing a different hot key when 
you see the wizard page with the Hot key field. To change 
your built-in program hot keys, you can use the Type 
Keystroke Action. For information on using the Type 
Keystroke Action, see page 115.

PORTING ACTION SETS
You can import Action Sets when you receive QuicKeys 
Action Sets from other QuicKeys users or when you want to 
use some of the Action sets installed with QuicKeys. When 
you import Actions, you import all the attributes originally 
assigned to the particular Actions. For example, you import 
the triggers, icons, and scope selections for the Actions. If the 
scope of the Action is invalid in the new environment, the 
scope is automatically reassigned to Universal.

To import your Action Set:

1. Select File>Import.

2. Navigate to the location of the Quickeys Action Set you 
want to import and select the file with the .qkx extension.

3. Click Open. The Action Set is imported into your collection 
of QuicKeys Actions. Look in the My Actions tab to view 
them.

❖ You can also double-click a .qkx file to import it into 
your collection of QuicKeys Actions.

Importing Duplicate Hot Keys
If you import QuicKeys Actions that use
assigned to existing Actions, the dialog i

Import new Actions without hot key as
Unassigns hot keys for imported Action
key triggers. Imported Actions that do n
keys retain their hot key trigger after im

Import new Actions and unassign exist
triggers—Unassigns existing hot keys so
can use them. All imported Actions reta
while Actions that already exist in the M
stripped of their hot key assignments.

Cancel the import of new Actions—Sto
Actions.

FIGURE 28: The QuicKeys Import dialog appears
duplicate hot keys as it imports new Actions.
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Action names to 
TING ACTION SETS
 can export Action Sets when you want to share your 
cKeys Actions with other QuicKeys users or when you 
t to back up your Actions. When the Setup Wizard tab is 
layed, you can export all of your QuicKeys Actions. If any 
e other tabs are displayed, only selected Actions are 
rted. When you export Actions, all attributes are 
rted. These attributes include the triggers, icons, and 
e assignments for the Actions being exported. 

xport your Action Set:

elect the Actions you want to export.

elect Export or Export Selection from the File menu.

hoose where you want to save the exported file and click 
ave. Your Action Set is saved to the location you specified.

❖ QuicKeys 2.0 Actions Sets are not compatible with 
QuicKeys 1.0.

OMIZING QUICKEYS
re are several different ways to customize QuicKeys. For 

ple, you can choose whether or not the introduction 
e appears in the Setup Wizard and what type of view you 
in the My Actions tab. You can also resize a QuicKeys 
ting toolbar by clicking a corner of the toolbar and 
ging it so it appears as a single, double, or triple-column 

bar. It’s completely up to you.

NG QUICKEYS OPTIONS

 can customize what you see when you run QuicKeys in 
ptions dialog. Click Options on the View menu to view the 

ions dialog. You choices include:

Keyboard Layout—Chooses the keyboard la
similar to the keyboard you use. You can cho
standard or laptop layout. 

Show icon in taskbar—Displays the QuicKe
taskbar. You can right-click the QuicKeys ico
QuicKeys menu.

You can disable this option if you do not wan
Actions from the QuicKeys menu. When this
cleared, the Option dialog’s Show hot keys in Qu
box is dimmed.

Show hot keys in QuicKeys Menu—Display
assigned to your Actions in the QuicKeys me
taskbar must be selected for this option to be av
want to disable this option if you only want 
display in the QuicKeys menu.

FIGURE 29: The Options dialog
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ith a click of your 

FIG

mized and maximized

t 
nce step

Sequence 
Show Setup Wizard introduction page—Displays the 
introduction page in the Setup Wizards whenever you create 
or modify an Action from the Setup Wizards tab. When you 
become familiar with what each Action does, you may want 
to disable this option to go through the Setup Wizard more 
quickly.

Always use Setup Wizards for editing—Displays a Setup 
Wizard each time you modify an Action. When this check box 
is cleared and you attempt to modify an Action from the My 
Actions tab, the Action Properties dialog appears rather than a 
Setup Wizard. Clear this option if you are an advanced 
QuicKeys user and you do not want to use wizards.

Show sequence recording toolbar—Dis
recording toolbar after you select the Sta
you can control recording with a click of

Show sequence playback toolbar—Dis
toolbar when you are running a Sequen
the playback of a QuicKeys Sequence w
mouse.

URE 30: The Setup Wizard introduction page

FIGURE 31: The Recording toolbar

FIGURE 32: The Playback toolbar when it is mini

Pause Stop Cancel

PauseCancel

Curren
Seque

Open 
Editor

Collapse/
expand toolbar
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FIGURE
ING TOOLBARS
 can resize toolbars by clicking on a corner of the toolbar 
 dragging it until it appears as a long, single-row toolbar 
 short, multi-row toolbar.

ING INFORMATION
 can choose how you want to sort information in the 
rent QuicKeys dialogs by clicking a column header.

GING VIEWS IN THE MY ACTIONS TAB
 can view the My Actions tab in any of the views available in 
View menu. You can choose from the following views:

G ONLINE HELP
 can access QuicKeys Help from the Help menu, from the 
cKeys menu, by pressing F1, or by clicking the Help button. 
 Help system allows you to browse or search topics using 
Contents, Index, or Find tabs. Use the Contents and Index tabs as 
 would use the table of contents or index in a standard 
ual. Use the Find tab as you would use the Find feature in 
ndard software product.

The Help system installed with QuicKeys is d
printed manual in that it is written to answer
questions you may have as you use the QuicK
contrast, this printed manual is written to tea
QuicKeys using detailed explanations and ex

YOUR FIRST ACTION
By now you’ve probably completed the Quic
you have already created some Actions. How
takes you through your first Action from beg
as you would set up Actions without the Qui
In the following instructions, you create an A
Notepad with a hot key.

HOW TO SET UP AND USE A QUICKEY

1. Right-click the QuicKeys menu in the task
Open QuicKeys Editor.

2. In the Setup Wizards tab, select the Open butto

 33: You can resize toolbars to the dimensions you prefer.

• Large Icons • Small Icons
• List • Details
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 that offers the Create/

 Next.

 Next.

n page and click Next.
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uicKeys Controller
t Audio Volume
ial-Up Networking
stem Specials

ip Files
uick Type
3. Read the introduction page and click Next.

4. In the Setup Wizard, select Create a new Action and click Next.

5. Select Program and click Next.

6. Select Notepad from the program list and click Next. (Notepad 
is a program installed with the Windows operating 
system.)

7. Type a name for the new Action if you do not want to use 
the default name, Notepad.

8. Select the Assign hot key box and click Next.

9. Press the F7 key and click Next.

10.Click Finish.

11. Press F7. The Notepad program should start. Remember 
this hot key trigger so you can use it whenever you want to 
open Notepad. See “Triggering Actions” on page 25 for 
more information on hot keys and other triggers.

Setting Up Multiple Actions
If you don’t want to go through the Setu
different Actions, you can create all 5 Ac
using the Create/edit multiple Actions option. 
Actions option is available for the followin

To create multiple Actions simultaneou

1. Select an Action in the Setup Wizards tab
edit multiple Actions option.

2. Read the Introduction page and click

3. Select Create/edit multiple Actions and click

4. Read the Multiple Action Introductio

URE 34: The Wizard introduction page appears whenever you create 
dit an Action. If you do not want the introduction page to display, 
ct the “Don’t show Wizard introduction pages” check box.

• Advanced Text Tools • C
• Folders • C
• Instant E-mail • O
• QuicKeys Clipbook • Q
• Screen Settings • Se
• Type Date/Time • D
• File Handler • Sy
• Window Handler • Z
• Screen Saver • Q
• Screen Capture
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FIGURE
Edit Mu

ember your hot 
elect the check box for each Action you wish to create.

hoose whether you want to trigger the Actions using hot 
eys or the QuicKeys menu. If you want to use a hot key, 
osition your cursor in the Hot key column and press a hot 
ey. If you want to use the QuicKeys Menu, click the Menu 
olumn.

TING MULTIPLE ACTIONS
 can delete multiple Actions simultaneously from the 
cKeys Editor My Actions tab. Just Ctrl+click the Actions you 
t to delete and then right-click the selected Actions. Select 
e from the context menu that appears.

USING THE QUICKREFERENCE 
The QuickReference Card is a window that d
QuicKeys Actions and corresponding hot ke
purpose is to jog your memory if you forget 
performs which Action. You can launch Actio
them in the QuickReference Card, or you can
QuickReference Card to view the Actions an
have created.

By default, QuicKeys uses the Shift+Ctrl+Space 
the QuickReference Card. When triggered, th
QuickReference Card opens to the tab repres
the most restrictive scope. For example, if Fil
when you press Shift+Ctrl+Space, the Actions sc
FileMaker appear in the frontmost QuickRef
If there are no Actions scoped to FileMaker, t
frontmost.

 35: A dialog similar to this one appears when you click Create/
ltiple Actions in the Setup Wizard.

FIGURE 36: Use the QuickReference Card to help rem
keys.



35• • • •
EX

FIG
Qu
task
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When you want to close the QuicKeys Editor, simply click the 
QuicKeys Editor close box or select Exit from the File menu. 
However, if you select Exit QuicKeys from the QuicKeys menu, 
the QuicKeys Engine is turned off. To turn it back on again, 
you must click the Windows Start menu and select QuicKeys 
from the Programs submenu.

URE 37: By default, you can exit the QuicKeys program from the 
icKeys menu. The QuicKeys menu is located in the status area of the 
bar.
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 •
KEYS TOOLBARS

e programs contain toolbars that allow you to cut, copy, 
 paste selected items just by clicking the corresponding 
s. Similarly, QuicKeys offers toolbars which allow you to 
t Quickeys Actions by clicking a QuicKeys toolbar button. 

g toolbars is beneficial if you want quick and convenient 
ss to specific Actions without having to remember the hot 

 that triggers them. In fact you can place all of your 
cKeys Actions on toolbars if you are visually-oriented. You 
 even choose to Auto-hide your toolbars to preserve space 
our screen. And, if you find the program toolbars you use 
 daily basis a bit limited in their functionality, supplement 
r program toolbars with QuicKeys toolbars. The way you 
p and use your QuicKeys toolbars is completely 

endent upon you and the way you work.

cKeys toolbars have two components: the toolbar itself 
 the buttons on the toolbar. The Toolbar Setup Wizard 
es you through creating both components, so setting up 

r toolbars is relatively easy.

BAR STYLES
re are four toolbar styles available for QuicKeys toolbars: 

Click-N-Go

Dockable

Floating

Pop Out

 section discusses each toolbar style and provides 
ples of when to use one style over another.

CLICK-N-GO
A Click-N-Go toolbar closes immediately aft
button on the toolbar. This type of toolbar is 
want to preserve screen real estate. For exam
want to memorize which Action starts one of
installed on your computer, you can create a
toolbar that enables you to start each of these
clicking the appropriate program button on t
you have to remember is the hot key that ope
Go toolbar or select the toolbar from the Qui
can then click the appropriate program icon 
and watch as the toolbar disappears just as th
program opens.

Sizing Click-N-Go Toolbars
You can size Click-N-Go toolbars by clicking
edge of the toolbar and dragging when the c
double-sided arrow. If some buttons are not 
size the toolbar, the toolbar frame becomes a

FIGURE 38: The Click-N-Go toolbar disappears as soo
of its buttons.
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screen th
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ABLE
ockable toolbar attaches to an entire side of your screen. 
 type of toolbar is useful when you want to keep your 
bar in the same position whenever you start a specific 
ram. For example, if you have several Actions for 

rosoft Word, you can place them on a program-specific, 
kable toolbar so they are accessible whenever Microsoft 
d is open. See page 22 for more information on Action 
e or making Actions program-specific.

o-hide
 can choose to hide Dockable toolbars by selecting the 
-hide check box in the Toolbars Setup Wizard or Action 

erties dialog. When Auto-hide is selected, the Dockable 
bar is hidden from view until your cursor is placed near 
side of the screen where the toolbar is located.

Each side of your screen supports one Docka
uses the Auto-hide feature. By default, Dock
dock to the top of your screen. Consequently
create a second Dockable/Auto-hide toolbar
your first Dockable/Auto-hide toolbar to a d
your screen, you get the error message show

Moving Dockable Toolbars
You can drag Dockable toolbars from one sid
to another. If you drag Dockable toolbars aw
of the screen, they become Floating toolbars.

FLOATING
A Floating toolbar can be moved anywhere o
This type of toolbar is useful when your proj
working in several different programs simul
benefit of using a Floating toolbar in this typ
that your Actions are only a click away.

 39: This Dockable toolbar is anchored to the same side of the 
at contains the taskbar. You can drag Dockable toolbars to any 
our screen.

FIGURE 40: This error appears when you attempt to p
Auto-hide Dockable toolbar on the same side of your s
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For example if you are creating an advertisement for your 
company picnic, you can have a Universal, Floating toolbar 
with buttons that start PageMaker, open a specific project 
folder on your hard drive, change the view of the pamphlet to 
75%, and save your work.

Moving Floating Toolbars
You can move Floating toolbars anywhere on your screen. 
However, if you move them near the side of your screen they 
become Dockable toolbars.

Sizing Floating Toolbars
You can size Floating toolbars by clicking on the corner or 
edge of the toolbar and dragging. You can make Floating 
toolbars as big or as small as you want. You can even size 
them so your toolbar buttons appear in multiple rows. If some 
buttons are not visible after you size the toolbar, the toolbar 
frame becomes a dotted line.

POP OUT
A Pop Out toolbar enables you to save o
by popping out from the side of the scre
mouse moves near the toolbar. Unlike A
multiple Pop Out toolbars can be placed
the screen. When you click a button on a
toolbar retreats back to the side of the sc
interfere with your work. See Figure 42.

❖ To hide the title of a Pop Out t
toolbar and select Hide Toolbar T

Moving Pop Out Toolbars
You can move Pop Out toolbars anywhe
clicking and dragging on the empty area

URE 41: This Floating toolbar displays anywhere you drag it. Floating 
lbars are the only type of QuicKeys toolbar that contain a title bar and 
se box.

FIGURE 42: Three Pop Out toolbars on the right 
desktop
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 the Name box. 
start programs, 

nd click Next.

pears to help you 

t.

 want to add to 

tion you want to 

tion Menu you 

. The Toolbar 

te.
ing Pop Out Toolbars
 can size Pop Out toolbars by clicking on the corner or 
e of the toolbar and dragging when the cursor becomes a 
ble-sided arrow. If some buttons are not visible after you 
 the toolbar, the toolbar frame becomes a dotted line.

TING TOOLBARS
 can choose whether or not to use the Setup Wizard to 
st you in creating your QuicKeys Toolbars. If you are a 
cKeys beginner, CE Software recommends using the Setup 
ard because it explains each of your options. If you are 
ady familiar with the available toolbar options, use the 
on Properties dialog. You can open the Action Properties 
og by selecting Create>QuicKeys Tools>Toolbar.

 THE SETUP WIZARD

reate a toolbar using the Setup Wizard:

elect the Toolbar button in the Setup Wizards tab.

ead the introduction page and click Next.

elect Create a new Action and click Next.

elect Floating, Dockable, Click-N-Go, or Pop Out and click Next.

5. Select Small or Large and click Next.

6. Type a descriptive name for this toolbar in
For example, if the buttons in the toolbar 
name the toolbar “Programs.”

7. Select the Place in QuicKeys menu check box a

8. Click Finish. The Toolbar Button Wizard ap
add buttons to your toolbar.

9. Read the introduction screen and click Nex

10.Select the check box for each program you
the toolbar and click Next.

11. Select the check box for each QuicKeys Ac
add to the toolbar and click Next.

12.Select the check box for each QuicKeys Ac
want to add to the toolbar and click Next.

13.Read the final wizard page and click Finish
Button Wizard appears. 

FIGURE 43: Select the type of toolbar you want to crea
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❖ See “Adding Buttons to Toolbars” on page 42 for 
more information on toolbar buttons.

ING THE ACTION PROPERTIES DIALOG

To create a toolbar without the Setup Wizard:

1. Select the View>Options.

2. Clear the check box to Always show Setup Wizards for editing and 
click OK.

3. Select the My Toolbars tab.

4. Right-click anywhere on the Toolbars pane and select New 
Toolbar from the context menu that appears.

5. In the Action Properties dialog that a
toolbar style you want to use. The too
defined on page 37.

6. Click the Auto-hide check box if you wa
Dockable toolbar that hides when the
from it.

7. Select the toolbar button size.

8. Type a name for the toolbar in the Nam

9. If you want to choose a hot key to tri
on the Hot key box and press the keys y
example, press the Shift key, the Contro
simultaneously.

10.Click OK when you are finished. The T
appears. See page 42 for more inform

URE 44: The My Toolbars tab

FIGURE 45: You can change the properties of you
Properties dialog.
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NG BUTTONS TO TOOLBARS
 can add buttons to your toolbar by using the Toolbar 
on Wizard or by dragging-and-dropping items to your 
bar. 

 THE TOOLBAR BUTTON WIZARD
 can open the Toolbar Button Wizard using one of three 
hods:

Right-click a toolbar or toolbar button listed in the My 
Toolbars tab and select Toolbar Button Wizard.

Right-click anywhere in the Toolbars pane of the My Toolbars 
tab. When you complete the Action Properties dialog and 
press OK, the Toolbar Button Wizard automatically 
appears.

Right-click an existing toolbar and select Toolbar Button 
Wizard.

 Toolbar Button Wizard appears after you create a toolbar.

ead the introduction page of the Toolbar Button Wizard 
nd click Next.

elect the check box for each program you would like to 
isplay in your toolbar.

3. Click Next.

4. Select the check box for each QuicKeys Ac
like to display on your toolbar. If you hav
QuicKeys Actions, there are no items liste
the wizard.

5. Click Next.

6. Select the check box for each QuicKeys Ac
would like to display on your toolbar. See
information on Action Menu buttons.

7. Click Next.

8. Read the final wizard page and click Finish

Your buttons now display on the toolbar.

FIGURE 46: The Toolbar Button Wizard
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ING DRAG-AND-DROP FUNCTIONALITY
An easy way to add a button to a toolbar is to select a file or 
QuicKeys Action and drag it to an existing toolbar. Drag-and-
drop functionality only works for Open File and QuicKeys 
Action buttons. It does not work for QuicKeys Action Menu 
buttons. Some examples of when you would want to drag-
and-drop items to toolbars include:

•  Drag your weekly report from your My Documents folder 
to a QuicKeys toolbar, so you can simply click a toolbar 
button next time you need to open it rather than 
navigating through countless directories.

•  If you have a File Handler Action on your toolbar that 
changes the file extension to .doc, you can drag a .txt file to 
the File Handler button to quickly change the file extension.

•  Create an Microsoft Word “Open” button. Drag files to 
this button to open documents in Microsoft Word.

PES OF TOOLBAR BUTTONS
When you create a QuicKeys toolbar, you can choose from 
three different types of toolbar buttons: Open File buttons, 
QuicKeys Action buttons, or Action Menu buttons.

OPEN FILE BUTTONS
Use Open File buttons to open any file y
example, you can create an Open File bu
Acrobat Reader. Open File buttons adop
you have chosen to open.

To add an Open File button to your too

1. Right-click an empty area in a toolba
on your desktop.

2. Select Open File from the New Button sub

3. Select the file you want to open from 
Open.

The toolbar displays the new Open File 

URE 47: In this example, you can see what each type of toolbar button 
ks like. An Open File button uses the icon of the file it opens, a 
icKeys Action button uses the icon of the QuicKeys Action it opens, 
 an Action Menu button uses the icon of the QuicKeys Action it opens 

ng with a drop-down arrow.

Open File 
button that 
opens the 
Acrobat Reader 
program

QuicKeys Action 
button that performs 
a specific QuicKeys 
Controller Action

Action Menu button 
that displays the 
options available in 
the Advanced Text 
Tools Action when 
you click the list 
arrow

FIGURE 48: Right-click an area of an open toolba
toolbar button to view this menu.



44 Chapter 4
QuicKeys Toolbars

• • • •

QUICK
Use
hav
Qui
butt

To a

1. R
o

2. S
a

3. S
A
d

4. C

The

ctions on a 
s Action Menu 
ons from a single 
icKeys Clipbook 
l see a list of 
also choose 
t Actions menus. 

ction Menu 

ction is 
n toolbars. It 
method for 
Windows tray is 

FIGURE
toolbar b
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EYS ACTION BUTTONS
 QuicKeys Action buttons to trigger QuicKeys Actions you 
e already created. For example, if you have created a 
cKeys Action that reformats selected text, you can put a 
on that triggers that Action on the toolbar.

dd a QuicKeys Action button to your toolbar:

ight-click an empty area in a toolbar that is already open 
n your desktop.

elect QuicKeys Action from the New Button submenu that 
ppears.

elect an Action from the Add Action to Toolbar window. The 
ctions in this window are taken from the Action list 
isplayed in the My Actions tab of the QuicKeys Editor.

lick OK when you have selected the Action.

 toolbar displays the new QuicKeys Action button. 

ACTION MENU BUTTONS
Use Action Menu buttons to place special fun
toolbar drop-down menu. QuicKeys provide
buttons so you can access a set of related Acti
toolbar button. For example, if you add a Qu
Action Menu button to your toolbar, you wil
Clipbook Actions when you click it. You can 
options from the Defined Actions and Recen

❖ Some Actions are not available as A
buttons. 

Tip for laptop users: The Window Selector A
especially useful as an Action Menu button o
provides laptop users with a quick and easy 
switching between open windows when the 
full.

 49: Right-click an area of an open toolbar that does not contain a 
utton to view this menu.

FIGURE 50: Toolbar Action Menus provide shortcuts t
Actions.
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To add an Action Menu button to your toolbar:

1. Right-click an empty area on a toolbar that is already open 
on your desktop.

2. Select Action Menu from the New Button submenu that appears.

3. Select an Action from the Add Menu to Toolbar window and 
click OK.

The toolbar displays the new Action Menu button. 

SPLAYING TOOLBARS
You can display, or trigger, toolbars using one of the following 
methods:

•  Press the hot key you assigned to it.

•  Open the QuicKeys menu and select it from the Toolbars 
submenu.

•  Right-click a QuicKeys toolbar in the
select Show Toolbar in the context men

•  Direct the toolbar to display at a cert
Timed Triggers tab in the Action Proper

•  Create a button on one of your toolba
toolbar.

EDITING TOOLBARS
You can edit a toolbar by right-clicking i
the options that appears in the context m
empty area of the toolbar to edit the tool
toolbar button to edit the toolbar button.

You can also edit toolbars by changing t
size, toolbar button order, and toolbar sc

URE 51: Right-click an area of an open toolbar that does not contain a 
lbar button to view this menu.

FIGURE 52: Right-click a toolbar in the My Toolb
menu.
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Posi
poin
you

ar by holding 
rea of the toolbar 
t to move an 
ey as you drag 

toolbar. For 
oolbar displays 
ms. You can 
Wizards tab, the 
nctionality.

 to toolbars that 
lbar buttons. For 
ting a Microsoft 
lbar that only 

ope, select the 
e pages of each 
 the beginning of 
tions to Create an 
ultiple Actions. The 
ithin the Setup 
GING THE TOOLBAR STYLE

Change Dockable toolbars to Floating toolbars by 
dragging the Dockable toolbar from the edge of the 
screen.

Change Floating toolbars to Dockable toolbars by 
dragging the Floating toolbar to the edge of the screen.

Change Floating toolbars to Click-N-Go toolbars by 
selecting the Toolbars button in the Setup Wizards tab and 
selecting Edit an Action in the appropriate wizard page. 
Change the selection from Floating to Click-N-Go and 
continue through the wizard until you are finished 
making changes.

Change Dockable toolbars to Click-N-Go toolbars by 
selecting the Toolbars button in the Setup Wizards tab and 
selecting Edit an Action in the appropriate wizard page. 
Change the selection from Dockable to Click-N-Go and 
continue through the wizard until you are finished 
making changes.

Change Floating toolbars to Pop Out toolbars by selecting 
the Toolbars button in the Setup Wizards tab and selecting Edit 
an Action in the appropriate wizard page. Change the 
selection from Floating to Pop Out and continue through the 
wizard until you are finished making changes

TING TOOLBAR SIZE
tion your cursor on the edge of the toolbar until the 
ter becomes a sizing arrow. Drag the toolbar to the size 

 prefer using the sizing arrow.

❖ You cannot size Dockable toolbars.

REARRANGING TOOLBAR BUTTONS
You can rearrange toolbar buttons on a toolb
down the Alt key and dragging them to the a
where you want them displayed. If you wan
Action menu button, you must press the Alt k
the button.

CHANGING TOOLBAR SCOPE
Toolbar Scope is the range of operation for a 
example, you can choose whether a specific t
in only one program, or in all of your progra
change the scope of a toolbar using the Setup 
Action Properties dialog or drag-and-drop fu

❖ It is possible to add toolbar buttons
have a different scope than the too
example, a toolbar button represen
Word Action can be added to a too
works in Internet Explorer.

Using the Setup Wizard
To use the Setup Wizard to change toolbar sc
Toolbars button in the Setup Wizards tab. Read th
wizard dialog and follow the instructions. At
the Setup Wizard, you are presented with op
Action, Edit an Action, Delete an Action, or Create/edit m
setup for each of these options is explained w
Wizard.
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n Action to it.

FIG
Set
Using the Action Properties Dialog
The following instructions assume you have the Always use Setup 
Wizards for editing check box cleared in the Options dialog. See 
page 30 for more information.

To change the scope of a toolbar using the Action Properties 
dialog:

1. Click the My Toolbars tab in the QuicKeys Editor.

2. Right-click one of the toolbars listed on the Toolbars pane.

3. Select Properties from the context menu that appears.

4. In the Action Properties dialog, click the Action Scope tab.

5. In the Scope drop-down list, choose w
toolbar to display. See page 22 for mo
information on Action Scope.

6. Click OK when you are finished.

Using Drag-and-Drop Functional
You can change Action scope by draggin
Scope tab to another in the My Keyboard, M
tabs. For drag-and-drop functionality to
Scope tabs must already be created. For 
to change your Reformat Text Action fro
to a Microsoft Word Action, Microsoft W
specified as a program-specific Scope op
the tab has to exist before you can drag a

URE 53: This dialog appears when you click the Toolbars button in the 
up Wizards tab and choose to create or edit a Toolbars Action.

FIGURE 54: The Action Scope tab
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isappears.

e the Toolbar
ING TOOLBARS
re are a variety of methods for closing QuicKeys toolbars, 
ending on the toolbar’s style.

ar Style How to Close the Toolbar

le • Use the Auto-hide feature to 
temporarily hide the toolbar.

• Right-click the toolbar in the My 
Toolbars tab and select Hide 
Toolbar from the context menu 
that appears.

• Right-click the QuicKeys menu in 
the status area of the taskbar and 
select the toolbar from the 
Toolbars submenu. The 
checkmark that was next to the 
toolbar name disappears.

• Click the close box in the title bar 
of the toolbar.

• Right-click the toolbar in the My 
Toolbars tab and select Hide 
Toolbar from the context menu 
that appears.

• Right-click the QuicKeys menu in 
the status area of the taskbar and 
select the toolbar from the 
Toolbars submenu. The 
checkmark that was next to the 
toolbar name disappears.

Click-N-Go • Right-click the
Toolbars tab an
Toolbar from th
that appears.

• Right-click the
the status area
select the toolb
Toolbars subme
checkmark tha
toolbar name d

• Click outside t
toolbar.

Pop Out • Right-click the
Toolbars tab an
Toolbar from th
that appears.

• Right-click the
the status area
select the toolb
Toolbars subme
checkmark tha
toolbar name d

Toolbar Style How to Clos
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LETING TOOLBARS
There are three methods for deleting toolbars:

•  Right-click a toolbar and select Delete from the context 
menu that appears.

•  Select the Toolbar button in the Setup Wizards tab and choose 
to Delete an Action on the appropriate Setup Wizard page.

•  Select a QuicKeys toolbar listed in the My Toolbars tab and 
select Delete Toolbar from the Edit menu.

EDITING TOOLBAR BUTTONS
Use the Toolbar Button Wizard if you w
through the process of adding buttons to
can add one button at a time or add seve
simultaneously.

To add a single button to your toolbar:

1. Right-click an area of the open toolba
a toolbar button.

2. Select Open File from the New Button sub

3. Navigate through your directories un
you want to open from your toolbar. 
file, click Open. The file automatically 
toolbar.

To add multiple buttons to your toolba

1. Right-click anywhere on an open too

2. Select Toolbar Button Wizard from the con
appears.

3. Read the introduction page of the wiz
click Next.

URE 55: You can delete a toolbar from the QuicKeys Setup Wizard.
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FIGURE
elect the check box(es) for each program you would like 
o display in your toolbar.

lick Next.

elect the check box(es) for each QuicKeys Action you 
ould like to display in your toolbar. If you have not 

reated any QuicKeys Actions, no items are listed on this 
age.

lick Next.

elect the check box(es) for each QuicKeys Action menu 
ou would like to display on your toolbar 

lick Next.

ead the final wizard page and click Finish. The toolbar 
isplays with the additional buttons you specified.

ADJUSTING TOOLBAR BUTTON SIZE
To change the size of your toolbar buttons, ri
of an open toolbar that does not contain any 
Choose whether you want to use Small Buttons
from the context menu that appears.

CHANGING BUTTON ICONS
QuicKeys uses different button icons for each
example, Open File buttons use the icons of t
open, while QuicKeys Action buttons use the
QuicKeys Actions they trigger. If you want to
the button icons on your toolbar, you can sub
default icons with sample icons installed by Q
your own custom icons or bitmaps.

Using Icons Supplied with QuicKeys
QuicKeys installs several different sets of ico
your toolbars. These icons are located in the 
Files\CE Software\QuicKeys directory.

To select sample icons:

1. Right-click a button on an open toolbar.

2. Select Set icon from file.

3. Select an icon collection from the Icon File d
You can choose from workplace icons, mu
symbols, or Windows control icons. See th
information on using the Browse button in 
dialog.

 56: The Toolbar Button Wizard introduction page
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and click Open. The 
ppear in the Select Icon 

 file, it displays 
he Icon File drop-down 

FIG
Qu
4. Click the icon you want to use. The icon darkens when it is 
selected.

5. Click OK when you have selected the icon you want to use 
on your toolbar. The new icon appears on the button you 
selected.

Using Custom Icons
There are two types of custom icons: ico
computer programs (such *.exe files, *.d
icons you create. The following instructi
information on selecting any of these ico
toolbar buttons. For information on crea
add to your toolbar icon collection, see p

To select custom icons:

1. Right-click a button on an open toolb

2. Select Set icon from file.

3. Click the Browse button.

4. Navigate to the icon file you want to 

5. Choose the icon file you want to use 
contents of the icon file you selected a
window.

❖ Once you select a custom icon
permanently as an option on t
list.

URE 57: Choose an icon from one of the icon sets installed with 
icKeys.
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FIGURE
clicking 

ncher icon is 

lbar icons.
elect an icon from your new icon file and click OK. The 
ew icon appears on the toolbar you selected.

❖ If you delete, rename, or move custom icons that are 
used in toolbars, the toolbar button that used that 
icon displays the default icon.

Using Bitmap Images
Bitmap files use the .bmp file extension, and, u
they cannot be sized. They must use the same
were specified when the bitmap was origina
ability to add bitmaps to your toolbars enabl
from a wide variety of graphics for your tool
long as the graphic is proportional to your sc

To select a bitmap file:

1. Right-click a button on an open toolbar.

2. Select Set icon from bitmap.

3. Navigate to the bitmap graphic you want
graphic must use the .bmp extension in the

 58: The collection of icons shown in this graphic was selected by 
the Browse button and navigating to the EXPLORE.EXE file.

FIGURE 59: In this illustration, the QuicKeys Web Lau
replaced by a custom bitmap graphic.

FIGURE 60: Select a standard bitmap file to use as too
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sele
4. Choose the graphic you want to use and click Open.

The new icon appears on the toolbar you selected.

Restoring Icons
Just as many programs have the “Undo” function, QuicKeys 
offers the Restore default icon option. This feature allows you to 
go back to using the default toolbar button icon for the 
selected toolbar button. Just right-click a button on an open 
toolbar and select Restore default icon from the context menu that 
appears. This is extremely useful if you want to experiment 
with different icons because you can return to the default 
icons at any time.

LETING TOOLBAR BUTTONS
To delete a toolbar button, open the toolbar and right-click the 
toolbar button you want to delete. Select Delete Button from the 
context menu that appears. Select Yes at the Confirm Delete 
prompt. The button is deleted from the toolbar.

❖ If you delete all your Actions from the My Actions tab, 
the toolbar buttons that display QuicKeys Action 
menus remain available on the toolbar until each 
button is manually deleted or until the entire 
toolbar is deleted. 

URE 61: To delete a toolbar button, right-click the toolbar button and 
ct Delete Button from the menu that appears.
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TROLLING THE QUICKEYS PROGRAM

 QuicKeys Controller Action gives you special controls 
r the QuicKeys program. These controls, or Actions, allow 
 to use QuicKeys without interrupting your work. The 
ions at your disposal when you use the QuicKeys 
troller include:

 chapter provides information about each of these Actions 
ell as instructions for creating, editing, and deleting them.

KEYS CONTROLLER
 QuicKeys Controller Action is invaluable when you use 
cKeys on a daily basis. This Action automates the 
cKeys program so it works as smoothly as everything else 
 QuicKeys controls.

NG UP QUICKEYS CONTROLLER ACTIONS
re are two ways to create or edit QuicKeys Controller 
ions: use the Setup Wizard or use the Action Properties 
og. 

Using the Setup Wizard
To use the Setup Wizard, select the Setup Wizar
QuicKeys Editor and click the QuicKeys Control
the pages of each wizard dialog and follow t
At the beginning of the Setup Wizard, you ar
options to Create an Action, Edit an Action, Delete an 
multiple Actions. The setup for each of these opt
within the Setup Wizard.

Using the Action Properties Dialog
The Action Properties dialog enables you to 
options within a QuicKeys Action from a sin
capability provides an alternative for users w
use the Setup Wizard. 

• Open QuicKeys 
Editor

• Show QuickReference 
Card

• Enable hot keys and 
timers

• Disable hot keys and 
timers

• Toggle QuicKeys 
Status

• Start Recording 
[Sequences]

• Stop Recording 
[Sequences]

• Toggle Recording

• Exit QuicKeys

FIGURE 62: This dialog appears when you click the Q
button in the Setup Wizards tab and choose to create o
Controller Action.
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Actions 
 following instructions assume you have the Always use Setup 
rds for editing check box cleared in the Options dialog. See 
e 30 for more information.

se the Action Properties dialog to create or edit a 
cKeys Controller Action, follow these steps:

elect Create>QuicKeys Tools>QuicKeys Controller.

2. Choose an option from the Action-specific
of the dialog. The available options are di
next section of this chapter.

3. In the General tab of the Action Properties d
automatically assigned to the Action. You
assigned Action name or type a different 

4. If you want to choose a hot key to trigger
in the Hot key box and press the key(s) you
example, press the Alt key, the Control key, a
simultaneously.

5. Click OK. Your new Action immediately ap
Actions tab.

6. Close the QuicKeys Editor and press the h
selected. The Action-specific option you s
react immediately to the trigger.

QUICKEYS CONTROLLER OPTIONS
Below is a description of the Action-specific 
available with the QuicKeys Controller Actio

Open QuicKeys Editor—Opens the QuicKey

Show QuickReference Card—Displays the Q
Card. The QuickReference Card is useful whe
hot key for a specific Action and want to look
You can also click an Action listed in the Quic
to trigger it. Read more about the QuickRefe
page 34.

Set status of QuicKeys—Turns QuicKeys ho
or toggles between the on and off state.

Enable hot keys and timers—Turns Qu
and timers on.

Disable hot keys and timers—Turns Q
and timers off.

 63: The QuicKeys Controller Action Properties dialog appears 
u select the QuicKeys Controller Action from the Create menu, or 
u double-click an existing QuicKeys Controller Action in the My 
tab.
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Toggle status—Switches between QuicKeys being on 
and off.

Set recording status—Starts or stops recording, or uses the 
same trigger to toggle between the start or stop state.

Start recording—Starts recording a Sequence.

Start recording (disable smart recognition)—Starts 
recording a Sequence. You should only select this option 
if you are having difficulty using Sequences with a 
particular program. For example, if your Sequence 
cannot complete a Select Menu Action successfully, you 
may want to choose this type of recording. When smart 
recognition is disabled, Sequences are composed solely 
of Mouse Click, Window Select, Window Waits, Type 
Text, and Type Keystroke Actions.

Stop recording—Stops the recording process.

Toggle recording—Starts and stops recording.

Exit QuicKeys—Quits the QuicKeys Engine and the 
QuicKeys Editor.

LETING QUICKEYS CONTROLLER ACTIONS
To delete a QuicKeys Controller Action:

1. Select the My Actions tab in the QuicKeys Editor.

2. Right-click the Action you want to delete.

3. Select Delete from the context menu that appears.

4. Choose Yes at the Confirm Delete prompt. The Action is 
immediately cleared from the Actions list.
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NG WITH QUICKEYS

you ever get tired of typing the same lines of text in E-mail 
sages? Or do you routinely need to type special 

racters, such as an umlaut, into foreign correspondence? 
 probably guessed it—QuicKeys can take care of these 
res for you.

 QuicKeys Type Text, Type Date/Time, Advanced Text 
ls, and Special Characters Actions save you time by typing 
information you need with a QuicKeys trigger. This 
pter provides instructions for using these Actions to type 
, type the date and time in a specified format, insert 
bols and international characters in documents, reformat 
cted text, and much more.

G ADVANCED TEXT TOOLS
 Advanced Text Tools Action is useful when you want to 
ipulate blocks of text. For example, you can use this 

ion to eliminate those pesky quote marks from your E-mail 
sages before you forward the message to another person. 
 tasks, or Actions, available using the Advanced Text Tools 
ude:

NG UP ADVANCED TEXT TOOLS ACTIONS
re are two ways to create and edit QuicKeys Advanced 
t Tools Actions: use the Setup Wizard or use the Action 
perties dialog.

Using the Setup Wizard
To use the Setup Wizard, select the Setup Wizar
QuicKeys Editor and click the Advanced Text Too
the pages of each wizard dialog and follow t
At the beginning of the Setup Wizard, you ar
options to Create an Action, Edit an Action, Delete an 
multiple Actions. The setup for each of these opt
within the Setup Wizard.

• Reformat Text • Quote Text

• Strip Quote Marks • Uppercase

• Lowercase • Title Case

FIGURE 64: This dialog appears when you click the A
button in the Setup Wizards tab and choose to create o
Text Tools Action.
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Actions 
ng the Action Properties Dialog
 following instructions assume you have the Always use Setup 
rds for editing check box cleared in the Options dialog. See 
e 30 for more information.

se the Action Properties dialog to create or edit an 
anced Text Tools Action, follow these steps:

elect Create>Text Tools>Advanced Text Tools.

elect an Action from the Action drop-down list.

n the General tab of the Action Properties dialog, a name is 
utomatically assigned to the Action. You can use the 
ssigned Action name or type a different one.

4. If you want to choose a hot key to trigger
in the Hot key box and press the key(s) you
example, press the Alt key, the Control key a
simultaneously. 

❖ This Action is also a good candidat
Action Menu trigger. See page 44 f
information on Action Menu toolb

5. Click OK. Your new Action appears in the 

6. Close the QuicKeys Editor and open a wo
program. Select a block of text and press t
assigned to this Action. The block of text y
changes, depending on what type of text A

ADVANCED TEXT TOOLS OPTIONS
This section describes the Action-specific pro
with the Advanced Text Tools Action.

Reformat text—Removes carriage returns an
from selected text. This is especially useful fo
want to copy text from a Web page or an E-m

 65: The Advanced Text Tools Action Properties dialog appears 
u select the Advanced Text Tools Action from the Create menu, or 
u double-click an existing Advanced Text Tools Action in the My 
tab.
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s Action.
Quote text—Inserts a specified character at the beginning of 
each line of selected text. This option is useful when you want 
to forward a message from a client to your manager and you 
need to distinguish your comments from the customer’s 
comments.

Quote—The character you specify for the Quote Text option. 
You can specify up to eight characters in this field.

Characters per line—The number of consecutive 
characters the Quote Text option counts before inserting a 
carriage return.

Strip quote marks—Deletes the quote c
the beginning of each line of selected tex
useful when E-mail reply text needs to b
processing document.

Uppercase—Converts all selected text to
characters. For example, the sentence yo
look like this after selecting it and trigge
option: CONVERTS ALL SELECTED TE
CHARACTERS.

Lowercase—Converts all selected text to
characters. For example, the sentence yo
look like this after selecting it and trigge
option: converts all selected text to lowe

URE 66: The graphic on the left illustrates text copied from a Web 
e before it is reformatted. Notice the irregular line breaks. The graphic 

the right illustrates text copied from a Web page after it is reformatted. 
tice the irregular line breaks are gone.

FIGURE 67: The top graphic shows an E-mail mes
marks. The bottom graphic shows an E-mail mes
quote marks stripped using the Strip Quote Mark
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the Always use Setup 
s dialog. See 

uick Type button in 
uick Type Action.
e case—Converts all selected text to title case characters. 
example, the sentence you just read would look like this 
r selecting it and triggering the Title Case option: Converts 
Selected Text To Title Case Characters.

gle case—Converts lowercase text to uppercase text and 
 versa.

ING ADVANCED TEXT TOOLS ACTIONS
elete an Advanced Text Tools Action:

elect the My Actions tab in the QuicKeys Editor.

ight-click the Action you want to delete.

elect Delete from the context menu that appears.

hoose Yes at the Confirm Delete prompt. The Action is cleared 
rom the Actions list.

G QUICK TYPE
 Quick Type, you can specify typed abbreviations for 
 words, names, or phrases up to 10 KB. All you need to do 
ild a glossary of the words you use and then choose 

ch abbreviations you want to use for them. When a 
acter key is followed by a tab, space, or return key, the 
acter represented by the key is replaced by the word or 
e you specified in the Quick Type Action. For example, 

 could type Q+space and the words “CE Software, Inc.” 
ld be typed into your document.

❖ If you accidentally type the wrong Quick Type 
abbreviation, you can cancel the Action by pressing 
Ctrl+Esc.

❖ For best performance, limit Quick Type text to 2 KB.

SETTING UP QUICK TYPE ACTIONS
There are two ways to create and edit QuicK
Actions: use the Setup Wizard or use the Act
dialog.

Using the Setup Wizard
To use the Setup Wizard, select the Setup Wizar
QuicKeys Editor and click the Quick Type butto
pages of each wizard dialog and follow the i
the beginning of the Setup Wizard, you are p
options to Create an Action, Edit an Action, Delete an 
multiple Actions. The setup for each of these opt
within the Setup Wizard.

Using the Action Properties Dialog
The following instructions assume you have 
Wizards for editing check box cleared in the Option
page 30 for more information.

FIGURE 68: This dialog appears when you click the Q
the Setup Wizards tab and choose to create or edit a Q
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To use the Action Properties dialog to create or edit a Quick 
Type Action, follow these steps:

1. Select Create>Text Tools>Quick Type.

2. Select an Action from the Action drop-down list.

3. In the General tab of the Action Properties dialog, a name is 
automatically assigned to the Action. You can use the 
assigned Action name or type a different one.

4. Assign a trigger to the Action.

5. Click OK. Your new Action appears in the My Actions tab.

6. Close the QuicKeys Editor.

ICK TYPE OPTIONS
This section describes the Action-specific properties available 
with the Quick Type Action.

Enable Quick Type—Turns on Quick Ty
When QuickType is enabled, the Quick 
the Tray. Right-click the Quick Type icon
the Quick Type menu.

Disable Quick Type—Turns off Quick T

Toggle Quick Type—Alternately enable
Type functionality.

Edit Quick Type glossary—Opens the Q
window shown in Figure 70.

The Quick Type Glossary
The Quick Type glossary contains all the
names you want to type when you trigg
Action. 

To add text to your glossary:

1. Click the Edit glossary button in the Qui
or Action Properties dialog. (See Figu

2. In the Quick Type Glossary window, 

URE 69: The Quick Type Action Properties dialog appears when you 
ct the Quick Type Action from the Create menu, or when you double-
k an existing Quick Type Action in the My Actions tab.

FIGURE 70: The Quick Type Glossary window
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the Always use Setup 
s dialog. See 
ialog.

FIGURE

heck Spelling 
r edit a Check 
n the Edit Glossary Entry dialog, specify the text key that 
ill trigger the Action, the application (scope) in which the 
ction will occur, and the text you want the Action to type.

lick OK to return to the Quick Type Glossary window.

lick Done in the Quick Type Glossary window when you 
re finished.

ING QUICK TYPE ACTIONS

elete a Quick Type Action:

elect the My Actions tab in the QuicKeys Editor.

ight-click the Action you want to delete.

elect Delete from the context menu that appears.

hoose Yes at the Confirm Delete prompt. The Action is cleared 
rom the Actions list.

G CHECK SPELLING
 the Check Spelling Action you can check the spelling of a 

cted block of text in virtually any document. 

❖ Only one personal dictionary may be selected for 
each Check Spelling Action.

SETTING UP CHECK SPELLING ACTIO
There are two ways to create and edit QuicK
Spelling Actions: use the Setup Wizard or us
Properties dialog.

Using the Setup Wizard
To use the Setup Wizard, select the Setup Wizar
QuicKeys Editor and click the Check Spelling bu
pages of each wizard dialog and follow the i
the beginning of the Setup Wizard, you are p
options to Create an Action, Edit an Action, Delete an 
multiple Actions. The setup for each of these opt
within the Setup Wizard.

Using the Action Properties Dialog
The following instructions assume you have 
Wizards for editing check box cleared in the Option
page 30 for more information on the Options d

 71: The Edit Glossary Entry dialog

FIGURE 72: This dialog appears when you click the C
button in the Setup Wizards tab and choose to create o
Spelling Action.
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To use the Action Properties dialog to create or edit a Check 
Spelling Action, follow these steps:

1. Select Create>Text Tools>Check Spelling.

2. Select an Action and a dictionary.

3. In the General tab of the Action Properties dialog, a name is 
automatically assigned to the Action. You can use the 
assigned Action name or type a different one.

4. Assign a trigger to the Action.

5. Click OK. Your new Action appears in

Close the QuicKeys Editor and open a w
program. Select a block of text and press
assigned to this Action. The block of tex
checked for spelling errors.

CHECK SPELLING OPTIONS
Below is a description of the Action-spec
available with the Check Spelling Action

Check spelling—Checks the spelling of
specified dictionary.

Add words to dictionary—Adds words
Check Spelling dictionary.

URE 73: The Check Spelling Action Properties dialog appears when 
 select the Check Spelling Action from the Create menu, or when you 
ble-click an existing Check Spelling Action in the My Actions tab.
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FIGURE
 dictionaries—Changes the words in the Check Spelling 
ionaries.

tionary options—Chooses which language options you 
t to use for your default dictionary.

DELETING CHECK SPELLING ACTIONS

To delete a Check Spelling Action:

1. Select the My Actions tab in the QuicKeys E

2. Right-click the Action you want to delete.

3. Select Delete from the context menu that ap

4. Choose Yes at the Confirm Delete prompt. The
from the Actions list.

SPECIAL CHARACTERS
The Special Characters Action is useful when
type a specific symbol or international charac
you specify. International symbols and chara
accents, diacriticals, and special alphabetic ch
required for punctuation and non-English w
everyone uses these symbols and characters,
to use in the Windows operating system. 

For example, if you wanted to type a tradem
you would usually have to press Alt+0153. Thi
shortcut key to remember, especially if you n
several of these types of “shortcuts.” QuicKe
easier to use special characters by providing 
assigning simple triggers to the characters yo
For instance, you can use QuicKeys to make 
trademark symbol rather than using Alt+0153.

QuicKeys can type characters and symbols fr
have selected. By default, QuicKeys uses the

SETTING UP SPECIAL CHARACTERS A
There are two ways to create or edit QuicKey
Actions: use the Setup Wizard or use the Act
dialog.

 74: The Personal Dictionaries dialog

 75: The Language Options window
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Using the Setup Wizard
To use the Setup Wizard, select the Setup Wizards tab in the 
QuicKeys Editor and click the Special Characters button. Read the 
pages of each wizard dialog and follow the instructions. At 
the beginning of the Setup Wizard, you are presented with 
options to Create an Action, Edit an Action, or Delete an Action. The 
setup for each of these options is explained within the Setup 
Wizard.

Using the Action Properties Dialog
The following instructions assume you have the Always use Setup 
Wizards for editing check box cleared in the Options dialog. See 
page 30 for more information.

To use the Action Properties dialog to create or edit a Special 
Characters Action, follow these steps:

1. Select Create>Text Tools>Special Characters.

2. Select the font you want to view.

3. Select the character you want to type

4. In the General tab of the Action Proper
name for this Action in the Name box

5. If you want to choose a hot key to tri
in the Hot key box and press the key(s)
example, press the Alt key, the Control k
simultaneously.

URE 76: This dialog appears when you click the Special Characters 
ton in the Setup Wizards tab and choose to create or edit a Special 
aracters Action.

FIGURE 77: Select the character you want to type
properties pane. If you want to view this characte
when you select the Special Characters trigger, cl
from a popup list check box.
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nstructions. At 
resented with 

Action, or Create/edit 
ions is explained 
lick OK. Your new Action appears in the My Actions tab.

lose the QuicKeys Editor and open a word processing 
rogram. Position your cursor in the document and press 

he hot key you assigned to this Action. The special 
haracter you specified is typed into the open document.

AL CHARACTERS OPTIONS
 section describes the Action-specific properties available 
 the Special Characters Action.

ple font—Changes the symbols based on the selected 
. The font is only for sample viewing; the character you 
ct will be inserted using the font already chosen in the 
iving program.

ct the character to type—This option is available in the 
p Wizard. Simply click which character you would like to 
 using this Action. Notice that uppercase and lowercase 
acters are listed separately. 

ct character from a popup list—Choose this option when 
 want a table of special characters to appear when you 
ct the Special Characters trigger. For example, if you are 
ng a letter to your business partner in France and you 
er this option, you can select the international character 
 in his name from the character table. The table 

ppears and the international character is automatically 
rted into your letter.

ING SPECIAL CHARACTERS ACTIONS

elete a Special Characters Action:

elect the My Actions tab in the QuicKeys Editor.

ight-click the Action you want to delete.

elect Delete from the context menu that appears.

hoose Yes at the Confirm Delete prompt. The Action is cleared 
rom the Actions list.

TYPING THE DATE AND TIME
The Type Date/Time Action is useful when y
the date and/or time into documents. For ex
use this Action to insert the date and time in
reports.

SETTING UP TYPE DATE/TIME ACTION
There are two ways to create and edit QuicK
Time Actions: use the Setup Wizard or use th
Properties dialog.

Using the Setup Wizard
To use the Setup Wizard, select the Setup Wizar
QuicKeys Editor and click the Type Date/Time b
pages of each wizard dialog and follow the i
the beginning of the Setup Wizard, you are p
options to Create an Action, Edit an Action, Delete an 
multiple Actions. The setup for each of these opt
within the Setup Wizard.
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Using the Action Properties Dialog
The following instructions assume you have the Always use Setup 
Wizards for editing check box cleared in the Options dialog. See 
page 30 for more information.

To use the Action Properties dialog to create or edit a Type 
Date/Time Action, follow these steps:

1. Select Create>Text Tools>Type Date/Time.

2. Select the Date/Time format you want to use from the 
Format drop-down list.

3. In the General tab of the Action Proper
automatically assigned to the Action.
assigned Action name or type a diffe

4. If you want to trigger this Action from
click the Include in QuicKeys menu check b

5. Click OK. Your new Action appears in

6. Close the QuicKeys Editor.

7. Open a document in a word processi

8. Trigger the Type Date/Time Action y
and time you specified is typed into t

URE 78: This dialog appears when you click the Type Date/Time 
ton in the Setup Wizards tab and choose to create or edit a Type Date/
e Action.

FIGURE 79: The Type Date/Time Action Propert
you select the Type Date/Time Action from the Cr
double-click an existing Type Date/Time Action i
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ATE/TIME OPTIONS
 section describes the Action-specific properties available 
 the Type Date/Time Action.

at—This option is available in the Action Properties 
og. The Format drop-down list displayed in this dialog 
ains several different formats you can choose from when 
 create a Date/Time Action. When you select a format, a 
ple of how that format will look appears in the Sample 
.

Custom Format—If you select Custom Format fr
the Format Builder button is enabled.

 
Custom Format Builder—Clicking the Forma
either the Setup Wizard or the Action Proper
displays a Custom Date/Time Builder dialog. Selec
the left column of the window and click the A
move it to the right column. Rearrange the o
selected formats using the Up and Down butto
in ALL CAPS check box to capitalize all your da
characters. A sample of the combined format
displays at the bottom of the window. 

Date/Time Abbreviation Meaning

mm month

dd day

yyyy year

dow day of the week

hh hour

mm minute

ss second

ap AM/PM

24 hour military time

FIGURE 80: Use the Custom Date/Time Builder to bu
and time formats.
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DE
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 want to type 
er. For example, you 
re line in E-mail 
on into databases.

ype Text Actions: use 
ties dialog, use drag-
.

 Wizards tab in the 
tton. Read the pages 

tructions. At the 
presented with 
elete an Action. The 
ed within the Setup 
Notice in Figure 80 that you must specify commas, colons, 
dashes, slashes, and spaces in your formats if you want to use 
them in your custom format. Click OK in the Custom Date/Time 
Builder window when you are finished. Your new format 
displays in the Sample field of the Action Properties dialog.

Standard Formats—This radio button is available in the Setup 
Wizard. The scroll list displays the formats you can choose 
from when you create a Date/Time Action. When you select a 
format, a sample of how that format will look displays at the 
bottom of the wizard screen.

LETING TYPE DATE/TIME ACTIONS

To delete a Type Date/Time Action:

1. Select the My Actions tab in the QuicKeys Editor.

2. Right-click the Action you want to delete.

3. Select Delete from the context menu that appears.

4. Choose Yes at the Confirm Delete prompt
from the Actions list.

TYPING TEXT
The Type Text Action is useful when you
frequently-used text with a simple trigg
can use this Action to type your signatu
messages or to enter common informati

SETTING UP TYPE TEXT ACTIONS
There are four ways to create QuicKeys T
the Setup Wizard, use the Action Proper
and-drop functionality, or cut and paste

Using the Setup Wizard
To use the Setup Wizard, select the Setup
QuicKeys Editor and click the Type Text bu
of each wizard dialog and follow the ins
beginning of the Setup Wizard, you are 
options to Create an Action, Edit an Action, or D
setup for each of these options is explain
Wizard. 

If you combine these custom 
formats in the Custom Date/
Time Builder...

Your Date/Time Action 
types something similar to 
this...

Full month name+space+Day of 
month+space+Two digit 
year+space+slash+space+Hour in 
12hr format+space+Minute as 
number

October 04 98 / 03 45

Full weekday 
name+colon+space+Abbreviated 
month name+space+Day of 
month+colon+space+Four digit year

Sunday: Oct 04: 1998

Hour in 12hr format+colon+Minute as 
number+colon+Second as 
number+space+AM/PM 
indicator+space+slash+space+Time 
zone

03:51:27 PM / Central Daylight 
Time
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FIGURE
the Setup

pears when you 
hen you double-

b.
ng the Action Properties Dialog
 following instructions assume you have the Always use Setup 
rds for editing check box cleared in the Options dialog. See 
e 30 for more information.

se the My Actions tab to create or edit a Type Text 
on, follow these steps:

elect Create>Text Tools>Type Text.

ype the text you want to use when you trigger this Action.

❖ Press Ctrl+Tab to insert a tab in the text you type.

❖ The text box can hold up to 10 KB of text, or up to 
10,000 characters.

3. In the General tab of the Action Properties d
automatically assigned to the Action. You
assigned Action name or type a different 

4. If you want to choose a hot key to trigger
in the Hot key box and press the key(s) you
example, press the Alt key, the Control key, a
simultaneously. 

5. Click OK. Your new Action appears in the 

6. Close the QuicKeys Editor and open your
Position your cursor in the document and
or other trigger you assigned to this Actio
specified is typed into the open documen

 81: This dialog appears when you click the Type Text button in 
 Wizards tab and choose to create or edit a Type Text Action.

FIGURE 82: The Type Text Action Properties dialog ap
select the Type Text Action from the Create menu, or w
click an existing Type Text Action in the My Actions ta
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Using Drag-and-Drop Functionality
You can select text from one window and drag-and-drop it in 
the QuicKeys Editor to create a Type Text Action. When you 
drop the selected text onto one of the Editor tabs, the Action 
Properties dialog (shown in Figure 82) appears. The text you 
dropped onto the QuicKeys Editor appears in the Action-specific 
properties area of the dialog. You can edit the text in this dialog 
or you can assign the Type Text Action a trigger, such as a hot 
key or a place on an existing toolbar. Click OK in the Action 
Properties dialog when you are finished creating your Type 
Text Action.

Cutting and Pasting Text
You can cut selected text from one window and paste it into 
the Setup Wizards, My Keyboard, or My Actions tabs of the QuicKeys 
Editor. 

To create a Type Text Action using cut and paste:

1. Select a block of text.

2. Copy it to the Clipboard.

3. Right-click in the Setup Wizards tab, the My Keyboard tab, or the 
My Actions tab of the QuicKeys Editor and select Paste from 
the context menu that appears.

A new Type Text Action appears in the My Actions tab of the 
QuicKeys Editor. You must assign the Type Text Action a 
trigger before you can use it.

ITING TYPE TEXT ACTIONS
To edit a Type Text Action:

1. Select the My Actions tab in the QuicKeys Editor. 

2. Double-click the Action you want to edit.

3. Make the necessary changes in the Action Properties dialog 
and click OK.

DELETING TYPE TEXT ACTIONS
To delete a Type Text Action:

1. Select the My Actions tab in the QuicKe

2. Right-click the Action you want to de

3. Select Delete from the context menu th

4. Choose Yes at the Confirm Delete prompt
from the Actions list.
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KING WITH FILES AND FOLDERS

computer users must learn how to manipulate files and 
ers early in their computer experience. Navigating 
ugh countless directories searching for that one file soon 
mes second nature out of necessity, but such tasks can 

 become quite time-consuming. QuicKeys can automate 
e tedious processes for you with Actions such as File 
dler, Folders, Open, Recent Files, and Zip Files.

HANDLER
 File Handler Action is useful when you want to rename, 
e, or edit the attributes of selected files. Attributes can be 

thing from read/write access to file names. This feature is 
emely valuable if you ever work with large batches of 
. 

example, some Web sites make heavy use of scanned or 
tal photographs. Often, these are delivered in large 
hes to webmasters to be posted on the Web. QuicKeys 
es it possible to rename these images en masse with 
erical or alphabetical modifiers, so that files named 

.jpg, 002.jpg, etc., can me renamed chicago001.jpg, 
ago002.jpg, etc. This helps bring order to the batch of 
ges. Additionally, files can be locked and unlocked by 
cKeys with a single hot key or mouse click. This is 
able when you want to lock a batch of original images to 
re that modifications are made only to the copies.

All of the tasks, or Actions, available with Fil
include:

SETTING UP FILE HANDLER ACTIONS
There are two ways to create or edit QuicKey
Actions: use the Setup Wizard or use the Act
dialog. When you are setting up File Handler
use wildcards (such as * and ?) in the Specified
box.

• Set attributes • Set ex

• Move • Copy

• Rename • Delete

• Open with
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se the Setup Wizard, select the Setup Wizards tab in the 
cKeys Editor and click the File Handler button. Read the 
es of each wizard dialog and follow the instructions. At 
beginning of the Setup Wizard, you are presented with 
ons to Create an Action, Edit an Action, or Delete an Action. The 
p for each of these options is explained within the Setup 
ard.

Using the Action Properties Dialog
The following instructions assume you have 
Wizards for editing check box cleared in the Option
page 30 for more information

To use the Actions Properties dialog to crea
Handler Action, follow these steps:

1. Select Create>File & Folder Tools>File Handler.

2. Choose an option from the Action-specific
of the dialog. For example, choose to Mark

3. In the General tab of the Action Properties d
automatically assigned to the Action. You
assigned Action name or type a different 

 83: This dialog appears when you click the File Handler button 
tup Wizards tab and choose to create or edit a File Handler 
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ific properties 

ion or the specified 
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4. If you want to choose a hot key to trigger this Action, click 
in the Hot key box and press the key(s) you want to use. For 
example, press the Shift key, the Control key, and the S key 
simultaneously.

5. Click OK. Your new Action appears in the My Actions tab.

6. Close the QuicKeys Editor.

7. Select a group of files or folders and p
other trigger you assigned to this Act

TRIGGERING FILE HANDLER ACTIO
After you have specified your File Hand
trigger your File Handler Actions severa

• You can right-click any file on your h
File Handler Action from the context
File Handler Action is only available
when you have created one using the

• If you have a File Handler Action Me
toolbar, you can drag files to the Acti
button to move or copy the files, set t

• You can press the hot key you assign
Action to trigger it.

• You can set up a timed trigger to star
Action.

• You can place File Handler Actions in
and select the Action from the menu.

FILE HANDLER OPTIONS
Below is a description of the Action-spec
available with the File Handler Action.

Set attributes—Alters the current select
file or folder. You can change one or man
attributes such as read-only, hidden, sys
time. Select Read-only so files cannot be ed
hide the selected file or folder. Select Sys
folder to one that is exclusively used by 
Select Archive to mark the file or folder fo

URE 84: The File Handler Action Properties dialog appears when you 
ct the File Handler button from the Create menu, or when you double-
k an existing File Handler Action in the My Actions tab.
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FIGURE
Action-s

sk for extension” 
extension—Appends a specified extension to the file 
es of currently selected or pre-specified files and folders. 

 extensions are the three-characters appended to selected 
. Changing file extensions is useful when you want the 
cted file to be recognized by a different program. 

❖ You do not have to type the period character when 
specifying the file extension; QuicKeys 
automatically inserts it.  

sk for extension...—Prompts you for a file extension 
hen you trigger the Set extension Action. You must 

upply an extension composed of up to three characters 
hen the prompt appears. For example, you would type ico 

nd click OK if you wanted the selected files to be 
ecognized as icon files.

Move—Moves the current selection or pre-sp
folders to a destination you specify. 

If using wildcards, ignore subfolders—D
not to move subfolders if a wildcard is us
name. A wildcard is a character, such as a
question mark (?), that can be used to repr
characters.

 85: Use the lower half of the Action Properties dialog to specify 
pecific options.

FIGURE 86: This dialog appears when you have the “A
check box selected.
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FIG

g files or folders
Move To—Moves the selected files or folders to one of the 
locations specified in the Move drop-down list. Select To 
Windows Desktop, Up one folder, Out of all folders, and To specified 
folder,. 

Browse—Specifies where the selected files will be moved. 
The location you specify displays in the Folder text box.This 
option is only available when the To specified folder option is 
selected in the Move list. 

❖ Be very careful when you choose to move large 
batches of files to the root level of your hard drive. 
Due to the way the Windows operating system 
stores filenames, you may run into a character limit 
if you copy files with long file names to the root 
level of your drive.

Copy—Moves the current selection or p
folders to one of the locations specified i
list. Select To Windows Desktop, Up One Folder,
Specified Folder.

If using wildcards, ignore subfolde
not to move subfolders if a wildcard
name. A wildcard is a character, such
question mark (?), that can be used to
characters.

Rename—Renames the currently selecte
files or folders using the naming conven

Delete—Deletes currently selected or pr
folders. You can choose to move files/fo
Bin or you can choose to delete them pe

URE 87: Action-specific properties for moving files or folders

FIGURE 88: Action-specific properties for copyin
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xample of what 
splays at the 
play “Open with...” dialog—Displays the Windows 
en With” dialog for the currently selected file or pre-
ified file. For example, this option may be useful for text-
d files that you alternately open in Notepad and 

rosoft Word.

ng the Rename Files or Folders Action
 following section only provides information on the 
ous renaming options available in the Action-specific 
erties pane of the Action Properties dialog.

ename files and folders using prefix text:

elect Rename Files or Folders in the Action drop-down list of the 
ile Handler’s Action Properties dialog.

elect Prefix Text in the Style drop-down menu.

ype the text you want to use as a prefix in the names of 
he selected files or folders. An example of what the 
enamed files/folders will look like displays at the bottom 
f the dialog.

4. Click OK when you are finished.

To rename files and folders using a prefix v

1. Select Rename Files or Folders in the Action drop
File Handler’s Action Properties dialog.

2. Select Prefix Variable in the Style drop-do

3. Choose the variable you want to use as a 
names of the selected files or folders. An e
the renamed files/folders will look like di
bottom of the dialog.

FIGURE 89: Prefix text options
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4. Click OK when you are finished.

To rename files and folders using a variable and text:

1. Select Rename Files or Folders in the Action drop-down list of the 
File Handler’s Action Properties dialog.

2. Select Variable & Text in the Style drop-down list.

3. Type the text you want to use in the Text box.

4. Choose the variable you want to use f
radio buttons. An example of what th
folders will look like displays at the b

5. Click OK when you are finished.

To rename files and folders using text a

1. Select Rename Files or Folders in the Action
File Handler’s Action Properties dial

2. Select Text & Variable in the Style drop-do

3. Type the text you want to use in the T

4. Choose the variable you want to use f
radio buttons.

An example of what the renamed files/f
displays at the bottom of the dialog.

URE 90: The Prefix Variable option

FIGURE 91: The Variable Text option
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 list.
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like displays at 

FIGURE
lick OK when you are finished.

ename files and folders by appending text:

elect Rename Files or Folders in the Action drop-down list of the 
ile Handler’s Action Properties dialog.

elect Append Text in the Style drop-down list.

n the Text box, type the text you want to add to the end of 
he file or folder name. An example of what the renamed 
les/folders will look like displays at the bottom of the 
ialog.

4. Click OK when you are finished.

To rename files and folders by appending a

1. Select Rename Files or Folders in the Action drop
File Handler’s Action Properties dialog.

2. Select Append Variable in the Style drop-down

3. Select the variable you want to add to the
folder name from the Variable radio button
what the renamed files/folders will look 
the bottom of the dialog.

 92: The Text & Variable option
FIGURE 93: The Append Text option



83• • • •
e currently selected or 
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ys Editor.

lete.

at appears. 

. The Action is cleared 

FIG
4. Click OK when you are finished.

To rename files and folders using a fixed name:

1. Select Rename Files or Folders in the Action drop-down list of the 
File Handler’s Action Properties dialog.

2. Select Fixed Name in the Style drop-down menu.

3. Type the name you want to use for th
pre-specified file or folder.

4. Click OK when you are finished.

DELETING FILE HANDLER ACTION

To delete a File Handler Action:

1. Select the My Actions tab in the QuicKe

2. Right-click the Action you want to de

3. Select Delete from the context menu th

4. Choose Yes at the Confirm Delete prompt
from the Actions list.

URE 94: The Append Variable option

FIGURE 95: Fixed name options
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nted with 

Action, or Create/edit 
ions is explained 

lders button in the 
rs Action.
ERS
 Folders Action is useful if you frequently switch between 
ers during the course of your computer work. For 

ple, if you are a Webmaster, you know that Web sites 
ain hundreds, if not thousands, of files and dozens of 
ctories. Maneuvering to open or save a file within the 
n and Save dialogs requires either a lot of mouse 
ement or keyboarding. QuicKeys chops through this 
uctivity killer by allowing you to set up shortcuts to 

ctories. With a simple Folders hot key you can move deep 
 the directory hierarchy and save countless hours. 
n you set up the Folders Action, you can choose to switch 
een the following pre-defined and user-defined folders 

ing the course of your work:

SETTING UP FOLDERS ACTIONS
There are two ways to create or edit QuicKey
Actions: use the Setup Wizard or use the Act
dialog.

Using the Setup Wizard
To use the Setup Wizard, select the Setup Wizar
QuicKeys Editor and click the Folders button. R
each wizard dialog and follow the instructio
beginning of the Setup Wizard, you are prese
options to Create an Action, Edit an Action, Delete an 
multiple Actions. The setup for each of these opt
within the Setup Wizard.

Pre-defined Actions

• Windows folder • Windows Temporary 
folder

• Windows Desktop 
folder

• My Documents 
folder

• Favorites folder • Application Data 
folder

• Up one folder level

User-defined Actions

• Open a specified 
folder

• Create a folder
FIGURE 96: This dialog appears when you click the Fo
Setup Wizards tab and choose to create or edit a Folde
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ou want to use. For 
, and the F8 

 the My Actions tab.

d select the Save As 

 appears when you 
r when you double-click 
Using the Action Properties Dialog
The following instructions assume you have the Always use Setup 
Wizards for editing check box cleared in the Options dialog. See 
page 30 for more information.

To use the Action Properties dialog to create or edit a Folders 
Action, follow these steps:

1. Select Create>File & Folder Tools>Folders.

2. Choose an option from the Action-specific properties pane 
of the dialog.

3. In the General tab of the Action Properties dialog, a name is 
automatically assigned to the Action. You can use the 
assigned Action name or type a different one.

4. If you want to choose a hot key to tri
in the Hot key box and press the keys y
example, press the Shift key, the Alt key
simultaneously.

5. Click OK. Your new Action appears in

6. Close the QuicKeys Editor.

7. Open a word processing program an
option. 

FIGURE 97: The Folders Action Properties dialog
select the Folders Action from the Create menu, o
an existing Folders Action in the My Actions tab.
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INNT folder 
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pen dialog is 

ndows 
ws Temporary 
 is displayed.

ows Desktop 
en any standard 

ies dialog
ress the Folders hot key. The folder you selected appears 
ithin the standard Save dialog or the folder you specified 
ill be created.

ERING FOLDERS ACTIONS
r you have set up your Folders options, you can trigger 
 several different ways:

ight-click any file on your hard drive and select a Folders 
ction from the context menu that appears. A Folders 
ction is only available from the context menu when you 
ave created one using the QuicKeys Editor.

ress the hot key you assigned to the Folders Action to 
rigger it.

et up a timed trigger to start the Folders Action.

lace Folders Actions in the QuicKeys menu and select the 
ction from the menu.

dd a Folders Action to a QuicKeys toolbar and trigger the 
ction from the toolbar.

RS OPTIONS
w is a description of the Action-specific properties 
lable with the Folders Action.

Windows folder—Opens the Windows or W
(depending on your operating system) or sw
Windows folder when any standard Save or O
displayed.

Windows Temporary folder—Opens the Wi
Temporary folder or switches to your Windo
folder when any standard Save or Open dialog

Windows Desktop folder—Opens the Wind
folder or switches to your desktop folder wh
Save or Open dialog is displayed.

FIGURE 98: The Folders options in the Action Propert
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DE
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ction to open a report 

pen Actions: use the 
 dialog, use drag-and-

 Wizards tab in the 
n. Read each of the 

he instructions. At the 
presented with 
te an Action, or Create/edit 
 options is explained 

the Open button in the 
 Open Action.
My Documents folder—Opens the My Documents folder or 
switches to your My Documents folder (or the Personal folder 
if you are using NT) when any standard Save or Open dialog is 
displayed.

Favorites folder—Opens the Favorites folder or switches to 
your Favorites folder when any standard Save or Open dialog is 
displayed.

Application Data folder—Opens the Application Data folder 
or switches to your Application Data folder when any 
standard Save or Open dialog is displayed.

Up One folder—Switches to the folder above the level of the 
folder you are viewing. 

Open a specified folder—Switches to the folder you specified 
when you created the Action.

Create a folder—Creates a folder in the active Explorer 
window or in the directory you specify. The new folder has 
the name you provide in the text field.

LETING FOLDERS ACTIONS

To delete a QuicKeys Folders Action:

1. Select the My Actions tab in the QuicKeys Editor.

2. Right-click the Action you want to delete.

3. Select Delete from the context menu that appears.

4. Choose Yes at the Confirm Delete prompt. The Action is cleared 
from the Actions list.

THE OPEN ACTION
The Open Action is useful when you wa
documents, control panels, or other type
trigger. For example, you can use this A
you frequently need to edit.

SETTING UP THE OPEN ACTION
There are four ways to create QuicKeys O
Setup Wizard, use the Action Properties
drop functionality, or use cut and paste.

Using the Setup Wizard
To use the Setup Wizard, select the Setup
QuicKeys Editor and click the Open butto
dialogs in the Setup Wizard and follow t
beginning of the Setup Wizard, you are 
options to Create an Action, Edit an Action, Dele
multiple Actions. The setup for each of these
within the Setup Wizard. 

FIGURE 99: This dialog appears when you click 
Setup Wizards tab and choose to create or edit an
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ress the Alt key, 

e for a timed 
 as E-mail 
y. See page 25 for 
s.

My Actions tab.

ot key you 
m you selected 

ars when you select 
ouble-click an 
ng the Action Properties Dialog
 following instructions assume you have the Always use Setup 
rds for editing check box cleared in the Options dialog. See 
e 30 for more information.

se the Action Properties dialog to create or edit an Open 
on, follow these steps:

elect Create>File & Folder Tools>Open.

hoose option(s) from the Action-specific properties pane 
f the dialog. For example, choose Program from the Type 
rop-down list and choose a program to open from the Path 
rop-down list.

n the General tab of the Action Properties dialog, a name is 
utomatically assigned to the Action. You can use the 
ssigned Action name or type a different one.

4. Click in the Hot key box and press the key(s
to trigger the Open Action. For example, p
the Ctrl key, and the 1 key simultaneously.

❖ This Action is also a good candidat
trigger if you open programs, such
software, at the same time each da
more information on timed trigger

5. Click OK. Your new Action appears in the 

6. Close the QuicKeys Editor and press the h
assigned to this Action. The file or progra
opens.

FIGURE 100: The Open Action Properties dialog appe
the Open button from the Create menu, or when you d
existing Open Action in the My Actions tab.
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 panel, or other type 
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 specified for the 
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rer view. If you 
the Explorer program 
 in the Explorer view. 
Using Drag-and-Drop Functionality
You can drag-and-drop programs, documents, control panels, 
or other types of files to the QuicKeys Editor’s Setup Wizards tab 
to quickly create an Open Action. When you drop one file onto 
the Setup Wizards tab, the Action Properties dialog (shown in 
Figure 100) appears. The file you dropped onto the QuicKeys 
Editor appears in the Path box of the Action-specific properties area 
of the dialog. You can edit the text in this dialog or you can 
assign it a trigger, such as a hot key. 

When you drop multiple files onto the Setup Wizards tab, the files 
are automatically made into Open Actions that display in the 
My Actions tab of the QuicKeys Editor. You can double-click 
these new Open Actions to assign triggers to them, such as a 
timed trigger or a place in the QuicKeys Menu.

Click OK in the Action Properties dialog when you are finished 
creating your Open Action.

Copying and Pasting Files and Folders
You can copy selected files to your Clipboard and paste them 
into the Setup Wizards, My Keyboard, or My Actions tabs of the 
QuicKeys Editor. 

To create an Open Action using cut and paste:

1. Select one or several files or folders.

2. Right-click the selected file and folders and choose Copy 
from the context menu that appears.

3. Right-click in the Setup Wizards tab, the My Keyboard tab, or the 
My Actions tab in the QuicKeys Editor and select Paste from 
the context menu.

A new Open Action displays in the My Actions tab of the 
QuicKeys Editor. 

EN OPTIONS
Below is a description of the Action-specific properties 
available with the Open Action.

Program—When you choose to open a p
QuicKeys, you are presented with a list 
which to choose. That list is populated b
your Start menu.

Document—When you choose to open a
QuicKeys, you must click the Browse butt
the document you want to open.

Control Panel—When you choose to op
with QuicKeys, you are presented with 
panels installed on your computer.

Custom—When you choose to open a fi
using any of the other Open options, yo
directory path for that file in the Run field
button and navigate to it.

Type—The type of file you want to open
can open programs, documents, control
custom files.

Path—The information required in the P
upon the type of file you selected in the 
Specify the program, document, control
of file you wish to open.

Parameters—The program-specific com
use to further control the behavior of the
example, the /n/e,C:\ parameter is already
Windows Explorer program. This param
Explorer in the C:\ directory in an Explo
changed the parameter to /n/e,C:\Windows, 
would open in the C:\Windows directory
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❖ Each program installed on your computer has its 
own unique set of command parameters that are 
reminiscent of DOS commands. Consequently, it 
would be wise to have experience with DOS before 
typing text in the Parameters field.

t in—This command can be traced back to the DOS 
nge directory” (CD) command. If you want to open a 
ram that can only look for files in the currently selected 

ctory, it is important to specify the directory path in the 
 in field. 

example, if you can recall any DOS commands, you may 
ember that you once had to type copy C:\Programs 
stem\Documents to successfully copy files from one directory 

nother. However, if you typed C:\System C:\Documents, you 
ld get an error because the computer was looking for 
ograms in the C:\System\Documents directory.

—The appearance of the window when it opens. You can 
e the file appear in a normal, minimized, or maximized 
dow.

ING OPEN ACTIONS

elete a QuicKeys Open Action:

elect the My Actions tab in the QuicKeys Editor.

ight-click the Action you want to delete.

elect Delete from the context menu that appears. 

hoose Yes at the Confirm Delete prompt. The Action is cleared 
rom the Actions list.

RECENT FILES
The Recent Files Action gives you more prec
files you want to locate than what is provide
Windows operating system. It enables you to
modified files by searching modification date
interval you specify. For example, if you dow
shareware program from the Internet and ca
later time, Recent Files can find it for you. Yo
following search options when you direct the
Action to locate files.

SETTING UP RECENT FILES ACTIONS
There are two ways to create and edit QuicK
Actions: use the Setup Wizard or use the Act
dialog.

• Files modified in the 
last 15 minutes

• Files 
last h

• Files modified in the 
last 24 hours

• Files 
last “
“X” m

• Exclude the Windows 
Temporary files from 
the search
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the last 15 minutes.
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rent one.

 the QuicKeys menu, 
ox.
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ialog appears when you 
 you double-click an 
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Using the Setup Wizard
To use the Setup Wizard, select the Setup Wizards tab in the 
QuicKeys Editor and click the Recent Files button. Read the 
pages of each wizard dialog and follow the instructions. At 
the beginning of the Setup Wizard, you are presented with 
options to Create an Action, Edit an Action, or Delete an Action. The 
setup for each of these options is explained within the Setup 
Wizard. 

Using the Action Properties Dialog
The following instructions assume you have the Always use Setup 
Wizards for editing check box cleared in the Options dialog. See 
page 30 for more information.

To use the Action Properties dialog to c
Files Action, follow these steps:

1. Select Create>File & Folder Tools>Recent File

2. Choose an option from the Action-sp
of the dialog. For example, choose In 

3. In the General tab of the Action Proper
automatically assigned to the Action.
assigned Action name or type a diffe

4. If you want to trigger this Action from
click the Include in QuicKeys menu check b

URE 101: This dialog appears when you right-click the Recent Files 
ton in the Setup Wizards tab and choose to create or edit a Recent Files 

tion.

FIGURE 102: The Recent Files Action Properties d
select Recent Files from the Create menu, or when
existing Recent Files Action in the My Actions tab
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 an Action. The 
ithin the Setup 

the Always use Setup 
s dialog. See 

ip Files button in 
p Files Action.
lick OK. Your new Action appears in the My Actions tab.

lose the QuicKeys Editor and select the Recent Files 
ction from the QuicKeys menu. All the files that have 
een modified in the interval you have specified are 
isplayed in a list.

ING RECENT FILES ACTIONS

elete a QuicKeys Recent Files Action:

elect the My Actions tab in the QuicKeys Editor.

ight-click the Action you want to delete.

elect Delete from the context menu that appears.

hoose Yes at the Confirm Delete prompt. The Action is cleared 
rom the Actions list.

ILES
 Zip Files Action enables you to compress files, extract 
pressed files, add to compressed files, and validate 
pressed files. 

NG UP ZIP FILES ACTIONS
re are two ways to create and edit QuicKeys Zip Files 
ons: use the Setup Wizard or use the Action Properties 
og.

Using the Setup Wizard
To use the Setup Wizard, select the Setup Wizar
QuicKeys Editor and click the Zip Files button
of each wizard dialog and follow the instruc
beginning of the Setup Wizard, you are prese
options to Create an Action, Edit an Action, or Delete
setup for each of these options is explained w
Wizard. 

Using the Action Properties Dialog
The following instructions assume you have 
Wizards for editing check box cleared in the Option
page 30 for more information.

FIGURE 103: This dialog appears when you click the Z
the Setup Wizards tab and choose to create or edit a Zi
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 the My Actions tab.

r the Zip Files Action.

log appears when you 
u double-click an 
To use the Action Properties dialog to create or edit a Zip 
Files Action, follow these steps:

1. Select Create>File & Folder Tools>Zip Files.

2. Choose an option from the Action-specific properties pane 
of the dialog. For example, choose Add files to zip.

3. In the General tab of the Action Properties dialog, a name is 
automatically assigned to the Action. You can use the 
assigned Action name or type a different one.

4. Select a trigger for the Action.

5. Click OK. Your new Action appears in

6. Close the QuicKeys Editor and trigge

FIGURE 104: The Zip Files Action Properties dia
select Zip Files from the Create menu, or when yo
existing Zip Files Action in the My Actions tab.



94 Chapter 7
Working With Files and Folders

• • • •

ZIP FI
Belo
avai

Add
Whe
the 
mus
dest
pre-
you
Clic
aler

Extr
Whe
loca
dest
repl
in th
chec
unz

Veri
this
the 
spec

DELET

To d

1. S

2. R

3. S

4. C
f

LES OPTIONS
w is a description of the Action-specific properties 
lable with the Zip Files Action.

 files to zip—Adds the specified file to the Zip archive. 
n this option is selected, you must choose whether to zip 

file that is currently selected or a pre-specified file. You 
t also indicate a destination for the zip file. The 
ination can be the same directory as the specified file or a 
specified directory. Finally, you must tell QuicKeys how 
 want to handle situations where a zip file already exists. 
k the Notify when completed check box if you want to be 
ted when the files have been zipped. See Figure 104.

act files from zip—Decompresses the specified files. 
n this option is selected, you must choose the source 

tion of the zip file you want to decompress as well as the 
ination for the decompressed files. Then, you must choose 
acement options if the decompressed files are duplicated 
e destination directory. Click the Notify when completed 
k box if you want to be alerted when the files have been 

ipped.

fy zip file—Verifies that the zip file isn’t corrupted. When 
 option is selected, you must choose whether to verify the 
file that is currently selected or a file that has been pre-
ified in the Zip Files Action.

ING ZIP FILES ACTIONS

elete a QuicKeys Zip Files Action:

elect the My Actions tab in the QuicKeys Editor.

ight-click the Action you want to delete.

elect Delete from the context menu that appears.

hoose Yes at the Confirm Delete prompt. The Action is cleared 
rom the Actions list.
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 dialog that is 

properties 

on using the 

ton Click Sequence 
PTER 8

 •
G SYSTEM TOOLS

tem Tools encompass the Button Click, Mouse Click, 
se Position, QuicKeys Clipbook, Run Script, Select Menu, 

System Clock, System Specials, Type Keystroke, and 
dow Handler Actions. These Actions are invaluable if you 
 to control or change the appearance and behavior of the 
dows environment, but you don’t like digging around in 
system preferences. You can use the System Tools Actions 
hange your screen settings, cut and paste text and graphics 
our Clipbook, rearrange the windows on your desktop, 
 scripts, and much more. 

ON CLICK
 Button Click Action clicks dialog buttons in the frontmost 
dow. For example, you might want an Action that clicks 
Cancel button in a dialog when you press Alt+Ctrl+C. This is a 
ful Action to incorporate into your QuicKeys Sequences.

k the Specify window properties button to display the Window 
perties dialog. Using the Window finder tool in the 
dow Properties dialog enables you to automatically 
ulate the text fields and buttons in the Action Properties 
og. See page 173 for more information.

NG UP BUTTON CLICK ACTIONS

nsert a Button Click Action in a Sequence:

pen the Sequence Editor.

osition the insert arrow where you want to insert the 
utton Click in the Sequence.

elect Create>System Tools>Button Click.

4. Complete the Sequence Action Properties
shown in Figure 105 and click OK.

BUTTON CLICK OPTIONS
Below is a description of the Action-specific 
available with the Button Click Action.

Find button by name—Locates a dialog butt
information in the Button Text box.

FIGURE 105: The Action Properties dialog for the But
tool
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 continue to the 
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e Sequence, or 

ditor.

pears. 

ction is cleared 

 a mouse click 
eful in QuicKeys 
en there is no 

t to select. For 
t opens your 
rforms a Save As 

FIGURE
buttons 
utton text—Types the name of the button.

xact match—Select Exact match if the button text must 
atch the button in the software exactly.

 button by coordinates—The intersection of the X and Y 
dinates where the mouse click should occur.
—The horizontal coordinates for the mouse click.

—The vertical coordinates for the mouse click.

 button by ID—The Button Click looks for a program-
ific ID rather than looking for coordinates. Button IDs are 
cally only known by developers, so the IDs are not 
monly used.

cify window properties—Displays the Window Properties 
og, which allows you to select a specific window with 
r mouse. See Figure 190 on page 173 for more information.

en button is found—Chooses whether to always click the 
on or radio button, click the button only when it’s on, or 
 the button only when it’s off. The same rules apply to 
k boxes. If you want to look for a checked check box, 

ct Click always or Click when on. If you want to look for an 
hecked check box, select Click always or Click when off.

Mouse button—The button that is clicked fo
Middle button option is not applicable unless yo
mouse button.

Modifiers—The keys that must be pressed in
with the mouse click.

If step succeeds—If the Button Click functio
list specifies what the Sequence should do ne
it can stop the Sequence, and notify the user,
next step of the Sequence or skip to the next 

If step fails—If the Button Click function fai
appears specifies what the Sequence should 
example, it can stop the Sequence, stop the S
notify the user, continue to the next step of th
skip to the next step.

DELETING BUTTON CLICK ACTIONS

To delete a QuicKeys Button Click Action:

1. Select the My Actions tab in the QuicKeys E

2. Right-click the Action you want to delete.

3. Select Delete from the context menu that ap

Choose Yes at the Confirm Delete prompt. The A
from the Actions list.

MOUSE CLICK
The Mouse Click Action allows you to mimic
with a keystroke. This Action is especially us
Sequence Actions because there are times wh
keyboard equivalent for the option you wan
example, if you are recording a Sequence tha
weekly report in Microsoft Word and then pe

 106: This is an illustration of how QuicKeys defines which 
are “on” and which are “off.”

A check box that is “on”

A radio button that is “off”

A check box that is “off”

A radio button that is “on”
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SE

ific properties 

s for the Mouse Click 
ordinates are 

ates for the release of 

e Mouse Click Sequence 
command to save the file to a specific directory, the Sequence 
will use a Mouse Click Action to tell your computer to click 
the Up One Folder Level icon. This specifies the directory at the 
appropriate time in the Sequence of Actions. 

The Mouse Click Action is based on screen coordinates, which 
most users are unfamiliar with. Consequently, it is likely that 
the only time you will open the Mouse Click Action is when 
you are editing the Mouse Click information after recording a 
Sequence.

Click the Specify window properties button to display the Window 
Properties dialog. Using the Window finder tool in the 
Window Properties dialog enables you to automatically 
populate the text fields and buttons in the Action Properties 
dialog. See page 173 for more information.

TTING UP A MOUSE CLICK ACTION

To insert a Mouse Click Action in a Sequence:

1. Open the Sequence in which you want to insert a Mouse 
Click.

2. Position the insert arrow where you want to insert the 
Mouse Click in the Sequence.

3. Select Create>System Tools>Mouse Click.

4. Complete the Sequence Action Properties dialog that is 
shown in Figure 107 and click OK. MOUSE CLICK OPTIONS

Below is a description of the Action-spec
available with the Mouse Click Action.

Click mouse at—Chooses the coordinate
as well as the point from which those co
measured. 

Release mouse at—Chooses the coordin
the mouse click.

FIGURE 107: The Action Properties dialog for th
tool
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 insert a Mouse 

 to insert the 
ble click—Double-clicks the mouse.

The horizontal coordinates for the Mouse Click.

The vertical coordinates for the Mouse Click.

erenced from—The point from which the coordinates are 
sured. Options include Top Left, Top Right, Bottom Left, 
om Right, and Current Mouse Position.

tive to—Chooses whether the mouse click coordinates 
r relative to the Screen, the Frontmost program window, 
e Window selected using the Select Properties button.

se button—The mouse button that is clicked for this 
on. The Middle button option is not applicable unless you 
e a third mouse button.

ifiers—The keys that must be pressed in combination 
 the Mouse Click.

ep succeeds—If the Mouse Click functions properly, this 
pecifies what the Sequence should do next. For example, 
n stop the Sequence and notify the user, continue to the 
 step of the Sequence, or skip to the next step.

ep fails—If the Mouse Click functions fails, the list that 
ears specifies what the Sequence should do next. For 

ple, it can stop the Sequence, stop the Sequence and 
fy the user, continue to the next step of the Sequence, or 
 to the next step.

DELETING MOUSE CLICK ACTIONS

To delete a Mouse Click Action:

1. Select the My Actions tab in the QuicKeys E

2. Right-click the Action you want to delete.

3. Select Delete from the context menu that ap

Choose Yes at the Confirm Delete prompt. The A
from the Actions list.

MOUSE POSITION
The Mouse Position Action enables you to sp
want your mouse with a QuicKeys trigger. W
functionality you can keep your hands on the
than constantly switching back to your mous

Click the Specify window properties button to disp
Properties dialog. Using the Window finder 
Window Properties dialog enables you to au
populate the text fields and buttons in the Ac
dialog. See page 173 for more information.

SETTING UP A MOUSE POSITION ACT

To create a Mouse Position Action:

1. Open the Sequence in which you want to
Position.

2. Position the insert arrow where you want
Mouse Position in the Sequence.

3. Select Create>System Tools>Mouse Position.
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MO

mouse in the center of 

ions the mouse in the 
rrently active on your 

 mouse at the 
lly enter the 
dow properties button to 
 Specify window properties 
pears. See Figure 190 

 the Window 

IONS

ys Editor.

lete.

at appears. 

he Action is cleared 

FIG
Seq
4. Complete the Mouse Position Action Properties dialog that 
is shown in Figure 108 and click OK.

USE POSITION OPTIONS
Below is a description of the Action-specific properties 
available with the Mouse Position Action.

Remember mouse position—Memorizes the current location 
of the mouse so you can later return the mouse to that location 
with a QuicKeys trigger.

Restore last mouse position—Returns the mouse to its 
previous location.

Center mouse on screen—Positions the 
your screen.

Center mouse on active window—Posit
center of the window or dialog that is cu
screen.

Center mouse on control—Positions the
coordinates you specify. You can manua
coordinates, or you can use the Specify win
specify the location. When you click the
button, the Window Properties dialog ap
on page 173 for more information about
Properties dialog.

DELETING MOUSE POSITION ACT

To delete a Mouse Position Action:

1. Select the My Actions tab in the QuicKe

2. Right-click the Action you want to de

3. Select Delete from the context menu th

Choose Yes at the Confirm Delete prompt. T
from the Actions list.

URE 108: The Action Properties dialog for the Mouse Position 
uence tool
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KEYS CLIPBOOK
u ever use a word processor or an E-mail program, you 
ably also use the Ctrl+X, Ctrl+C, and Ctrl+V key combinations 
t, copy and, paste text and graphics to and from your 

board. But were you ever frustrated by the limitations of 
Clipboard? First of all, you can only store one item in the 
board. Secondly, you can’t really view what’s currently in 

Clipboard unless you make a special effort to install the 
er awkward Clipbook or Clipboard Viewer in Windows 
r 98. 

 QuicKeys Clipbook Action remedies both of these system 
tations and adds a lot more functionality to the whole 
board feature. For example, the QuicKeys Clipbook 
erves stylized text, font information, and color. Plus, with 

uicKeys Clipbook, you can store any item you add to the 
book for as long as you want. For times when the Type 
 Action can’t hold enough text, use the Clipbook Action, 
ch is only limited by the amount of disk space available. 
 can also manage your stored Clipboard items using the 
board Editor. You have much better control and 
tionality with the Clipbook Action than you have with 
parable system tools.

FIGURE 109: To use the QuicKeys Clipbook, you first 
items to your Clipbook collection. 

1 
Select a file, a 
block of text, or 
a graphic to 
add to your 
QuicKeys 
Clipbook.

2
Select the QuicKeys 
Clipbook “copy” 
trigger to add the 
selected item to the 
Clipbook. 

3
The s
is add
QuicK
Clipbo
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FIG
the

m Clipboard

 Clipboard allows one 
Clipboard.

 Clipboard Viewer 
es not display items 
han text and graphics.

way to save a clip in the 
perating system unless 
pecifically chosen to 
lipboard View in 

8 or the Clipbook in 
5.

 the Windows clipboard 
alled, you must go 
 standard save dialogs 
ividual item you select.

ws solution has no 
ktop interface for the 

Windows 95 clipbook 
ing capability, but it 
its contents to the 
en access privileges 

because it is a network 

 Clipboard is lost when 
e is restarted.
URE 110: When you have items in your Clipbook, you can then paste 
m into your documents with a simple QuicKeys trigger.

5
The clip you select 
is pasted into your 
open document. 

4
After you add clips to the 
QuicKeys Clipbook, 
select the “paste” trigger 
and choose which 
Clipbook clip to paste.

QuicKeys Clipbook vs. the Syste

You can add up to 185 items to the 
QuicKeys Clipbook.

The system
item in the 

The QuicKeys Clipbook can store 
and display any type of information 
you specify, such as a file, selected 
text, graphics, etc.

The System
program do
well other t

You can save QuicKeys Clipbook 
clips simply by setting up a “Copy 
selection to Clipbook” Action.

There’s no 
Windows o
you have s
install the C
Windows 9
Windows 9

The QuicKeys Clipbook saves 
multiple items quickly.

If you have
utilities inst
through the
for each ind

The QuicKeys Clipbook provides 
an editor where you can copy 
selected clips to the system 
Clipboard, paste items from the 
system Clipboard into the 
QuicKeys Clipbook, delete 
selected clips, and rename 
selected clips.

The Windo
straight des
Clipboard. 
has an edit
advertises 
network wh
are set up 
program.

You can keep items in the QuicKeys 
Clipbook for as long as you want.

The system
the machin
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k for the first 

p Wizards tab.

t.

ook, Open Clipbook 

 options so they 
. The menu 
e options you 

board by 
lipbook from the 
me clips, you can 
lecting Prompt for 
 need to interact 

before you can 
rompt for item to 

ation of multiple 
es the most 
e it. The Action 
ingle QuicKeys 
ions.
the Always use Setup 
ons dialog. See FIGURE

Wizard t
NG UP THE QUICKEYS CLIPBOOK ACTION
re are two ways to create and edit QuicKeys Clipbook 
ons: use the Setup Wizard or use the Action Properties 
og. Since the QuicKeys Clipbook requires the creation of 
tiple Actions to function, the Setup Wizard provides the 
t efficient way to set it up the first time you use it. 

ng the Setup Wizard
se the Setup Wizard, select the Setup Wizards tab in the 
cKeys Editor and click the QuicKeys Clipbook button. Read 
 of the dialogs in the Setup Wizard and follow the 

ructions. At the beginning of the Setup Wizard, you are 
ented with options to Create an Action, Edit an Action, Delete an 
n, or Create/edit multiple Actions. The setup for each of these 
ons is explained within the Setup Wizard. 

If you are setting up the QuicKeys Clipboo
time, follow these steps:

1. Click the QuicKeys Clipbook button in the Setu

2. Read the introduction page and click Next.

3. Select Create/edit multiple Actions and click Nex

4. Click the check box for Copy selection to clipb
Editor, and Prompt for list of items to paste.

5. Click in the Menu column for each of these
can be triggered from the QuicKeys menu
column should display a Yes for each of th
selected.

6. Click Finish.

Now, you need to add some clips to your clip
choosing items and selecting Copy selection to c
QuicKeys menu. When you have collected so
start inserting them in your documents by se
item to paste in the QuicKeys menu. There is no
with the system Clipboard at all.

❖ You must exit the Clipbook Editor 
see your newly added clips in the P
paste window.

Using the Action Properties Dialog
Since the QuicKeys Clipbook requires the cre
Actions to function, the Setup Wizard provid
efficient way to set it up the first time you us
Properties dialog is best used for creating a s
Clipbook Action or editing your existing Act
The following instructions assume you have 
Wizards for editing check box cleared in the Opti
page 30 for more information. 

 111: Use the “Create/Edit Multiple Actions” option in the Setup 
o set up several Actions simultaneously.
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c option you selected 

ACTION
eral illustration of 
t, you create a 
 QuicKeys Clipbook. 
lets you choose which 
iew the QuicKeys 
re storing, you can 
. This feature extends 
 Paste features so you 
les, text, and graphics 

FIG
sele
item
To use the Action Properties dialog to create or edit a 
QuicKeys Clipbook Action, follow these steps:

1. Select Create>System Tools>QuicKeys Clipbook.

2. Choose an option from the Action-specific properties pane 
of the dialog.

3. In the General tab of the Action Properties dialog, a name is 
automatically assigned to the Action. You can use the 
assigned Action name or type a different name.

4. If you want to trigger the QuicKeys Clipbook Actions from 
the QuicKeys menu, select the Include in QuicKeys menu check 
box.

❖ This Action is also a good candidate for an Action 
menu button on a toolbar. See page 44 for more 
information.

5. Click OK. Your new Action appears in the My Actions tab.

6. Close the QuicKeys Editor and trigge
Clipbook Actions. The Action-specifi
reacts to the trigger.

USING THE QUICKEYS CLIPBOOK 
Figure 109 and Figure 110 provide a gen
how the QuicKeys Clipbook works. Firs
QuicKeys Action that adds clips to your
Then you create a QuicKeys Action that 
clips you want to paste. If you want to v
Clipbook Editor to see all the clips you a
create a trigger that displays that as well
the functionality of the system’s Cut and
can maintain and use frequently-used fi
with ease.

URE 112: You must add items to your Clipbook using the “Copy 
ction...” Action before anything appears in the “Paste preselected 
...” list.
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Informat
selected

he Clipbook Action 
Paste button.
LIPBOOK EDITOR
 can use the Clipbook Editor to view, copy, paste, delete, 
name your clips. The Clipbook Editor appears when you 
er the Open Clipbook Editor Action. You can close the 
book Editor by selecting Exit from the File menu or by 
ing the close box.

EYS CLIPBOOK OPTIONS
w is a description of the Action-specific properties 
lable with the QuicKeys Clipbook Action.

e item from Clipbook—Pastes a block of text or a graphic 
 a document. The item may be specified by selecting it in 
Selected item dropdown list or typing the item name in 
text box.

❖ The Preview area of the Clipbook E
display any information if a file is 
only display selected text and grap

Prompt for list of items to paste from Clipb
the window shown in Figure 114 so you can c
you would like to paste.

 113: The Clipbook Editor

he 
 clip to 
em 
d.

Pastes the System 
Clipboard contents 
into the QuicKeys 
Clipbook.

Deletes the 
selected clip.

s you 
ded to 
book 
e “Add 
n to 
d” 
r the 
tton 
bove.

ion on the 
 clip.

Renames the 
selected clip.

FIGURE 114: When you trigger the Paste function of t
this window appears. Select a clip to use and click the 
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cript Actions using 
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ave the Always use Setup 
Options dialog. See 

FIG
Clip
OK
Copy selection to Clipbook—Adds the selected text or 
graphic image to the clipbook, where it is stored until you 
delete it. The name of your selection can be specified in the 
text box, or you can direct QuicKeys to prompt you for the 
name of the selection. You can store up to 185 items in the 
QuicKeys clipbook.

Open Clipbook Editor—Displays the items being stored in 
the QuicKeys clipbook. You can then select an item and 
proceed to paste it into a document.

Delete item from Clipbook—Deletes the currently selected or 
pre-specified item from the Clipbook.

LETING CLIPBOOK ACTIONS

To delete a QuicKeys Clipbook Action:

1. Select the My Actions tab in the QuicKeys Editor.

2. Right-click the Action you want to delete.

3. Select Delete from the context menu that appears. 

4. Choose Yes at the Confirm Delete prompt. The Action is cleared 
from the Actions list.

DELETING CLIPS FROM THE CLIPB
To delete a single clip from the Clipbook
Clipbook Editor, select the clip you wan
Delete from the Edit menu. You can also cr
the Delete item from Clipbook option to elimin
Clipbook Editor.

To delete all of your clips from the Clipb
Clipbook Editor and select Clear all from 

RUN SCRIPT
The Run Script Action executes scripts. S
instructional commands written in a com
is recognized by specific programs or sc
Script Action is only available from the C
Script Action is useful for running script
QuicKeys trigger. 

If you know how to write Windows scrip
them as long as the appropriate script en
your computer. You can create and run j
basic scripts, or any other type of scripts
Host supports. Windows Scripting Host
independent scripting host for 32-bit Wi

SETTING UP THE RUN SCRIPT AC
You can create and edit QuicKeys Run S
the Action Properties dialog.

Using the Action Properties Dial
The following instructions assume you h
Wizards for editing check box cleared in the 
page 30 for more information.

URE 115: When you trigger the “Copy selection” function of the 
book Action this window appears. Type a name for the clip and click 

.
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d lines you can 
cted script. For 
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ditor.

pears.
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FIGURE
se the Action Properties dialog to create or edit a Run 
pt Action, follow these steps:

elect Create>System Tools>Run Script.

hoose a script for QuicKeys to launch. Use the Browse 
utton to navigate through your directories if you cannot 
ype the path of the script.

n the General tab of the Action Properties dialog, a name is 
utomatically assigned to the Action. You can use the 
ssigned Action name or type a different name.

f you want to choose a hot key to trigger this Action, click 
n the Hot key box and press the key(s) you want to use. For 
xample, press the Shift key, the Control key, and the F8 key 
imultaneously.

5. Click OK. Your new Action appears in the 

6. Close the QuicKeys Editor and press the h
trigger you assigned to this Action. The sc
should launches.

RUN SCRIPT OPTIONS
Below is a description of the Action-specific 
available with the Run Script Action.

Select script—Displays the directory path fo
field.

Browse—Navigates to the location of the

Parameters—The program-specific comman
use to further control the behavior of the sele
example, /n/e,C:\ opens Windows Explorer
directory in an Explorer view.

DELETING RUN SCRIPT ACTIONS

To delete a QuicKeys Run Script Action:

1. Select the My Actions tab in the QuicKeys E

2. Right-click the Action you want to delete.

3. Select Delete from the context menu that ap

4. Choose Yes at the Confirm Delete prompt. The
from the Actions list.

 116: The Run Script Action Properties dialog
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 Wizards tab in the 
 button. Read the 
the instructions. At 
are presented with 
elete an Action. The 
ed within the Setup 

og
ave the Always use Setup 
Options dialog. See 

reate or edit a Select 

 the Select Menu button 
dit a Select Menu 
LECT MENU
You can select any item from a menu without using a mouse 
now that you have the Select Menu Action at your disposal. 
Select Menu is useful when you want to avoid using your 
mouse, or when you want to select a menu item that does not 
have a hot key assigned to it. For example, you can use this 
Action to assign a single hot key that selects the Exit command 
in all of your programs.

❖ The Select Menu Action is most often used within 
QuicKeys Sequences, but it can also be used to 
create single-task Actions.

TTING UP SELECT MENU ACTIONS
There are two ways to create or edit QuicKeys Select Menu 
Actions: use the Setup Wizards tab or use the My Actions tab.

Using the Setup Wizard
To use the Setup Wizard, select the Setup
QuicKeys Editor and click the Select Menu
pages of each wizard dialog and follow 
the beginning of the Setup Wizard, you 
options to Create an Action, Edit an Action, or D
setup for each of these options is explain
Wizard.

Using the Action Properties Dial
The following instructions assume you h
Wizards for editing check box cleared in the 
page 30 for more information.

To use the Action Properties dialog to c
Menu Action, follow these steps:

1. Select Create>System Tools>Select Menu.

FIGURE 117: This dialog appears when you click
in the Setup Wizards tab and choose to create or e
Action.
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FIGURE
you choo
double-c n is being used to 
pecify the menu item you want QuicKeys to locate when 
his Action is triggered.

n the General tab of the Action Properties dialog, a name is 
utomatically assigned to the Action. You can use the 
ssigned Action name or type a different name.

f you want to choose a hot key to trigger this Action, click 
n the Hot key box and press the key(s) you want to use. For 
xample, press the Shift key and the F3 key simultaneously.

lick OK. Your new Action appears in the My Actions tab.

6. Close the QuicKeys Editor and press the h
trigger you assigned to this Action. The m
selected.

SELECT MENU OPTIONS
Below is a description of the Action-specific 
available with the Select Menu Action.

Menu Item—This option is available in the S
Type the name of the menu item you want to

Browse—This option is available in both 
and the Action Properties dialog. As soon
Browse button, the QuicKeys Editor disapp
recording palette appears. Select the men
to use for this Action. The QuicKeys Edito
the name of the menu item you selected d
Menu Item field. To cancel the Browse optio
button on the recording palette.

❖ The recording palette remembers i
position on your screen when it op

 118: The Select Menu Action Properties dialog appears when 
se the Select Menu Action from the Create menu, or when you 
lick an existing Select Menu Action in the My Actions tab. FIGURE 119: In this illustration, the Select Menu Actio

select the Word Wrap option in the Notepad program.
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perties dialog. Use 
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t corner of your 

ystem menu for 

t system menu for 
Starts with—Requires that the menu item QuicKeys 
searches for must start with the characters supplied in the 
Menu Item box.

Exact match—Requires that the menu item QuicKeys 
searches for must exactly match the characters supplied in 
the Menu Item box. This means that the search is case 
sensitive.

Contains—Requires that the menu item QuicKeys 
searches for must contain the characters supplied in the 
Menu Item box.

[Menu item to select] Menu item—This option is available in 
the Action Properties dialog. Type the name of the menu item 
you want to select in this box.

[Menu item to select] Menu ID—This option is available in 
the Action Properties dialog. Menu IDs vary from program to 
program. Therefore, the Menu ID field should only be 
populated when you click the Browse button and QuicKeys 
records the Menu ID number for the menu item selected. The 
Menu ID number is useful when a menu contains 
information, such as colors, that cannot be specified in the 
Menu text field. It is also useful if the menu item toggles 
between two options, such as Redo and Undo.

[Choose menu item from] Active program menu—This 
option is available in the Action Properties dialog. Use this 
option to select an item from the menus displayed in the 
currently active program. For example, if Microsoft Word was 
the foreground program on your desktop, this Action would 
select an item from one of Word’s menus.

[Choose menu item from] Active progr
This option is available in the Action Pro
this Action to select an item from the me
when you click the program icon in an o
program icon is the icon in the upper lef

[Choose menu item from] Active docum
This option is available in the Action Pro
this Action to select an item from the me
when you click the program icon in an o
program icon is the icon in the upper lef
document window. 

FIGURE 120: This is an example of the program s
Microsoft Excel.

FIGURE 121: This is an example of the documen
Microsoft Excel.



110 Chapter 8
Using System Tools

• • • •

[Ch
avai
sele

[Ch
the A
to se
men

DELET

To d

1. S

2. R

3. S

4. C
f

hange your 
e designated on a 

IONS
m Clock Actions: 
b.

ds tab in the 
 button. Read the 
nstructions. At 
resented with 
 an Action. The 

ithin the Setup 

FIGURE

et System Clock 
r edit a Set System 
oose menu item from] Start menu—This option is 
lable in the Action Properties dialog. Use this option to 
ct an item from the Windows Start menu.

oose Menu] Context menu—This option is available in 
ction Properties dialog. Use this option when you want 

lect a context menu item within a Sequence. Context 
us appear when you right-click your mouse.

ING SELECT MENU ACTIONS

elete a Select Menu Action:

elect the My Actions tab in the QuicKeys Editor.

ight-click the Action you want to delete.

elect Delete from the context menu that appears.

hoose Yes at the Confirm Delete prompt. The Action is cleared 
rom the Actions list.

SET SYSTEM CLOCK
Using the Set System Clock Action, you can c
system clock to a time you specify or to a tim
specified time server.

SETTING UP SET SYSTEM CLOCK ACT
There are two ways to create or edit Set Syste
use the Setup Wizards tab or use the My Actions ta

Using the Setup Wizard
To use the Setup Wizard, select the Setup Wizar
QuicKeys Editor and click the Set System Clock
pages of each wizard dialog and follow the i
the beginning of the Setup Wizard, you are p
options to Create an Action, Edit an Action, or Delete
setup for each of these options is explained w
Wizard.

 122: The Windows Start menu

FIGURE 123: This dialog appears when you click the S
button in the Setup Wizards tab and choose to create o
Clock Action.
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ties dialog, a name is 
 You can use the 
rent name.

gger this Action, click 
) you want to use. For 
y, and 0 

 the My Actions tab.

rties dialog appears 
m the Create menu, or 
ck Action in the My 
Using the Action Properties Dialog
The following instructions assume you have the Always use Setup 
Wizards for editing check box cleared in the Options dialog. See 
page 30 for more information.

To use the Action Properties dialog to create or edit a Set 
System Clock Action, follow these steps:

1. Select Create>System Tools>Set System Clock.

2. Specify how you want to set your system clock. You can 
choose to set it by a selected remote time server or you can 
enter a specific date and time.

3. In the General tab of the Action Proper
automatically assigned to the Action.
assigned Action name or type a diffe

4. If you want to choose a hot key to tri
on the Hot key box and press the key(s
example, press the Shift key, the Ctrl ke
simultaneously.

5. Click OK. Your new Action appears in

FIGURE 124: The Set System Clock Action Prope
when you choose the Set System Clock Action fro
when you double-click an existing Set System Clo
Actions tab.



112 Chapter 8
Using System Tools

• • • •

6. C
t
c

SET S
Belo
avai

Rem
time
serv
Nav
to li

To a
the 
add

te and/or time to 

he system clock 

ION

ion:

ditor.

pears.

 Action is cleared 
lose the QuicKeys Editor and press the hot key or other 
rigger you assigned to this Action. The system clock is 
hanged using the date and time you specified.

YSTEM CLOCK OPTIONS
w is a description of the Action-specific properties 
lable with the Set System Clock Action.

ote time server—Sets the system clock according to the 
 indicated on a selected remote time server. Default time 
ers include NIST, Purdue University, Coypu, and the U.S. 
al Observatory. You can also click the Edit time servers button 
nk to other remote time servers.

dd a time server to your list of remote time servers, click 
Add button and provide the remote time server’s name, 
ress, time protocol, and network protocol.

❖ If you are using a firewall, check that ports 37 or 123 
are open. See your network administrator for more 
information.

Specified date and/or time—Chooses the da
which you want to set your system clock.

Notify when completed—Alerts you when t
has been successfully changed.

DELETING A SET SYSTEM CLOCK ACT

To delete a QuicKeys Set System Clock Act

1. Select the My Actions tab in the QuicKeys E

2. Right-click the Action you want to delete.

3. Select Delete from the context menu that ap

4. Choose Yes at the Confirm Delete prompt. The
from the Actions list.

FIGURE 125: The Remote Time Servers dialog
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u want to automate.

 the System Specials 
ate or edit a System 
ING SYSTEM SPECIALS
The System Specials Action offers a way to make a variety of 
common computer tasks faster and easier to complete. You 
can use the System Specials Action to shutdown your 
computer, restart your computer, restart Windows, log off 
your computer, lock your computer, set your computer to 
standby, or empty the Recycle Bin.

TTING UP SYSTEM SPECIALS ACTIONS
There are two ways to create or edit QuicKeys System Specials 
Actions: use the Setup Wizards tab or use the My Actions tab.

Using the Setup Wizard
To use the Setup Wizard, select the Setup Wizards tab in the 
QuicKeys Editor and click the System Special button. Read the 
pages of each wizard dialog and follow the instructions. At 
the beginning of the Setup Wizard, you are presented with 
options to Create an Action, Edit an Action, or Delete an Action. The 
setup for each of these options is explained within the Setup 
Wizard.

Using the Action Properties Dial
The following instructions assume you h
Wizards for editing check box cleared in the 
page 30 for more information.

To use the Action Properties dialog to c
Specials Action, follow these steps:

1. Select Create>System Tools>System Special

2. Specify which basic computer task yo

FIGURE 126: This dialog appears when you click
button in the Setup Wizards tab and choose to cre
Specials Action.
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FIGURE
you choo
you dou
n the General tab of the Action Properties dialog, a name is 
utomatically assigned to the Action. You can use the 
ssigned Action name or type a different name.

elect a trigger for this Action.

lick OK. 

lose the QuicKeys Editor and press the hot key or other 
rigger you assigned to this Action. 

M SPECIALS OPTIONS
w is a description of the Action-specific properties 
lable with the System Specials Action.

tdown computer—Shuts down your computer.

tart computer—Restarts your computer.

Restart Windows—Restarts the Windows op
This option only works for Windows 98.

Log off computer—Logs you off your compu

Lock computer—Locks your computer. This
works for Windows 2000. When you unlock 
you must enter your Windows password at t

Set computer to standby—Puts your compu
mode.

Empty Recycle Bin—Deletes the contents of
Recycle Bin. Click the check box Prompt for con
want to see a prompt before the contents of th
actually deleted.

DELETING A SYSTEM SPECIALS ACTIO

To delete a System Specials Action:

1. Select the My Actions tab in the QuicKeys E

2. Right-click the Action you want to delete.

3. Select Delete from the context menu that ap

4. Choose Yes at the Confirm Delete prompt. The
from the Actions list.

 127: The System Specials Action Properties dialog appears when 
se the System Specials Action from the Create menu, or when 

ble-click an existing System Specials Action in the My Actions tab.
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PE KEYSTROKE
To truly personalize your computer, you need to have the 
ability to choose how you interact with it. QuicKeys gives you 
this ability with the Type Keystroke Action. This Action 
provides a way to change hot key assignments built into your 
programs with QuicKeys hot keys that make sense to you.

The Type Keystroke Action is useful when you want to 
substitute one key for another. For example, if you upgrade 
one of your programs only to find that all your favorite built-
in shortcut keys have been changed, you can just change them 
right back to what you’re accustomed to using with the Type 
Keystroke Action.

TTING UP TYPE KEYSTROKE ACTIONS
There are two ways to create and edit Type Keystroke Actions: 
use the Setup Wizard or use the Action Properties dialog.

Using the Setup Wizard
To use the Setup Wizard, select the Setup Wizards tab in the 
QuicKeys Editor and click the Type Keystroke button. Read each 
of the dialogs in the Setup Wizard and follow the instructions. 
At the beginning of the Setup Wizard, you are presented with 
options to Create an Action, Edit an Action, or Delete an Action. The 
setup for each of these options is explained within the Setup 
Wizard.

 

Using the Action Properties Dial
The following instructions assume you h
Wizards for editing check box cleared in the 
page 30 for more information.

FIGURE 128: This dialog appears when you click
button in the Setup Wizards tab and choose to cre
Keystroke Action.
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FIGURE
you sele
double-c
se the Actions Properties dialog to create or edit a Type 
stroke Action, follow these steps:

elect Create>System Tools>Type Keystroke.

ype the keystroke you want to replace in the Action-
pecific properties pane of the dialog.

n the Name box of the Action Properties dialog, a name is 
utomatically assigned to the Action. You can use the 
ssigned Action name or type a different name.

lick on the Hot key box and press the key(s) you want to 
se to trigger this Action.

lick OK. Your new Action appears in the My Actions tab.

6. Close the QuicKeys Editor and press the h
assigned to this Action. The hot key you s
produce the same results as the key it rep

TYPE KEYSTROKE OPTIONS
Below is a description of the Action-specific 
available with the Type Keystroke Action.

Key(s) to type—The key you want to replace
Keystroke Action enables you to substitute a
key for this key.

Modifiers—The keys that are pressed at the 
key(s) listed in the Key(s) to type box. The modi
include the Shift, Alt, Control, and Windows keys.

DELETING A TYPE KEYSTROKE ACTIO

To delete a Type Keystroke Action:

1. Select the My Actions tab in the QuicKeys E

2. Right-click the Action you want to delete.

3. Select Delete from the context menu that ap

4. Choose Yes at the Confirm Delete prompt. The
from the Actions list.

WINDOW HANDLER
The Windows Handler Action is useful for co
Windows without having to use your mouse

SETTING UP WINDOW HANDLER ACTI
There are two ways to create and edit Windo
Actions: use the Setup Wizard or use the Act
dialog.

 129: The Type Keystroke Action Properties dialog appears when 
ct the Type Keystroke Action from the Create menu, or when you 
lick an existing Type Keystroke Action in the My Actions tab.
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Using the Setup Wizard
To use the Setup Wizard, select the Setup Wizards tab in the 
QuicKeys Editor and click the Window Handler button. Read each 
of the dialogs in the Setup Wizard and follow the instructions. 
At the beginning of the Setup Wizard, you are presented with 
options to Create an Action, Edit an Action, or Delete an Action. The 
setup for each of these options is explained within the Setup 
Wizard. 

Using the Action Properties Dialog
The following instructions assume you have the Always use Setup 
Wizards for editing check box cleared in the Options dialog. See 
page 30 for more information.

To use the Actions Properties dialog to create or edit a 
Window Handler Action, follow these steps:

1. Select Create>System Tools>Window Handler.

2. Select the type of window you want 
then choose the Action you want to p
window.

3. In the Name box of the Action Propert
automatically assigned to the Action.
assigned Action name or type a diffe

4. Click on the Hot key box and press the
use to trigger this Action.

URE 130: This dialog appears when you click the Window Handler 
ton in the Setup Wizards tab and choose to create or edit a Window 
dler Action.

FIGURE 131: The Window Handler Action Prope
when you select the Window Handler Action from
when you double-click an existing Window Hand
Actions tab.
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FIGURE
lick OK. Your new Action appears in the My Actions tab.

lose the QuicKeys Editor and press the hot key you 
ssigned to this Action.

W HANDLER OPTIONS
 Window Handler options vary depending upon whether 
 select All windows, Active window, or Specified window. Below is a 
ription of the Action-specific properties available with the 
dow Handler Action.

Windows
cade windows—Staggers your windows across your 
en.

Tile windows horizontally—Arranges the w
horizontally on your screen.

 132: Cascading windows

FIGURE 133: Horizontally tiled windows
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FIG
Tile Windows Vertically—Arranges windows vertically on 
your screen.

Close all Windows—Closes all your open windows.

Minimize all Windows—Minimizes all your open windows.

Active Window
Close active window—Closes the frontm

Minimize active window—Minimizes t
frontmost window.

Maximize active window—Maximizes 
frontmost window.

Restore last minimized window—Retu
you minimized back to its original size.

Toggle active window size—Alternately
maximizes the frontmost window.

Center active window—Positions the ac
in the middle of your screen.

Set active window size—Adjusts the siz
window to the coordinates you specified

Specified Window
Close specified window—Closes the sp

Minimize specified window—Minimiz
window.

Maximize specified window—Maximiz
window.

Restore specified window—Returns the
you minimized back to its original size.

Toggle specified window size—Alterna
maximizes the specified window.

URE 134: Vertically tiled windows
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ter specified window—Positions the specified window so 
in the middle of your screen.

specified window size—Adjusts the size of the specified 
dow to the coordinates you specified in QuicKeys.

ING WINDOW HANDLER ACTIONS

elete a QuicKeys Window Handler Action:

elect the My Actions tab in the QuicKeys Editor.

ight-click the Action you want to delete.

elect Delete from the context menu that appears.

hoose Yes at the Confirm Delete prompt. The Action is cleared 
rom the Actions list.
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G SCREEN TOOLS

en Tools include Screen Capture, Screen Saver, and Screen 
ings Actions. These Actions enable you to capture images 
 your screen, trigger your screen saver, and adjust the 

lution of your screen with simple QuicKeys triggers.

EN CAPTURE
h QuicKeys you now have the flexibility of taking screen 
ts of your entire screen or an active window with a hot key. 
 can then save the captured image to a file, the Windows 
board, the QuicKeys Clipbook, or you can print it.

NG UP THE SCREEN CAPTURE ACTION
re are two ways to create and edit QuicKeys Screen 
ture Actions: use the Setup Wizard or use the Action 

perties dialog.

ng the Setup Wizard
se the Setup Wizard, select the Setup Wizards tab in the 
cKeys Editor and click the Screen Capture button. Read each 
e dialogs in the Setup Wizard and follow the instructions. 

he beginning of the Setup Wizard, you are presented with 
ons to Create an Action, Edit an Action, Delete an Action, or Create/edit 
iple Actions. The setup for each of these options is explained 
in the Setup Wizard.

 

Using the Action Properties Dialog
The following instructions assume you have 
Wizards for editing check box cleared in the Opti
page 30 for more information.

FIGURE 135: This dialog appears when you click the S
button in the Setup Wizards tab and choose to create o
Capture Action.
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FIGURE
button in
Capture 
se the Action Properties dialog to create or edit a Screen 
ture Action, follow these steps:

elect Create>Screen Tools>Screen Capture.

hoose what part of the screen you want to capture and 
hen choose how you want to save the image.

n the General tab of the Action Properties dialog, a name is 
utomatically assigned to the Action. You can use the 
ssigned Action name or type a different one.

4. If you want to trigger this Action from the
click the Include in QuicKeys menu check box.

5. Click OK. Your new Action immediately ap
Actions tab.

6. Close the QuicKeys Editor and select the 
Action from the QuicKeys menu.

SCREEN CAPTURE OPTIONS
Below is a description of the Action-specific 
available with the Screen Settings Action.

Capture entire screen—Takes a screen shot o
screen.

Capture active window—Takes a screen sho
window.

Paste into Windows clipboard—Stores the s
Windows clipboard.

Paste into QuicKeys Clipbook—Stores the s
QuicKeys Clipbook.

Print to the default printer—Prints the scree
printer specified in Windows as the default p

Save as a file—Stores the screen shot in a file

DELETING SCREEN CAPTURE ACTION

To delete a Screen Capture Action:

1. Select the My Actions tab in the QuicKeys E

2. Right-click the Action you want to delete.

3. Select Delete from the context menu that ap

Choose Yes at the Confirm Delete prompt. The A
from the Actions list.

 136: This dialog appears when you click the Screen Capture 
 the Setup Wizards tab and choose to create or edit a Screen 

Action.
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The Screen Saver Action enables you to control your screen 
saver with QuicKeys triggers. You can use QuicKeys to select 
a screen saver or to turn your screen saver on and off.

TTING UP THE SCREEN SAVER ACTION
There are two ways to create and edit QuicKeys Screen Saver 
Actions: use the Setup Wizard or use the Action Properties 
dialog.

Using the Setup Wizard
To use the Setup Wizard, select the Setup Wizards tab in the 
QuicKeys Editor and click the Screen Saver button. Read each of 
the dialogs in the Setup Wizard and follow the instructions. At 
the beginning of the Setup Wizard, you are presented with 
options to Create an Action, Edit an Action, Delete an Action, or Create/edit 
multiple Actions. The setup for each of these options is explained 
within the Setup Wizard. 

Using the Action Properties Dial
The following instructions assume you h
Wizards for editing check box cleared in the 
page 30 for more information.

FIGURE 137: This dialog appears when you click
in the Setup Wizards tab and choose to create or e
Action.
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FIGURE
in the Se
Action.
se the Action Properties dialog to create or edit a Screen 
er Action, follow these steps:

elect Create>Screen Tools>Screen Saver.

hoose a Screen Saver option. If you choose Select screen 
aver, you must specify which screen saver you want to use.

n the General tab of the Action Properties dialog, a name is 
utomatically assigned to the Action. You can use the 
ssigned Action name or type a different one.

f you want to trigger this Action from the QuicKeys menu, 
lick the Include in QuicKeys menu check box.

lick OK. Your new Action immediately appears in the My 
ctions tab.

6. Close the QuicKeys Editor and select the 
Action from the QuicKeys menu.

SCREEN SAVER OPTIONS
Below is a description of the Action-specific 
available with the Screen Saver Action.

Start screen saver—Starts your screen saver.

Stop screen saver—Closes the screen saver s
again visible.

Enable screen saver—Enables the screen sav
the specified interval.

Disable screen saver—Disables the screen sa
automatically start.

Toggle enabled/disabled status—Alternatel
disables the screen saver.

Select screen saver—Allows you to choose f
installed screen savers.

DELETING SCREEN SAVER ACTIONS

To delete a Screen Saver Action:

1. Select the My Actions tab in the QuicKeys E

2. Right-click the Action you want to delete.

3. Select Delete from the context menu that ap

Choose Yes at the Confirm Delete prompt. The A
from the Actions list.

 138: This dialog appears when you click the Screen Saver button 
tup Wizards tab and choose to create or edit a Screen Saver 
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ate or edit a Screen 
REEN SETTINGS
The Screen Settings Action is useful if you need to change 
your screen settings for different programs or different 
monitors. For example, if you use your laptop computer with 
a desktop monitor when you are at work, you may want to 
create a Screen Settings Action that automatically switches 
between the laptop screen settings and the desktop screen 
settings. The settings available in the Screen Settings Action 
depend upon the capabilities of your monitor and video card.

TTING UP THE SCREEN SETTINGS ACTION
There are two ways to create and edit QuicKeys Screen 
Settings Actions: use the Setup Wizard or use the Action 
Properties dialog.

Using the Setup Wizard
To use the Setup Wizard, select the Setup Wizards tab in the 
QuicKeys Editor and click the Screen Settings button. Read each 
of the dialogs in the Setup Wizard and follow the instructions. 
At the beginning of the Setup Wizard, you are presented with 
options to Create an Action, Edit an Action, Delete an Action, or Create/edit 
multiple Actions. The setup for each of these options is explained 
within the Setup Wizard.

 

Using the Action Properties Dial
The following instructions assume you h
Wizards for editing check box cleared in the 
page 30 for more information.

To use the Action Properties dialog to c
Settings Action, follow these steps:

1. Select Create>Screen Tools>Screen Settings.

2. Choose a screen setting from the Acti
pane of the dialog.

3. In the General tab of the Action Proper
automatically assigned to the Action.
assigned Action name or type a diffe

FIGURE 139: This dialog appears when you click
button in the Setup Wizards tab and choose to cre
Settings Action.
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FIGURE
you sele
double-c
f you want to trigger this Action from the QuicKeys menu, 
lick the Include in QuicKeys menu check box.

lick OK. Your new Action immediately appears in the My 
ctions tab.

lose the QuicKeys Editor and select the Screen Settings 
ction from the QuicKeys menu. The screen settings 

hould change immediately after you trigger the Action.

N SETTINGS OPTIONS
 section offers descriptions of the Action-specific 
erties available with the Screen Settings Action.

en Settings—Choose the settings you want to use for 
r screen display. 4-bit uses fewer colors than 16-bit, so it 
s not display images as sharply. 

❖ The settings that display in the Screen Settings list 
depend upon the capabilities of your video card and 
monitor.

Test—Changes the display so you can see
setting selection looks like.

DELETING SCREEN SETTING ACTION

To delete a QuicKeys Screen Settings Actio

1. Select the My Actions tab in the QuicKeys E

2. Right-click the Action you want to delete.

3. Select Delete from the context menu that ap

4. Choose Yes at the Confirm Delete prompt. Th
immediately cleared from the Actions list

 140: The Screen Settings Action Properties dialog appears when 
ct the Screen Settings Action from the Create menu, or when you 
lick an existing Screen Settings Action in the My Actions tab.
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u have the appropriate sound hardware you can use 
cKeys to play your CDs or DVDs, set the volume for your 
vidual audio devices, and play specified sounds. This 
pter provides instructions for setting up CD/DVD, Set 
io Volume, and Play Sound Actions to control all these 
s for you.

❖ You must have a sound card installed for the 
multimedia tools to function properly.

VD
h QuicKeys you can control your internal CD-ROM and 

 players. With a trigger you can: 

NG UP A CD/DVD ACTION
re are two ways to create and edit QuicKeys CD/DVD 
ions: use the Setup Wizard or use the Action Properties 
og.

Using the Setup Wizard
To use the Setup Wizard, select the Setup Wizar
QuicKeys Editor and click the CD/DVD button.
dialogs in the Setup Wizard and follow the in
beginning of the Setup Wizard, you are prese
options to Create an Action, Edit an Action, Delete an 
multiple Actions. The setup for each of these opt
within the Setup Wizard. 

Using the Action Properties Dialog
The following instructions assume you have 
Wizards for editing check box cleared in the Option
page 30 for more information.

• Play a CD or DVD • Pause a CD or DVD

• Stop a CD or DVD • Skip to the Next Track

• Go back to the 
Previous Track

• Eject the CD or DVD

FIGURE 141: This dialog appears when you click the C
the Setup Wizards tab and choose to create or edit a CD
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FIGURE
select the
click an e
se the Action Properties dialog to create or edit a CD/
D Action, follow these steps:

elect Create>Multimedia Tools>CD/DVD.

hoose an option from the Action-specific properties pane 
f the dialog. For example, select Pause.

n the General tab of the Action Properties dialog, a name is 
utomatically assigned to the Action. You can use the 
ssigned Action name or type a different name.

f you want to choose a hot key to trigger this Action, click 
n the Hot key box and press the key(s) you want to use. For 
xample, press the Control key and the F2 key 
imultaneously.

❖ This Action is also a good candidate for an Action 
Menu toolbar button. See page 44 for more 
information on Action Menu toolbar buttons.

lick OK. Your new Action appears in the My Actions tab.

6. Close the QuicKeys Editor and press the h
trigger you assigned to this Action.

CD/DVD OPTIONS
Below is a description of the Action-specific 
available with the CD/DVD Action:

Play—Plays the CD or DVD.

Pause—Pauses the CD or DVD.

Stop—Stops the CD or DVD.

Next track—Skips to the next track on the CD

Previous track—Skips to the previous track 
DVD.

Eject—Ejects the CD or DVD.

DELETING CD/DVD ACTIONS

To delete a QuicKeys CD/DVD Action:

1. Select the My Actions tab in the QuicKeys E

2. Right-click the Action you want to delete.

3. Select Delete from the context menu that ap

4. Choose Yes at the Confirm Delete prompt. The
from the Actions list.

 142: The CD/DVD Action Properties dialog appears when you 
 CD/DVD Action from the Create menu, or when you double-
xisting CD/DVD Action in the My Actions tab.
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 “Always use Setup 
nd you select Play Sound 
AY SOUND
The Play Sound Action is only available from the Create menu. 
This is because the Play Sound Action is typically used within 
QuicKeys Sequences. You can use the Play Sound Action to 
play selected .wav sound files when you select a QuicKeys 
trigger.

TTING UP A PLAY SOUND ACTION
There are two ways to create and edit QuicKeys Play Sound 
Actions: use the Setup Wizard or use the Action Properties 
dialog.

Using the Setup Wizard
You cannot select the Play Sound Action from the Setup Wizards 
tab. You can, however, use the Setup Wizard for this Action 
from the Create menu.

To use the Setup Wizard with the Play Sound Action:

1. Select View>Options.

2. Verify the Always use Setup Wizards for editing check box is 
selected in the Options dialog and click OK.

 

3. Back in the QuicKeys Editor, select M
menu. 

4. Select Play Sound in the Multimedia subm

5. The Setup Wizard appears to lead yo
of setting up the Play Sound Action. 

Using the Advance Properties Di
The following instructions assume you h
Wizards for editing check box cleared in the 
page 30 for more information.

FIGURE 143: This dialog appears when you have
Wizards for editing” checked in the Options dialog a
from the Create menu.
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FIGURE
select the
click an e
se the Action Properties dialog to create or edit a Play 
nd Action, follow these steps:

elect Create>Multimedia Tools>Play Sound.

hoose a sound file using the Browse button in the Action-
pecific properties pane of the dialog.

lick the Test button if you want to try out the select sound 
le.

n the General tab of the Action Properties dialog, a name is 
utomatically assigned to the Action. You can use the 
ssigned Action name or type a different name.

f you want to trigger the Play Sound Action from the 
uicKeys menu, click the Include in QuicKeys menu check box.

lick OK. Your new Action appears in the My Actions tab.

lose the QuicKeys Editor and select the new Play Sound 
ction using the trigger you specified.

PLAY SOUND OPTIONS
Below is a description of the Action-specific 
available with the Play Sound Action:

Sound file—Type the directory path for the s
would like to start with a QuicKeys trigger. T
a .wav extension in the file name.

Test—Click the Test button to verify you selec
sound and that the sound plays properly.

Browse—Click the Browse button to navigate 
you would like to use.

DELETING PLAY SOUND ACTIONS

To delete a QuicKeys Play Sound Action:

1. Select the My Actions tab in the QuicKeys E

2. Right-click the Action you want to delete.

3. Select Delete from the context menu that ap

4. Choose Yes at the Confirm Delete prompt. The
from the Actions list.

SET AUDIO VOLUME
The Set Audio Volume Action is useful when
able to set every option in your sound arsena
QuicKeys trigger. For example, with a single 
you can set the volume for all of your audio 
one of the available devices. The available au
include:

See page 132 for an explanation of these term

 144: The Play Sound Action Properties dialog appears when you 
 Play Sound Action from the Create menu, or when you double-
xisting Play Sound Action in the My Actions tab.

• Master Out • Wave

• Synth • CD
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TTING UP A SET AUDIO VOLUME ACTION
There are two ways to create and edit QuicKeys Set Audio 
Volume Actions: use the Setup Wizard or use the Action 
Properties dialog.

Using the Setup Wizard
To use the Setup Wizard, select the Setup Wizards tab in the 
QuicKeys Editor and click the Set Audio Volume button. Read 
each of the dialogs in the Setup Wizard and follow the 
instructions. At the beginning of the Setup Wizard, you are 
presented with options to Create an Action, Edit an Action, Delete an 
Action, or Create/edit multiple Actions. The setup for each of these 
options is explained within the Setup Wizard. 

Using the Action Properties Dialog
The following instructions assume you have the Always use Setup 
Wizards for editing check box cleared in the Options dialog. See 
page 30 for more information.

To use the Action Properties dialog to c
Audio Volume Action, follow these ste

1. Select Create>Multimedia Tools>Set Audio V

2. Choose an option from the Action-sp
of the dialog. For example, choose Ma

3. In the General tab of the Action Proper
automatically assigned to the Action.
assigned Action name or type a diffe

4. If you want to choose a hot key to tri
in the Hot key box and press the key(s)
example, press the Shift key, the Contro
simultaneously.

URE 145: This dialog appears when you click the Set Audio Volume 
ton in the Setup Wizards tab and choose to create or edit a Set Audio 
ume Action.

FIGURE 146: The Set Audio Volume Action Prop
when you select the Set Audio Volume Action fro
when you double-click an existing Set Audio Volu
Actions tab.



132 Chapter 10
Using Multimedia Tools

• • • •

5. C

6. C
t

SET A
Belo
avai

Mas
ever
com
you

Wav
com
usu
the 
on (

Syn
Dev
low
muc
of a
som

CD—

M
t

L
t

S
t

T
a

tion:

ditor.

pears.

 Action is cleared 
lick OK. Your new Action appears in the My Actions tab.

lose the QuicKeys Editor and press the hot key or other 
rigger you assigned to this Action.

UDIO VOLUME OPTIONS
w is a description of the Action-specific properties 
lable with the Set Audio Volume Action:

ter Out—Adjusts the volume in identical increments for 
y audio device available on your computer. It’s 
parable to the universal remote you have at home for 
r TV, VCR, and CD player.

e—Adjusts the volume for digitally sampled files on your 
puter. Wave files contain a .wav or .mpg extension and are 
ally quite large in size. An example of a wave file would be 
harp-like sound your computer makes when you turn it 
called “The Microsoft Sound.wav”).

th—Adjusts the volume for your Musical Instrument 
ice Interface (MIDI) files. MIDI sound files are typically 
 fidelity sounds synthesized by your computer that are 
h smaller in size than digitally sampled files. An example 

 Synth file would be the music you hear when you visit 
e Web sites.

Controls the volume for the computer’s CD player.

aximum—Turns the volume of the selected audio device 
o the loudest setting.

ouder—Turns the volume of the selected audio device to 
he next highest incremental setting.

ofter—Turns the volume of the selected audio device to 
he next lowest incremental setting.

oggle on and off—Turns the selected audio device 
lternately on and off.

DELETING AUDIO VOLUME ACTIONS

To delete a QuicKeys Set Audio Volume Ac

1. Select the My Actions tab in the QuicKeys E

2. Right-click the Action you want to delete.

3. Select Delete from the context menu that ap

4. Choose Yes at the Confirm Delete prompt. The
from the Actions list.
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 •
G NETWORK TOOLS

ur computer does not have access to other computers or 
Internet, the information in this chapter will probably not 
pplicable to you. If, however, your computer is on a 
ork, there are several network tasks that QuicKeys can 

 you with. These tasks include choosing printers and 
ork drives, as well as selecting Microsoft’s Dial-Up 

working settings.

SE PRINTER
 Choose Printer Action is useful if you frequently switch 
ters on your network. For example, this Action can be 
emely useful in QuicKeys Sequences when you want to 
 a fax and switch back to your regular printer once the fax 
nt.

NG UP THE CHOOSE PRINTER ACTIONS
re are two ways to create and edit QuicKeys Choose 
ter Actions: use the Setup Wizard or use the Action 

perties dialog.

Using the Setup Wizard
To use the Setup Wizard, select the Setup Wizar
QuicKeys Editor and click the Choose Printer bu
of the dialogs in the Setup Wizard and follow
At the beginning of the Setup Wizard, you ar
options to Create an Action, Edit an Action, Delete an 
multiple Actions. The setup for each of these opt
within the Setup Wizard. 

Using the Action Properties Dialog
The following instructions assume you have 
Wizards for editing check box cleared in the Option
page 30 for more information.

FIGURE 147: This dialog appears when you click the C
button in the Setup Wizards tab and choose to create o
Printer Action.
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FIGURE
se the Action Properties dialog to create or edit a Choose 
ter Action, follow these steps:

elect Create>Network Tools>Choose Printer.

hoose a printer from the Action-specific properties pane 
f the dialog.

n the General tab of the Action Properties dialog, a name is 
utomatically assigned to the Action. You can use the 
ssigned Action name or you can type a different name.

f you want to choose a hot key to trigger this Action, click 
n the Hot key box and press the key(s) you want to use. For 
xample, press the Shift key, the Alt key, the Control key, and 
he O key simultaneously.

lick OK. Your new Action immediately appears in the My 
ctions tab.

lose the QuicKeys Editor and press the hot key or other 
rigger you assigned to this Action. The printer you 
elected should immediately become the default printer.

CHOOSE PRINTER OPTIONS
Below is a description of the Action-specific 
available with the Choose Printer Action:

Select printer—Displays a list of all the print
have access. You can add more printers to thi
the Printer Control Panel and choosing the A

Display message when printer has changed
message when your default printer has been

DELETING CHOOSE PRINTER ACTION

To delete a QuicKeys Choose Printer Action

1. Select the My Actions tab in the QuicKeys E

2. Right-click the Action you want to delete.

3. Select Delete from the context menu that ap

4. Choose Yes at the Confirm Delete prompt. Th
immediately cleared from the Actions list

 148: The Action Properties dialog
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og
ave the Always use Setup 
Options dialog. See 

 the Dial-Up 
choose to create or edit a 
AL-UP NETWORKING
The Dial-Up Networking Action enables you to connect or 
disconnect from a Dial-Up Networking service with a simple 
QuicKeys trigger. Using the Dial-Up Networking Action is not 
as error-prone as manually switching between Dial-Up 
Networking services, and it can be invaluable if you use AOL 
and want to quickly switch between different access numbers. 
Yet another way you could use this Action is to create a timed 
trigger that dials your ISP immediately after you start your 
computer. 

You must have Dial-Up Networking installed and 
configured on your computer for this Action to function 
properly. The tasks available using the Dial-Up Networking 
Action include: 

TTING UP DIAL-UP NETWORKING ACTIONS
There are two ways to create and edit QuicKeys Dial-Up 
Networking Actions: use the Setup Wizard or use the Action 
Properties dialog.

❖ You must have Dial-Up Networking installed and 
configured on your computer for this Action to 
function properly. 

Using the Setup Wizard
To use the Setup Wizard, select the Setup
QuicKeys Editor and click the Dial-Up Net
each of the dialogs in the Setup Wizard 
instructions. At the beginning of the Setu
presented with options to Create an Action,
Action, or Create/edit Multiple Actions. The setu
options is explained within the Setup W

Using the Action Properties Dial
The following instructions assume you h
Wizards for editing check box cleared in the 
page 30 for more information.

• Connect to Dial-Up 
Networking service

• Disconnect from Dial-
Up Networking 
service

• Toggle connection 
state

FIGURE 149: This dialog appears when you click
Networking button in the Setup Wizards tab and 
Dial-Up Networking Action.
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mediately react 

properties 
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ice.

connects from a 

rvice to the list.

e new 

 new connection FIGURE
when yo
when yo
Actions 
se the Action Properties dialog to create or edit a Dial-
Networking Action, follow these steps:

elect Create>Network Tools>Dial-Up Networking.

hoose an option from the Action-specific properties pane 
f the dialog. For example, select Connect to a Dial-Up Networking 
ervice.

n the General tab of the Action Properties dialog, a name is 
utomatically assigned to the Action. You can use the 
ssigned Action name or type a different name.

4. If you want to trigger this Action from the
select the Include in QuicKeys menu check box.

5. Click OK. Your new Action immediately ap
Actions tab.

6. Close the QuicKeys Editor and trigger the
QuicKeys menu or with whatever trigger
The Dial-Up Networking service should im
to the trigger.

DIAL-UP NETWORKING OPTIONS
Below is a description of the Action-specific 
available with the Dial-Up Networking Actio

Connect to a Dial-Up Networking service—
service specified in the Dial-Up Networking 

Disconnect a Dial-Up Networking service—
from the specified Dial-Up Networking serv

Toggle connection status—Connects and dis
Dial-Up Networking service.

Add new connection —Adds another se

Notify upon success—Displays a dialog if th
connection is successful.

Notify upon failure—Displays a dialog if the
is not successful.

 150: The Dial-Up Networking Action Properties dialog appears 
u select the Dial-Up Networking Action from the Create menu, or 
u double-click an existing Dial-Up Networking Action in the My 
tab.
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ate or edit a Network 
LETING DIAL-UP NETWORKING ACTIONS

To delete a QuicKeys Dial-Up Networking Action:

1. Select the My Actions tab in the QuicKeys Editor.

2. Right-click the Action you want to delete.

3. Select Delete from the context menu that appears.

4. Choose Yes at the Confirm Delete prompt. The Action is 
immediately cleared from the Actions list.

TWORK DRIVES
The Network Drives Action is useful if you need to access 
several different network drives on a daily basis. The options 
available in the Network Drives Action include: 

TTING UP THE NETWORK DRIVES ACTION
There are two ways to create and edit QuicKeys Network 
Drives Actions: use the Setup Wizard or use the Action 
Properties dialog.

Using the Setup Wizard
To use the Setup Wizard, select the Setup
QuicKeys Editor and click the Network Dri
of the dialogs in the Setup Wizard and fo
At the beginning of the Setup Wizard, yo
options to Create an Action, Edit an Action, or D
setup for each of these options is explain
Wizard. 

• Connect to a 
network volume

• Toggle connection

• Disconnect from a 
network volume

FIGURE 151: This dialog appears when you click
button in the Setup Wizards tab and choose to cre
Drives Action.
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ialog appears when 
menu, or when you 
 My Actions tab.
ng the Action Properties Dialog
 following instructions assume you have the Always use Setup 
rds for editing check box cleared in the Options dialog. See 
e 30 for more information.

se the Action Properties dialog to create or edit a 
work Drives Action, follow these steps:

elect Create>Network Tools>Network Drives.

hoose a network drive from the Action-specific properties 
ane of the dialog.

n the General tab of the Action Properties dialog, a name is 
utomatically assigned to the Action. You can use the 
ssigned Action name or type a different name.

4. If you want to trigger this Action from the
select the Include in QuicKeys menu check box.

5. Click OK. Your new Action immediately ap
Actions tab.

6. Close the QuicKeys Editor and trigger the
Action from the QuicKeys menu or with w
type of trigger you assigned to this Action
drive you specified is immediately selecte

FIGURE 152: The Network Drives Action Properties d
you select the Network Drives Action from the Create 
double-click an existing Network Drives Action in the



139• • • •
NE eds—Displays a 

/unmap action was 

Displays a message 
action was not 

s
r your login 
rd information for 

er users do not know 
.

NS

ction:

ys Editor.

lete.

at appears.

t. The Action is 
s list.
TWORK DRIVES OPTIONS
Below is a description of the Action-specific properties 
available with the Network Drives Action:

Connect to a network volume—Connects you to a network 
volume.

Disconnect from a network volume—Terminates your 
connection to a network drive.

Toggle connection—Alternately connects and disconnects 
you from a network volume or drive.

Server path—The directory path of the network volume.

Browse—Click the Browse button to navigate to the location 
of the network volume.

Local drive—The drive letter your computer will use to 
identify the selected network volume. Do not select any 
drive letters that are already in use.

Reconnect at logon—Choose this option when you want to 
retain drive mapping information, even after you restart 
your machine. If this option is not checked and you restart 
your machine, you must trigger the Network Drive Action 
to remap the drive.

Name—The user name you use to login to the selected 
network volume.

Password—The password you use to login to the selected 
network volume.

Remember name and password—Select this option if you 
do not want to be prompted for your name and password 
each time you trigger this Network Drives Action.

Display notification if Action succe
message alerting you that your map
successful.

Display notification if Action fails—
alerting you that your map/unmap 
successful.

More About Network Drive Action
Since QuicKeys Actions are stored unde
preferences, your user name and passwo
network drives are secure as long as oth
your network login name and password

DELETING NETWORK DRIVE ACTIO

To delete a QuicKeys Network Drives A

1. Select the My Actions tab in the QuicKe

2. Right-click the Action you want to de

3. Select Delete from the context menu th

4. Choose Yes at the Confirm Delete promp
immediately cleared from the Action
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 Internet has become an integral part of many people’s 
puter experience. Anticipating your Internet needs, the 
ers of QuicKeys have developed the Web Launcher 

ion and Instant E-mail Actions. These Actions automate 
s such as launching Web sites and managing your 
ail.

ANT E-MAIL
ems like E-mail is suddenly the preferred mode of 
munication in our fast-paced world. So, why not make 
g it as efficient as possible? QuicKeys helps you make the 
 use of your time by providing the ability to create and 
 messages and selected files with a simple QuicKeys 

ger. 

 options available with the Instant E-mail Action include: 

ail programs that support mailto: handlers or that support 
Mail Application Program Interface (MAPI) can be used 
 the QuicKeys Instant E-mail Action. Some of the more 
mon programs that support MAPI include Microsoft® 

look, Outlook Express, Exchange client/Windows 
saging, Eudora™ Pro, Eudora™ Lite, Lotus® CC Mail, 
s Notes, and Novell® GroupWise. This list is not inclusive, 

ou should also ask your E-mail vendor whether or not 
r software supports MAPI.

SETTING UP INSTANT E-MAIL ACTION
There are two ways to create or edit QuicKey
Actions: use the Setup Wizard or use the Act
dialog.

Using the Setup Wizard
To use the Setup Wizard, select the Setup Wizar
QuicKeys Editor and click the Instant E-mail bu
pages of each wizard dialog and follow the i
the beginning of the Setup Wizard, you are p
options to Create an Action, Edit an Action, Delete an 
multiple Actions. The setup for each of these opt
within the Setup Wizard. 

• Create new message • Create message with 
text

• Send selected text • Send recent files

• Send selected files • Archive attachments

FIGURE 153: This dialog appears when you click the I
button in the Setup Wizards tab and choose to create o
mail Action.
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ng the Action Properties Dialog
 following instructions assume you have the Always use Setup 
rds for editing check box cleared in the Options dialog. See 
e 30 for more information.

se the Action Properties dialog to create or edit an 
ant E-mail Action, follow these steps:

elect Create>Internet Tools>Instant E-mail.

elect an option from the Action-specific properties pane of 
he dialog. For example, choose Create message with text and 
ype the text you want to include in your messages.

3. If you would like to restrict the functional
to your E-mail program, select the Action Sc
Program from the Scope drop-down list. Cho
program from the Program drop-down lis

FIGURE 154: The Instant E-mail Action Properties dia
you select the Instant QuicKeys Action from the Creat
you double-click an existing Instant E-mail Action in t
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4. In the General tab of the Action Properties dialog, a name is 
automatically assigned to the Action. You can use the 
assigned Action name or type a different name.

5. If you want to choose a hot key to trigger this Action, click 
in the Hot key box and press the key(s) you want to use. For 
example, press the Shift key, the Alt key, and the F7 keys 
simultaneously.

6. Click OK. Your new Action immediately appears in the My 
Actions tab.

7. Close the QuicKeys Editor.

8. Press the hot key or other trigger you assigned to the 
Instant E-mail Action. Your E-mail software should 
respond immediately to the QuicKeys Action as long as it 
handles mailto: or MAPI.

RE ABOUT INSTANT E-MAIL
QuicKeys uses your default E-mail program for Instant E-mail 
Actions. Your default mail program must support mailto: 
handling or the Mail Application Program Interface (MAPI) to 
work with QuicKeys.

STANT E-MAIL OPTIONS
Below is a description of the Action-specific properties 
available with the Instant E-mail Action.

Create new message—Opens a window where you can type 
your E-mail message.

Create message with text—Opens a message window that 
contains text you have already specified.

Send selected text—Attaches and sends selected text.

Send recent files—Displays a list of rece
you can choose to attach and send in a m
specify the time interval QuicKeys uses 
recently modified files. Your choices incl
in the last 6 hours, In the last half hour, In the last 2

Send selected files—Attaches and send

Zip attached files—Compresses attache
option when you want to compress you
Your E-mail client must support the Ma
Program Interface (MAPI) to properly e
file(s) because attachments are not self-e
the recipient of your compressed files m
unzipping files.

When QuicKeys is used to attach files, th
carrying the attachment contains a line t
attached by QuicKeys.”

Send to mailto handler—Displays a dia
choose whether to use a MAPI mail han
handler.

DELETING INSTANT E-MAIL ACTIO

To delete an Instant E-mail Action:

1. Select the My Actions tab in the QuicKe

2. Right-click the Action you want to de

3. Select Delete from the context menu th

4. Choose Yes at the Confirm Delete promp
immediately cleared from the Action
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LAUNCHER
 Web Launcher Action is useful when you want to open 
form Resource Locators (URLs) with a single hot key. For 

ple, you can use this Action to open CE Software’s home 
e with your Internet Browser. The Web Launcher Action 

des the following options: 

 Web Launcher Action supports File Transfer Protocol 
), HyperText Transfer Protocol (HTTP), and E-mail URLs. 
 means you can use the Web Launcher to visit FTP sites 
 Web sites, as well as to E-mail a friend or business 
ague. For example, if you want to use Web Launcher to 

o a secure FTP site, you would type
<username>:<password>@ftp.companyname.com.

❖ If you use Web Launcher with the America Online 
(AOL) browser, Internet Explorer is launched rather 
than the AOL browser.

NG UP WEB LAUNCHER ACTIONS
re are three ways to create and edit QuicKeys Web 
ncher Actions: use the Setup Wizard, use the Action 
erties dialog, or cut and paste a URL into the QuicKeys 

or.

Using the Setup Wizard
To use the Setup Wizard, select the Setup Wizar
QuicKeys Editor and click the Web Launcher bu
pages of each wizard dialog and follow the i
the beginning of the Setup Wizard, you are p
options to Create an Action, Edit an Action, or Delete
setup for each of these options is explained w
Wizard.

• Open URL • Open Text Selection 
As URL

• Display Netscape 
Bookmarks Browser

• Display Internet 
Explorer Favorites 
Browser

FIGURE 155: This dialog appears when you click the W
button in the Setup Wizards tab and choose to create o
Launcher Action.
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Using the Action Properties Dialog
The following instructions assume you have the Always use Setup 
Wizards for editing check box cleared in the Options dialog. See 
page 30 for more information.

To use the Action Properties dialog to create or edit a Web 
Launcher Action, follow these steps:

1. Select Create>Internet Tools>Web Launcher.

2. Select the option you want to use in the Action-specific 
properties pane of the dialog. For example, select Open URL.

3. In the General tab of the Action Proper
automatically assigned to the Action.
assigned Action name or type a diffe

4. If you want to choose a hot key to tri
in the Hot key box and press the key(s)
example, press the Shift key, the Contro
key simultaneously.

5. Click OK. Your new Action immediate
Actions tab.

6. Close the QuicKeys Editor.

7. Press the hot key or other trigger you
Action. The Web site you specified sh
immediately.

Cut and Paste URLs

1. Copy a URL to the system clipboard u
combination.

2. Open the QuicKeys Editor.

3. Paste the URL into QuicKeys by pres
combination. A pre-filled Web Launc
dialog appears.

4. Select a trigger for the Action and clic

WEB LAUNCHER OPTIONS
Below is a description of the Action-spec
available with the Web Launcher Action

Open URL—Opens the location specifie

URL—The Uniform Resource Locato
the specified page is located. Most U
http://www.cesoft.com/.

Show dialog before opening URL—
specify which URL you want to visit

URE 156: The Web Launcher Action Properties dialog appears when 
 select the Web Launcher Action from the Create menu, or when you 
ble-click an existing Web Launcher Action in the My Actions tab.
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from the
n text selection as URL—Opens selected text as a URL.

play Netscape Bookmarks browser—Displays the list of 
scape bookmarks you have accumulated in a Bookmark 

ser dialog. See Figure 157.

play Internet Explorer Favorites browser—Displays the 
f Internet Explorer favorites you have accumulated in a 

orites Browser dialog. See Figure 157.

❖ If you use AOL, use Open URL From Internet Explorer 
Favorites to display your list of favorite Web sites. 
Using this option does not display custom AOL 
items like favorite chat rooms, etc.

DELETING WEB LAUNCHER ACTIONS

To delete a Web Launcher Action:

1. Select the My Actions tab in the QuicKeys E

2. Right-click the Action you want to delete.

3. Select Delete from the context menu that ap

4. Choose Yes at the Confirm Delete prompt. Th
immediately cleared from the Actions list

 157: Open an Internet Explorer Favorite or a Netscape Bookmark 
 Web Launcher browser that appears.
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 •
DING SEQUENCES

cKeys Actions are great for simple, one-step tasks. 
ever, there are times when repetitive tasks require several 

secutive steps. For these situations, QuicKeys offers 
ences. Sequences are collections of Actions that you put 
ther to complete a multi-step task. Sequences can be as 
 or complex as you need and creating them is much easier 
 the alternative—learning a scripting language. 

example of a simple multi-step task you can replace is 
ing into your E-mail account and checking for new mail. 
re 158 illustrates how QuicKeys Sequences can help you 
mate this task. This particular Sequence will enable you 

rab a cup of coffee when you get into the office while 
cKeys prepares your list of mail. All you have to do is 
s the assigned QuicKeys trigger. When you return to your 

k, your mail will be ready for you to read and QuicKeys 
 have retreated into the background until it’s directed to 
plete other tasks.

OVERVIEW OF SEQUENCES
Building Sequences can be challenging unles
multi-step task clearly mapped out in your m
it’s important to know how QuicKeys Sequen
can make the most of their power and flexibi

There are two basic tasks you must complete
a Sequence: 

• You must record or manually create every
Action you want to include in the Sequen

• You must test and adjust your Sequence. 

❖ As you begin building Sequences w
remember that Sequences can be cr
of different ways and still be succe

This section provides some examples of wha
QuicKeys Sequences. While these particular 
not directly apply to how you intend to use Q
provide a striking illustration of how QuicKe
for just about anyone who uses a computer.

USING SEQUENCES IN INFORMATION
One task that system administrators must fre
is switching between E-mail accounts. Admi
have to assume several different electronic id
example, an administrator may have to send
systems administrator and as an individual w
Company X, depending on who is receiving 
administrator’s messages. This process of ch
mail identity can be quite time-consuming, s
candidate for automating with a QuicKeys S

 158: This example illustrates how QuicKeys Sequences can 
 routine, multi-step tasks.

your E-mail 
.

our user 
d password 
ompt.

 for new 

the OK 
 close the 
dow.

Combine these 
steps using the 
Sequence 
Editor or 
QuicKeys. 

Replace the 4-step 
task with a QuicKeys 
trigger such as a hot 
key, a toolbar button, 
an item in the 
QuicKeys menu, or a 
timed trigger.
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FIGURE
is example, an administrator changes the account 
erties in Microsoft Outlook Express to change his identity 
 Joe.Smith@cesoft.com to admin@cesoft.com.

t, look at the illustration of the Sequence in the Sequence 
or shown in Figure 159. Then, look at the instructions that 
ain how this Sequence was created to get a feel for how 
 can automate a task like this on your computer.

 the Sequence Was Created
 particular Sequence was created in three distinct parts. 
t, an Open Action was created that started Outlook 
ress. Then, the QuicKeys recording feature was put to use 
eps 2-9. Finally, there was some difficulty transitioning to 
area of the Outlook Express Properties dialog where text 
 typed so a separate Sequence was created just for that 
icular dialog. It’s a good example of how Sequences can 
hared between other Sequences using drag-and-drop 
tionality. 

e’s a play-by-play list of how this Sequence was built:

Create an Open Action

1. Create an Open Action and choose to ope
Express with a hot key trigger.

Open the Account Properties dialog in Out

1. Open Outlook Express with the hot key y
to it. Select Start Recording from the QuicKey

2. Press Alt+T to display the Tools menu.

3. Use your mouse to select Accounts from the

4. Click on the Mail tab in the Internet Accou

5. Select the account you want to change an
Properties button.

6. Click the Stop button on the Recording too
Sequence Editor appears. 

7. Name the Sequence Change E-mail Identity an
exit button. At this point, the Outlook Exp
dialog should still be in the foreground.

Type information in the Account Properties

1. Select Start Recording from the QuicKeys me

2. When you see the Recording toolbar, type
name in the Mail account box of the Properti

3. Press the Tab key to move down to the Na
name you want to use as your “new” iden

4. Press the Tab key twice to move down to th
box. Type the E-mail address you want to
“new” identity.

5. Press the Enter key to select the OK button.

6. Click the Close button in the Internet Acco

7. Press the Stop recording button on the Recor
Sequence Editor appears.

 159: A Sequence for system administrators.
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8. Click the Save & exit button. By default, the second recording 
you created is called New Recording Sequence.

Combine the three components of the Sequence

1. Now, it’s time to put the final Sequence together. Open the 
QuicKeys Editor so the Actions tab appears.

2. Open the Change E-mail Identity Sequence by double-clicking it 
in the Actions tab.

3. In the Sequence Editor, position the insertion line at the 
first step of the Sequence.

4. Position the My Actions tab so it’s tiled vertically alongside 
the Sequence Editor.

5. Drag-and-drop the Open Outlook Express Action from the 
QuicKeys Editor Actions tab to the Sequence Editor. As 
you drag the Action, your cursor becomes a plus sign (+). 
When you drop the Open Action, it is inserted where the 
insertion line is located (in the first step of the Sequence). 
This makes the Open Action a Sub-Sequence within the 
Change E-mail Identity Sequence.

6. Move the insertion line to the last step of the Sequence.

7. Drag-and-drop the New Recording Sequence you recorded 
last to the last step of the Sequence Editor.

8. Assign F3 as the hot key that triggers the Change E-mail Identity 
Sequence.

9. Close out of Outlook Express and press F3. QuicKeys 
should launch the program and change the Account 
Properties.

Now create other Sequences like this one so you can switch 
between multiple E-mail accounts with a simple keystroke.

USING SEQUENCES AS A WEBMAS
The webmaster job is one of today’s hot
defined jobs. It crosses the boundaries o
advertising, and technology. The nature 
webmasters at the heart of many of the c
activities, and the end results are seen by
even millions of people.

While the tools for creating web sites an
evolved significantly in the past few yea
that there is still substantial room for inc
Most webmasters have to use a variety o
maintain a web site. A typical toolkit ma
this:

While some tools combine a few of these
still no single solution that embraces all 
functions listed above. As a consequence
collectively is a challenge. However, Qu
can help you meet the challenges facing
providing measurable improvements in
errors, and general workload reduction.

The Typical Webmaster

• Text editor • Ja

• Page editor • F

• Browser(s) • G

• E-mail client
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distinct parts. 
d the CuteFTP 
re was put to use 

he FTP site used 
ersonal FTP Sites 

anager.

s into a commonly-
utions for Webmasters
 key to not going crazy as a webmaster is to be organized 
 to work quickly and accurately. The challenge is to 
tively use the wide array of tools to manage the contents 
at the site is up-to-date and works correctly. QuicKeys 

act as a major productivity enhancer in this environment. 
cKeys doesn’t represent one specific solution, but rather a 
ction of solutions that, applied to the webmaster’s tasks, 

yield substantial savings in time and greater efficiency.

 most powerful aspect of QuicKeys for the webmaster is 
ability to record a Sequence of actions and then play them 
. For example, launching an FTP client, typing in user and 
word information (QuicKeys encrypts the passwords it 

es), changing directories, and even moving files around 
all be part of a QuicKeys Sequence. You can customize 
r favorite page editor so that changing typeface, font size 
 style is no longer a series of mouse clicks, but rather a 
r and more reliable QuicKeys Sequence, all driven from a 
le-key press. Image editors can replay Sequences that 
ge image sizes, bit-depth, and other elements and then 
s and names the files.

 recording feature of QuicKeys can create very long and 
lved Sequences. One of the biggest strengths of this 
tion is that it provides an automation solution that works 
 virtually all of the programs a webmaster must use. And 

 of all, no scripting or programming is necessary to get a 
ence recorded.

lustrate a small sample of what QuicKeys recording can 
or you as a webmaster, the following section details the 
tion of a Sequence that starts the CuteFTP program and 
 into a frequently used ftp site.

To get a feel for how this Sequence was built
illustration of the Sequence in the Sequence E
Figure 160. Then, look at the instructions that
Sequence was created to get a feel for how yo
task similar to this on your computer.

How the Sequence Was Created
This particular Sequence was created in two 
First, an Open Action was created that starte
program. Then, the QuicKeys recording featu
in steps 2-10. 

❖ Before this Sequence was created, t
in the Sequence was added to the P
directory within the CuteFTP Site M

FIGURE 160: This Sequence launches CuteFTP and log
used FTP directory.
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s data on a network 
n tedious process of 

 want to enter or 
 work in a technical 

 open a knowledge 
o-date with the issues 
g from customers. 
etitive, and often 
when working in 

esentative logs into 
at most databases are 
 departments within 
able to use this exact 
of what you could 
Here’s a play-by-play of how this Sequence was built:

Create an Open Action

1. Create an Open Action and choose to open CuteFTP. Use 
the instructions on page 87 if you need assistance.

2. Name the Action and assign it a trigger.

Open a frequently-used FTP site

1. Open CuteFTP with the trigger you just assigned to it. 

2. Select Start Recording from the QuicKeys menu.

3. In the Site Manager window, open the Personal FTP Sites 
directory in the left pane.

4. In the right pane of the Site Manager, select the FTP site 
you want open.

5. Press Enter to connect to the site.

6. Click the OK button in the Login Messages window to close 
the window. The main CuteFTP dialog is open and the 
selected FTP site is displayed.

7. Press the Stop button on the Recording toolbar.

8. The Sequence Editor appears. Name the FTP Sequence FTP 
Login and assign it a trigger.

9. Click the Save & Exit button to save your new Sequence and 
close the Sequence Editor.

Combine the two components of the Sequence

1. Now, it’s time to put the final Sequence together. Open the 
QuicKeys Editor so the My Actions tab appears.

2. Display the Sequence Editor by double-clicking the FTP 
Login Sequence in the My Actions tab.

3. In the Sequence Editor, position the insertion line at the 
first step of the Sequence.

4. Position the My Actions tab so it’s tiled vertically alongside 
the Sequence Editor.

5. Drag-and-drop the Open CuteFTP Actio
Editor My Actions tab to the first step in
As you drag the Action, your cursor 
(+). When you drop the Open Action
the insertion line is located (in the fir
Sequence).

6. Click the Save & Exit button in the Sequ
your changes.

7. Close out of CuteFTP and press the tr
this Sequence. QuicKeys should laun
program and login to your favorite F

USING SEQUENCES WITH DATABA
If you use a database program that store
server, you may be familiar with the ofte
logging into the database each time you
retrieve information. For example, if you
support department, you might have to
database several times a day to stay up-t
other support representatives are hearin
QuicKeys can automate many of the rep
error-prone, processes that are required 
database programs.

In this example, a technical support repr
the company database. Keep in mind th
customized for different companies and
companies, so you will probably not be 
Sequence, but examine it as an example 
create with QuicKeys.



152 Chapter 13
Building Sequences

• • • •

Firs
Figu
Sequ
task

How
This
reco
from

• S

• C

• S

st is displayed

ted with a single 

ep Actions. There 
g option:

r

ing the QuicKeys 

ar appears and 
 palette options.) 
verything you do 
 you want 
he Recording 
ppears when you 
sted in the lower 

FIGURE
program
t, look at the illustration of the Sequence shown in 
re 161. Then, look at the instructions for how this 
ence was created to get a feel for how you can automate a 

 like this on your computer.

 the Sequence Was Created
 particular Sequence was created solely with the 
rding function. Once the Start Recording option was selected 
 the QuicKeys menu, the following tasks were recorded: 

tart FileMaker Pro

hoose to show FileMaker Pro Network host

elect which host server to open

• Choose which database in the selected ho

• Enter a password to the database

• Choose access privileges

• Choose how to view the database

• Maximize the database window

With QuicKeys, all these tasks can be comple
trigger.

RECORDING SEQUENCES
Recording is an easy way of creating multi-st
are three ways you can select the Start Recordin

• From the QuicKeys menu

• From the File menu in the QuicKeys Edito

• With a Start Recording hot key created us
Controller Action.

When you start recording, a Recording toolb
you are “live.” (See page 30 to set Recording
This means that QuicKeys is now watching e
on your computer. When you finish the tasks
QuicKeys to record, click the Stop button on t
palette. The Sequence Editor automatically a
click Stop. Every task you just completed is li
half of the Sequence Editor dialog.

 161: A Sequence that automates logging into a database 
.

FIGURE 162: The Recording palette

DeleteStopPause
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FIG

r half of the Sequence 
E SEQUENCE EDITOR
The Sequence Editor enables you to modify, or fine-tune, your 
Sequences. When the Sequence Editor appears, you can name 
the Sequence like you name your standard Actions and assign 
the Sequence a trigger.

The red line above the selected step is called the insertion line. 
The insertion line is useful when you need to insert another 
Action or a pause into your Sequence. The new item is 
inserted wherever the line is located.

E ACTIONS TOOLBAR
The tabs in the Sequence Editor are organized similarly to the 
QuicKeys Editor Create menu. Click a tab, such as the Network 
Tools tab, to display a group of buttons that represent each of 
the Actions contained within that category of QuicKeys tools. 
Use the buttons in this Action toolbar to add Actions to your 
Sequence.

THE RESULT COLUMN
The Result column displays the Result Hand
for a particular step in the Sequence. See
information on result handling.

THE REPEAT TAB
The Repeat tab enables you to choose whe
Sequence to repeat automatically or only
with a prompt. It also lets you choose ho
want the Sequence repeated.

PRINTING SEQUENCE STEPS
To print a list of the steps in your Sequen
Sequence Properties, open a Sequence an
Sequence Editor’s File menu.

CLOSING THE SEQUENCE EDITOR
When you are ready to close the Sequen
choose Save & Exit or Exit. Clicking the Exit 
any changes you made in the Sequence.

URE 163: The Sequence Editor

FIGURE 164: The Repeat tab appears in the uppe
Editor.
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TING SEQUENCES WITHOUT 
RDING

r you become more familiar with QuicKeys, you may find 
 it is not necessary to use the recording feature because 
 have already created all of the Actions you want in your 
ence. If you choose to create the Sequence from scratch, 

the Create menu, drag/drop, cut/paste, or import/export 
tions. When you are finished collecting the main pieces of 

r Sequence, use the Sequence tools discussed on page 160 
dd the finishing touches to your Sequence.

G THE RESULT HANDLING FEATURE
n you build Sequences, you may discover that your 
ence encounters unexpected conditions that can keep it 
 completing its assigned task successfully. To resolve this 

e, the QuicKeys Sequence Editor uses built-in result 
dling. This essentially means that you can tell each step of 
Sequence what to do if it comes across unexpected dialogs 
ther items. That way, you don’t waste your time watching 
r Sequence to ensure it doesn’t run into any obstacles 
le it’s running.

e If step succeeds and If step fails lists of the Action Properties 
og, you can direct a particular step in the Sequence to Stop 
equence, Stop the Sequence and notify user, Continue to the next step, or 
to the next step. Each result handling option is represented by 
fferent icon that displays in the Sequence Editor’s Result 
mn. You can double-click the icons to quickly change the 
lt handling option for a specific step. 

RESULT HANDLING EXAMPLE
Result Handling can be as simple or as powe
This example is relatively simple so that if yo
understand how to implement result handlin
Sequences, you can see how other people ha
In this example, a financial analyst automate
adding a comment to his finance database. K
most databases are customized for different 
departments within companies, so you will p
able to use this exact Sequence, but examine i
of what you could create with QuicKeys.

Sequence 
Icon

Definition

Continue to next step

Stop Sequence

Stop Sequence and notify 

Skip next step

Fail Sequence and notify us
only in subordinate Sequen

Fail Sequence (used only i
subordinate Sequences)
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First, look at the illustration of the Sequence shown in 
Figure 165. Then, look at the instructions for how this 
Sequence was created to get a feel for how you can automate a 
task like this on your computer.

How this Sequence Was Created
This Sequence is scoped to work only in the analyst’s database 
program. In other words, his database program must be open 
for this Sequence to function. The Sequence performs the 
following tasks:

• Types the current time and date into the record.

• Displays a Message dialog that prompts the analyst for 
additional comments. If a message is typed at the prompt, 
the Sequence continues to the next step. If a message is not 
typed at the prompt, the Sequence skips the next step.

• If a message was typed in the Message dialog, it is pasted 
into the database record and the Sequence is stopped.

• If a message was not typed in the Me
and time entry is deleted and the dat
to the state it was in at the beginning

Again, this Sequence is quite simple, bu
change your mind about entering inform
the middle of a Sequence.

EDITING SEQUENCES
If your Sequence does not behave as you
dialog shown in Figure 166 appears, you
tune your Sequence without the recorder
gives you the tools to do this. Fine-tunin
rearranging and inserting steps, as well 
tools.

INSERTING STEPS
You can insert Steps, or Actions, by selec
Create menu and creating them in the Set
Properties dialog that appears. You can i
your Sequence, select a specific window
dialog, and much more. See page 160 for
these types of Sequence tools.

You can also drag-and-drop Actions from
Editor’s Action list to the insertion poin
Editor. To do this, both windows must b

URE 165: A Sequence that uses Result Handling to add or delete 
rmation in a database.

FIGURE 166: This error dialog reveals which Seq
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ctions you create are inserted at the insertion point.

 must use copy/paste or drag-and-drop to add a Sequence 
nother Sequence. 

 Create Menu
 the Create menu to insert Actions into your Sequences.

ANGING STEPS IN THE SEQUENCE
rrange Sequence steps by dragging-and-dropping them in 
desired location within the Sequence Editor.

ING SEQUENCES
ename a Sequence, open the Sequence you want to 
me. Then, make your changes to the Sequence name and 
s the Enter key.

ING SEQUENCE STEPS
elete steps in a Sequence, open the Sequence Editor, select 

step you want to delete, and press the Delete key.

ENCE TIPS
re are some methods you can use when you build 
ences that help ensure that they function properly. This 

ion provides some basic tips for building QuicKeys 
ences.

uring recording, don’t click taskbar buttons; instead, use 
lt+Tab to select a different program. The taskbar buttons 
requently rearrange themselves on your taskbar, so 
licking on them is not a reliable method of choosing them 
n a Sequence.

se the keyboard to select options whenever possible. 
eyboard selections are more reliable than mouse clicks.

ake your movements slow and deliberate while 
ecording.

o not use a mouse wheel when you record your Actions.

• Insert Pauses in your Sequences if you are
problems getting your Sequences to play 

• Use the “Type Text” function to select item
example, it’s preferable to type the first tw
item in a drop-down list to select it rather
mouse to select it.

• Do not grab a scroll bar to scroll through 
Sequence. Instead, use the Page Up and Pag

• When you look at a particular Sequence i
Editor, it is normal for tabs and returns to
Type Keystroke Actions.

• As a matter of practice, you should not se
status area of the taskbar, or “tray,” durin
because they may not always be located i
when you trigger your Sequence.

• If you have a choice, use “Cut” and “Past
drag-and-drop.

• If you are consistently having problems w
program when you are recording Sequen
Disable smart recognition within the QuicKeys
Action. See page 57 for more information
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BORDINATE SEQUENCES
Subordinate Sequences, or “Sub-Sequences,” are Sequences 
that are embedded within other Sequences. This feature 
allows you to break a larger task into smaller tasks, which 
simplifies creating and troubleshooting complex Sequences. 

EATING SUBORDINATE SEQUENCES
You can create subordinate Sequences by opening an existing 
Sequence and selecting the Sequence option from the Create 
menu that appears. You can tell the difference between the 
Sequence Editor and the Sub-Sequence Editor by looking at 
the tabs. The Sequence Editor has five tabs: General, Repeat, 
Toolbars, Action Scope, and Timed Triggers. The Sub-
Sequence Editor only has three tabs: General, Repeat, and 
Step Results. 

❖ You can also drag-and-drop Sequences from the My 
Actions tab to create Sub-Sequences as shown in the 
example, “Using Sequences in Information 
Systems” on page 147.

HOW A SUB-SEQUENCE WORKS
To better understand Sub-Sequences, tak
following example. The example is very
illustrates the success and failure paths w
The Sequence discussed in this section i

When you press F11, this Sequence is trig
which button you press in the Message A
follow a success path or a failure path. 

FIGURE 167: This Sequence contains two Sub-Se
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one show
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ng Sequence from 
licking a Sub-
g Sub-Sequences in a Sequence

ress F11. A window appears with instructions to click OK 
o go to Sequence One or Cancel to go to Sequence Two.

lick OK to start the Sequence. Click Cancel to start Sequence 
wo.

 Sequence reacts to each choice you make by using the 
lt Handling options you have specified in each step of the 
ence.

SUB-SEQUENCE EDITOR
The Sub-Sequence Editor is composed of thre
tab, the Repeat tab, and the Step Results tab.

General Tab
Type the name of your Sub-Sequence in the G

Repeat Tab
The Repeat tab enables you to choose whether
Sequence to repeat automatically or only afte
with a prompt. It also lets you choose how m
want the Sequence repeated.You can repeat y
to 999 times.

 168: This window appears when you trigger a Sequence like the 
n in Figure 167. Depending on which button you select, the main 

e branches to different Sub-Sequences.

FIGURE 169: Open the Sub-Sequence Editor by selecti
the Create menu in the Sequence Editor or by double-c
Sequence.
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uence has completed 
Step Results Tab
Choose how you want your Sub-Sequence to react to 
successes and failures. In the If step succeeds and If step fails lists 
of the Action Properties dialog, you can direct a particular 
step in the Sequence to Stop the Sequence, Stop the Sequence and notify 
user, Continue to the next step, Skip to the next step, Fail Sequence, or Fail 
Sequence and notify user. Each result handling option is 
represented by a different icon that displays in the Sequence 
Editor’s Result column. You can right-click the icons and select 
Properties from the context menu that appears to quickly 
change the result handling option for a specific step. 

Stop Sequence—Stops the current Sequence and returns 
success to the main Sequence.

Stop Sequence and notify user—Stops the current 
Sequence, notifies user, and returns success to the main 
Sequence.

Continue to next step—Continues to the next step.

Skip next step—Skips to the next step of the current 
Sequence.

Fail Sequence—Exits the current Sequence and returns 
failure to the main Sequence.

Fail Sequence and notify user—Exits the current 
Sequence, notifies user, and returns failure to the main 
Sequence.

VING SEQUENCES
When you close the Sequence Editor, you are prompted to 
save your Sequence. If you do not choose to save your 
Sequence at that time, the Sequence will be deleted. If you are 
editing an existing Sequence and you do not choose to save 
your Sequence at the prompt, all of your changes are lost.

TRIGGERING SEQUENCES
Press the hot key you assigned to your n
the Sequence is triggered, the Playback t
page 31 for more information on the Pla
settings.) You can use this palette to pau
Sequence at any time.

When the Sequence is finished, the dialo
appears.

FIGURE 170: The Playback toolbar

FIGURE 171: This dialog appears when your Seq
successfully.
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own List

h Tabs
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G FAILED SEQUENCES
uicKeys is unable to complete a step in your Sequence that 
 the “notify user” result handling option, an alert window 
ears. Click OK to go to the failed step. Click Cancel to stop 
attempted playback of the Sequence. See page 154 for 
e information on result handling.

ACK OPTIONS
cute and repeat X times—Specifies how many consecutive 
es you want this Sequence to run. 

 for repeat count—Prompts you for the number of cycles 
cKeys should run through for this Sequence.

ING SEQUENCES
elete Sequences, select the My Actions tab in the QuicKeys 
or. Select the Sequence you want to delete and press the 
e key.

SEQUENCE TOOLS
The Sequence Editor uses Actions that are of
other contexts. These Actions are called Sequ
they include:

CHECK CONDITION
The Check Condition Sequence tool is a pow
for more advanced QuicKeys Sequences. Wit
Condition Action, you can verify that a speci
met before proceeding to the next step of the
example, you can create a Sequence that chec
time and only continues between 8:00 AM an

To insert a Check Condition Action into a S

1. Open the Sequence in which you want to
Condition Action.

2. Click the step where you want to insert th
Condition Action.

3. Select Create>Sequence Tools>Check Condition.

4. Complete the Sequence Action Properties
appears and click OK. See the Check Cond
section that follows for specific informatio
Condition option.

 172: This dialog appears when a sequence fails.

• Check Condition • Messa

• Password vault • Pause

• QuicKeys Event 
Logger

• Select
Dropd

• Select Items in List • Switc

• Wait for User Input • Wait f

• Window Selector
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FIG
Check Condition Options
Below is a description of the Action-specific properties 
available with the Check Condition Action.

Check file—Checks the presence of a user-specified file and 
optionally establishes if the file is read-only, a specific size, or 
a specific version. For example, you could insert a step in your 
sequence that checked for the presence of a specific weekly 
report that is greater or equal to 5 bytes in size.

Check folder—Checks for the presence 
folder.

Check window—Examines the status an
windows that possess the specified Title
properties. You can populate most of the
in this dialog using the Window Finder 

URE 173: The Check file Action Properties

FIGURE 174: The Check folder Action Properties
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s and/or state of 
d Type 
 boxes and menu 
se the Window Finder:

pen the window you want to examine in your Sequence.

pen the dialog shown in Figure 175. The window you 
pened in step 1 should now be behind the Check 
ondition Action Properties dialog.

lick your mouse on the Window Finder tool in the Action 
roperties dialog, and when your cursor becomes a 
agnifying glass, move your mouse over the window you 
ant to test. 

elease the Window Finder cursor when it is positioned 
ver the window you want to use in your Sequence. The 
heck window fields are automatically filled with information 
bout the selected window.

Check window control—Examines the statu
the control using the specified Text, Class, an
properties. You can populate most of the text
in this dialog using the Control Finder tool.

FIGURE 175: The Check window Action Properties
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clipboard for the 

FIG

ties
Click on the Control Finder tool and when your cursor 
becomes a magnifying glass move it to the control you want 
to test. When you release the Control Finder cursor, all the 
window control fields are filled with information.

Check clipboard—Looks at the System 
presence of a specific data type.

URE 176: The Check window control Action Properties

FIGURE 177: The Check clipboard Action Proper
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Che
runn

rrent system 

FIGURE
ck program—Verifies that a specified program exists, is 
ing, or is frontmost on your desktop.

Check current date and time—Checks the cu
date/time against the specified date/time.

 178: The Check program Action Properties FIGURE 179: Check for specific date and/or time
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 you must create a 
ts in that directory. 

 page 105), the scripts 
ropriate script engine 

nstall your script(s):

 your QuicKeys 
ld be C:\Program 
ipts.

Scripts folder. 

 the executable file 
ck.

 a custom dialog that 
quence. The dialog 
 within the Sequence.

ence:

t to insert a Message 

FIG
file
Run executable and test the result value—Launches an 
executable or a script that returns a numeric result. When you 
choose this option, you must indicate whether the executable 
is a Specified file or an Installed file. 

When you select Specified file, click the Browse button to locate 
the executable you want to use. After you select a file, you can 
specify a working directory or parameters under which the 
executable will run. You can also indicate what the Sequence 
can expect from the executable’s return code.

For the Installed file option to be available,
QKScripts directory and store your scrip
Just as the Run Script Action works (see
you add to this directory require the app
be installed on your computer.

To create the QKScripts directory and i

1. Create a folder called “QKScripts” in
directory. The path of the folder shou
Files\CE Software\QuicKeys\QKScr

2. Copy your executable(s) into the QK

3. Click the Installed file option and select
you wish to use for this condition che

MESSAGE
Use the Message Sequence tool to create
appears at a designated point in your Se
input can be used as an if/then decision

To insert a Message Action into a Sequ

1. Open the Sequence in which you wan
Action.

URE 180: Run an executable from an installed file or from a specified 
.
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 your custom 
e Sequence.

on in your 
e Sequence.

ops looking for 
og appears.

ed text on the 
 with returns.

ted, this list 
For example, it 
tinue to the next 

.

 the list that 
do next. For 
equence and 
e Sequence, or 

equences for 
s. If your 
 see what text 
.

quence:

nsert a Password 

ou want to insert 

FIGURE
osition the insertion line in the location you want to insert 
he Message Action.

elect Create>Sequence Tools>Message.

omplete the Sequence Action Properties dialog that 
ppears and click OK.

ssage Options
w is a description of the Action-specific properties 
lable with the Message Action.

sage to display—The text you want to appear in your 
om dialog.

Show OK button—Displays an OK button in
dialog that you can select to proceed with th

Show Cancel button—Displays a Cancel butt
custom dialog that you can select to cancel th

Continue automatically after X seconds—St
user input “X” seconds after the custom dial

Text entry field—Choose to place user-specifi
clipboard, to type the text, or to type the text

If step succeeds—After this Action is comple
specifies what the Sequence should do next. 
can stop the Sequence and notify the user, con
step of the Sequence, or skip to the next step

If step fails—After this Action is completed,
appears specifies what the Sequence should 
example, it can stop the Sequence, stop the S
notify the user, continue to the next step of th
skip to the next step.

PASSWORD VAULT
The Password Vault Action can be useful in S
storing information, such as E-mail password
passwords are stored, no one behind you can
you are typing to access other computers, etc

Using Password Vault
To insert a Password Vault Action into a Se

1. Open the Sequence in which you want to i
Vault Action.

2. Position the insertion line in the location y
the Password Vault Action.

3. Select Create>Sequence Tools>Password Vault.

 181: The Action Properties dialog for the Message Sequence tool
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 direct a QuicKeys 
f time before 

e:

t to insert a Pause 

ion you want to insert 

rties dialog shown in 
FIG
Seq

e Pause Sequence tool
4. Complete the Sequence Action Properties dialog shown in 
Figure 182 and click OK.

Password Vault Options
Below is a description of the Action-specific properties 
available with the Password Vault Action.

Password—The password you want the Sequence to enter.
 
If step succeeds—After this Action is completed, this list 
specifies what the Sequence should do next. For example, it 
can stop the Sequence and notify the user, continue to the next 
step of the Sequence, or skip to the next step.

If step fails—After this Action is completed, the list that 
appears specifies what the Sequence should do next. For 
example, it can stop the Sequence, stop the Sequence and 
notify the user, continue to the next step of the Sequence, or 
skip to the next step.

PAUSE
The Pause Action is useful if you need to
Sequence to wait for a specified length o
proceeding with the Sequence.

Using Pause
To insert a Pause Action into a Sequenc

1. Open the Sequence in which you wan
Action.

2. Position the insertion line in the locat
the Pause.

3. Select Create>Sequence Tools>Pause.

4. Complete the Sequence Action Prope
Figure 183 and click OK.URE 182: The Action Properties dialog for the Password Vault 

uence tool

FIGURE 183: The Action Properties dialog for th
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Pau
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Seco
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wha
the 
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If st
app
exam
noti
skip

ith the ability to 
ndows 2000 

s 95 and 

erties
se Options
w is a description of the Action-specific properties 
lable with the Pause Action.

ation—The length of the pause in measurements of 
nds or Milliseconds. These options give you precise 
rol over the duration of your pause so the Sequence takes 
onger than necessary to complete.

ep succeeds—After this Action is completed, this specifies 
t the Sequence should do next. For example, it can stop 

Sequence, stop the Sequence and notify the user, continue 
e next step of the Sequence, or skip to the next step.

ep fails—After this Action is completed, the list that 
ears specifies what the Sequence should do next. For 

ple, it can stop the Sequence, stop the Sequence and 
fy the user, continue to the next step of the Sequence, or 
 the next step.

QUICKEYS EVENT LOGGER
The QuicKeys Event Logger provides you w
write out events to the Windows NT and Wi
System Event log or to the log file on Window
Windows 98.

FIGURE 184: The QuicKeys Event Logger Action Prop



169• • • •
SE ptions

ific properties 
own List Action.

tify the dropdown list 

x or text or choose to 
 double-click the 

r by item text.

ific list controls. You 
r by text. Click the 
e Window Properties 

 the Window 
tically populate the 
perties dialog. See 

FIG
LECT ITEMS IN DROPDOWN LIST
Use Select Items in Dropdown List to check for specific combo 
box controls. Click the Specify window properties button to display 
the Window Properties dialog. Using the Window finder tool 
in the Window Properties dialog enables you to automatically 
populate the text fields and buttons in the Action Properties 
dialog. See Figure 190 on page 173.

Select Items in Dropdown List O
Below is a description of the Action-spec
available with the Select Items in Dropd

Browse—Click the Browse button to iden
containing the item you want to select.

Select item—Select an item by item inde
unselect all items. You can also choose to
selected item if you choose by item index o

SELECT ITEMS IN LIST
Use Select Items in List to check for spec
can direct QuicKeys to check by index o
Specify window properties button to display th
dialog. Using the Window finder tool in
Properties dialog enables you to automa
text fields and buttons in the Action Pro
Figure 190 on page 173.

URE 185: The Dropdown list Action Properties
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properties 
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he list containing 

ct a single item, 
select all items in 
g upon which 

d indicate 
e text you 

e to double-click 

FIGURE
Select Items in List Options
Below is a description of the Action-specific 
available with the Select Items in List Action

Browse—Click the Browse button to identify t
the item you want to select.

Do action—Choose to Select a single item, Unsele
Select a range of items, Unselect a range of items, or Un
the list. The Select by options change dependin
action you choose.

Select by—Select an item by index or text an
whether or not the text must exactly match th
specify in the Start text box. You can also choos
the selected item.

 186: The Select Items Action Properties
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SW

ific properties 

n to identify the tab 

 Specify window properties 
s dialog. Using the 
s dialog enables you 

 and buttons in the 
 on page 173.

 by item text and 
actly match the text 

put, such as a 
eding with the 
ait for any keystroke, 
click. Click one of the 
odifier key in 
 selected.

FIG
ITCH TABS
To switch tabs in a Sequence, specify the tab controls in the 
Switch Tabs Action Properties dialog. Click the Specify window 
properties button to display the Window Properties dialog. 
Using the Window finder tool in the Window Properties 
dialog enables you to automatically populate the text fields 
and buttons in the Action Properties dialog. See Figure 190 on 
page 173.

Switch Tabs Options
Below is a description of the Action-spec
available with the Switch Tabs Action.

Find tab control—Click the Browse butto
control on which to operate.

Find tab control on window—Click the
button to display the Window Propertie
Window finder in the Window Propertie
to automatically populate the text fields
Action Properties dialog. See Figure 190

Select tab—Select a tab by item index or
indicate whether or not the text must ex
you specify.

WAIT FOR USER INPUT
Direct your Sequence to wait for user in
keystroke or a mouse click, before proce
Sequence. You can have the Sequence w
a specific keystroke, or a specific mouse 
modifier check boxes to use a specific m
combination with the mouse button you

URE 187: The Switch Tabs Action Properties
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WAIT F
The
spec
Qui
For 
you
you
in th

lay the Window 
tool in the 
tomatically 
tion Properties 

equence:

 insert a Wait for 

ou want to insert 

FIGURE

t for window 
OR WINDOW
 Wait for Window Sequence tool gives you the ability to 
ify which window or what type of window you want 

cKeys to look for when it is cycling through a Sequence. 
example, if your Sequence opens several windows and 
 want to choose an option in the window named Browse, 
 just need to specify Wait for window whose title contains Browse 
e Sequence Action Properties dialog.

Click the Specify window properties button to disp
Properties dialog. Using the Window finder 
Window Properties dialog enables you to au
populate the text fields and buttons in the Ac
dialog. See Figure 190.

Using Wait for Window
To insert a Wait for Window Action into a S

1. Open the Sequence in which you want to
Window Action.

2. Position the insertion line in the location y
the Wait for Window Action.

3. Select Create>Sequence Tools>Wait for window.

 188: The Wait for User Input Action Properties

FIGURE 189: The Action Properties dialog for the Wai
Sequence tool.
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dow appears, 
inactive.

 for the Action “X” 
 triggered.

mpleted, this list 
ext. For example, it 
r, continue to the next 
step.

eted, the list that 
uld do next. For 
he Sequence and 
 of the Sequence, or 
4. Complete the Sequence Action Properties and click OK.

Wait for Window Options
Below is a description of the Action-specific properties 
available with the Wait for Window Action.

Wait for window whose title contains—Type the name that 
appears in the window’s title bar in this box.

Wait for Window with selected properties—Click the Select 
properties box to display the window selection dialog.

Window Properties—Choose the properties a window 
must possess to satisfy the Wait command. If you select the 
Window finder icon, wait until your cursor becomes a 
magnifying glass and drag it to the window you want to 
select. When you drag the Window finder icon, all the other 
Window Selector fields are filled with information. Click OK 
when you are finished with Window Selector. See 
Figure 189.

•Window name is the name in the title bar.
•Window class can be populated using the Window 

finder tool.
•A Top Level Window is a program or system window. 

A Popup Window is a secondary dialog within a pro-
gram.

•Click the Window finder icon and drag it to the win-
dow you want to select in your Sequence. As you drag, 
your cursor becomes a magnifying glass and the Win-
dow name, class, and type fields change dynamically, 
depending on where the cursor is positioned. 

•Select the Hide QuicKeys Editor check box when you 
want the Editor dialog to disappear while you use the 
window finder tool.

Wait until window—Waits until the win
disappears, becomes active, or becomes 

Give up after X seconds—Stops looking
seconds after this step of the Sequence is

If step succeeds—After this Action is co
specifies what the Sequence should do n
can stop the Sequence and notify the use
step of the Sequence, or skip to the next 

If step fails—After this Action is compl
appears specifies what the Sequence sho
example, it can stop the Sequence, stop t
notify the user, continue to the next step
skip to the next step.

FIGURE 190: The Window Properties dialog 
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S
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equence Editor. 

on if you want to 
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FIGURE
Sequenc
W SELECTOR
 the Window Selector to choose a program window in a 
ence. Click the Specify window properties button to display the 

dow Properties dialog. Using the Window finder tool in 
Window Properties dialog enables you to automatically 
ulate the text fields and buttons in the Action Properties 
og. See Figure 190.

nsert a Window Selector Action into a Sequence:

pen the Sequence in which you want to insert a Window 
elector Action.

osition the insertion line in the location you want to insert 
he Window Selector Action.

elect Create>Sequence Tools>Window Selector.

omplete the Sequence Action Properties dialog and click 
K.

Window Selector Options
Below is a description of the Action-specific 
available with the Window Selector Action.

Select window whose title contains—The n
window for which you want the Sequence to

Select window with selected properties—E
Properties button.

Select Properties—Displays the dialog show
and discussed on page 173.

If step succeeds—After this Action is comple
specifies what the Sequence should do next. 
can stop the Sequence, stop the Sequence and
continue to the next step of the Sequence, or 
step.

If step fails—After this Action is completed,
appears specifies what the Sequence should 
example, it can stop the Sequence, stop the S
notify the user, continue to the next step of th
skip the next step.

CLEARING SELECTED HOT KEY
When you no longer want a hot key assigned
Sequence, click the Clear hot key button in the S
You may want to take advantage of this opti
make this Sequence part of a larger Sequence
the assigned hotkey for a different Action.

 191: The Action Properties dialog for the Window Selector 
e tool.
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ENDIX A:

 •
 AND TROUBLESHOOTING

 section provides tips for using QuicKeys and describes 
tions for some common problems you may encounter 
n using QuicKeys.

ou can drag files to the QuicKeys Editor to create Open 
ctions.

ou can drag text to the QuicKeys Editor to create Type 
ext Actions.

peed up the process of creating and editing Actions by 
nchecking the Show Setup Wizard introduction page and Always 
se Setup Wizards for editing check boxes in the Options dialog. 
ee page 30 for more information.

ou can right-click an Action in the QuicKeys Editor and 
hoose Cut or Copy from the context menu that appears. 
hen you can set the insert arrow in the Sequence Editor, 
ight-click and choose Paste from the context menu to paste 
our Action into the Sequence. 

ou can create a Windows Selector Action if you use a 
aptop computer so that you can see all your open 
rograms without running out of room on the taskbar. The 
indows Selector Action is available in the Sequence Tools 

ubmenu of the Create menu.

ress Control+Tab to insert a tab in the Type Text Action 
roperties dialog.

f you have a scrolling mouse button between your right 
nd left mouse buttons do not use it to record your 
ctions.

• If you use Web Launcher with the Americ
browser, Internet Explorer is launched rat
browser.

• If you want the hot help that appears ove
to be more descriptive, change the name o
represented by the toolbar button. The ho
are filled by the information you provide 
of your Actions.

• Cut and paste URLs into the QuicKeys Ed
create Web Launcher Actions.

• Press Ctrl+Esc to stop Quick Type while it i

TROUBLESHOOTING
• Make sure you are very careful about assi

as your hot key triggers. For example, ass
Backspace key for the Open Microsoft Ex
could get irritating after a few minutes. If
to assign a single key as your hot key, Qu
warning dialog. The warning dialog is pe
turned off if you check the Do not ask me this
within the dialog.

• If you are using Windows NT, installation
while logged in as an administrator or as 
administrative rights.

• If you are consistently having problems w
program when you are recording sequenc
Disable smart recognition within the QuicKeys
Action.

• You must have a sound card for the Multi
work properly.
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ou can 
 QuicKeys button 

 difficulty 
 that ports 37 or 
ator for more 

 when you select 
t connection. If 
roperly, call CE 

u probably have 
en you restart 
ate Actions after 
re stored in a 
e and password. 

le users can log 
 yet retain their 
 is invisible to 

ncerned about 
esktop Scope is limited to the actual desktop being 
ctive. It does not include drive windows.

f you deselect Show Wizards For Editing, you see a different 
ialog when you edit an Action in the My Actions tab.

he Windows Specials Up one folder Action does not navigate 
p one folder level if you are using it within a standard 
indows Explorer window. It only works within Open or 

ave dialogs.

f you choose to open Microsoft Explorer in Full Screen view 
ver an auto hide toolbar, the auto hide toolbar will remain 
ehind the Explorer window until you close the toolbar 
nd reopen it.

f one of your QuicKeys triggers suddenly doesn’t work, 
ake sure you don’t have a QuicKeys dialog open on your 

esktop. When a QuicKeys dialog is open, the QuicKeys 
enu in the status area has a red X over it.

f you only see a few buttons in your Setup Wizards tab, click 
he drop-down list arrow at the top of the tab and select All 
izards from the list that appears. All your Setup Wizard 
uttons should immediately return.

ou must exit the Clipboard Editor before you can see 
our newly added clips in the Prompt for item to paste window.

ou must have an insertion point available before the 
uicKeys Clipboard paste function works properly.

f you delete, rename, or move custom icons that are used 
n toolbars, the toolbar button that used that icon will no 
onger display that graphic.

t is possible to add toolbar buttons to toolbars that have a 
ifferent scope than the Actions represented by the toolbar 
uttons. This capability may keep the Action that is 
riggered with the toolbar button from functioning 
roperly. For example, a toolbar button representing a 
icrosoft Word Action can be added to a toolbar that only 
orks in Internet Explorer.

• If you have an Action that doesn’t functio
toolbar trigger, try using a hot key trigger

• Make sure when you create toolbar trigge
not create an infinite loop. For example, y
repeatedly choose the current toolbar as a
in the Toolbar Button Wizard.

• If you are using a firewall and are having
connecting to a remote time server, check
123 are open. See your network administr
information.

• If you are experiencing frequent timeouts
Check for QucKeys updates, check your Interne
your Internet connection is functioning p
Software’s technical support team.

MULTI-USER WORKSTATIONS
If your Windows machine is on a network, yo
to provide your user name and password wh
your computer. If you start QuicKeys and cre
completing the login process, those Actions a
preference file that is linked to your user nam
The benefit of this architecture is that multip
into the network from the same workstation,
own personal QuicKeys Actions. The process
you, but it’s important to know if you are co
your Actions being used by someone else.
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ENDIX B:

 •
ATING CUSTOM TOOLBAR ICONS

 chapter discusses how to create icons that can be used in 
cKeys toolbars. The ability to create your own toolbar 
s enables you to completely customize how QuicKeys 
bars look and function.

G BITMAP IMAGES
u have a company logo or some other graphic saved as a 
ap, you can use it in a QuicKeys toolbar. Unlike icons, 

cKeys toolbars save bitmap images internally, so even if 
 delete the original image, your toolbar icons will remain 
ct.

se a bitmap image in your toolbar:

ight-click the icon you want to replace on the toolbar and 
elect Set icon from bitmap. A standard Open dialog appears.

avigate to the bitmap image you want to use

elect the bitmap image and click Open. The bitmap image 
ppears as a button on your QuicKeys toolbar.

RING DEFAULT ICONS
u don’t like the button changes you made to your 

cKeys toolbar, you can easily restore your icon buttons to 
r original appearance. Just right-click the toolbar button 
 want to replace and select Restore default icon.

TING AN ICON
u are a graphics professional and know how to create 
s, this section is for you. The first step in using one of your 
 icons in a QuicKeys toolbar is creating the icon. Icons 
ire the .ico extension in the file name and they must equal 

16 or 32x32 pixels.

The following example uses Microsoft’s Pain
most Windows users install it with the system
However, you can also use other graphics pr
icons, such as Adobe® Photoshop®.

To create an icon:

1. Open the Paint program that is installed w
installations of Windows.

2. Select Attributes from the Image menu.

3. In the Attributes dialog, type 32 in the Wid
fields. 

❖ You can also type 16 in both fields 
create a smaller icon.

4. Select Pels in the Units area to use Pixels a
measurement.

5. Select whether you want to use black and wh
your icon. 

6. Click OK when you are done. A blank squa
Paint dialog.

FIGURE 192: The Attributes dialog
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log.

ted.

 Icon dialog 

click OK. The new 
ou selected.FIGURE

line tool,
se the tools in the Paint program’s tool palette to create 
n image. 

elect Save as from the File menu.

avigate to the location on your hard drive where you 
ant to save this icon.

ype a name for the icon in the File name box. For example, 
ype greenface.ico to mark the file as an icon file.

elect 24-bit Bitmap from the Save as type drop-down list. 

lick Save. The new icon is saved to the location you 
pecified.

ING THE ICON IN QUICKEYS
 next step in customizing your toolbar buttons is adding 
r new icon to your toolbar buttons.

To set a custom toolbar icon:

1. Right-click a button on an open toolbar.

2. Select Set icon from file.

3. Click the Browse button in the Select Icon dia

4. Navigate to the custom icon you just crea

5. Choose the icon and click Open. The Select
appears.

6. Select the icon in the Select Icon dialog and 
icon appears immediately on the toolbar y 193: The icon in this example was created with the circle tool, the 

 and the pen tool.

FIGURE 194: The toolbar button menu
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PENDIX C:

 • • • •
E QUICKEYS ARCHITECTURE

QuicKeys is composed of three primary components: the QuicKeys Editor, the QuicKeys Engine, and QuicKey
those three primary components are several secondary components. To help you visualize this architecture, see 

QuicKeys 
Editor

Sequence 
Editor

Keyset Manager

Setup Wizard Manager

Action Editor Manager

QuicKeys 
Engine

Scope 
Manager

Playback Manager

Recording Manager

Toolbar Manager

Trigger Manager

OLE Automation Interface

VB Script Office Programs Other Tools

P
lu

g
-In

 A
P

I

Plug-in

Plug-in

Plug-in

Plug-in
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OT KEYS THAT CANNOT BE USED

There are some hot keys that QuicKeys cannot use because the hot key is reserved for another function. This ap
“blacklisted” hot keys along with a brief explanation of why they cannot be used.

Hot Key Why it can’t be used

F1 Opens QuicKeys Windows online Help

Windows+E Starts Windows Explorer

Control+Escape Opens the Start menu

Alt+Tab Opens the next program listed on the taskbar

Windows+Tab Selects the next taskbar button

Windows+F Locates files or folders

Windows+Control+F Finds a computer on the network

Windows+F1 Opens Windows online Help

Windows+R Opens the “Run” dialog

Windows+Pause Opens the System Properties control panel

Windows+E Opens Windows Explorer

Windows+D Shows the desktop

Windows+M Minimizes all windows

Windows+Shift+M Maximizes all windows

F12 (in NT and Windows 2000) Used by the Windows NT and Windows 2000 
operating system
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ion—Tasks QuicKeys completes. For example, you can 
ger an Action by selecting the hot key you assigned to the 
ion.

ion scope—The range of operation for an Action. For 
ple, you can create Actions that only work when 

rosoft Word is active or Actions that work in any active 
dow on your computer.

ion set— A collection of Actions or Sequences used 
arily in the context of importing or exporting Actions. 

example, users can export an Action Set and share it with 
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 and graphics. 
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cKeys menu—The context menu that appears when you 
t-click the QuicKeys icon located by default in the status 
 of the taskbar (also referred to as the Tray). 

ckStart Wizard—The wizard that appears automatically 
n you have not yet created any Actions in QuicKeys or 
n you select Run QuickStart Wizard from the QuicKeys Editor 
 menu.

—The appearance of a file when it is opened with the 
n Action.

e—The range of operation for an Action. For example, 
 can create Actions that only work when the Microsoft 
d is active or Actions that work in any active window on 
r computer.

uence—A series of Actions that execute consecutively.

p Wizards—The screens that help you create various 
s in a step-by-step fashion. 

rtcut—The icon that appears when you drag a QuicKeys 
on to the desktop and it becomes an “official” Microsoft 
tcut.

bar—The bar that appears by default at the bottom of the 
dows desktop. A QuicKeys icon appears in the status area 
e taskbar (also referred to as the Tray). When you right-
 the QuicKeys menu, a context menu appears that makes 

lbars, recording options, and open and exit options 
lable.

le—Turns a particular mode on or off. For example, you 
toggle hot keys on or off.

bar—The graphical palettes you can use to trigger Actions 
 display Action menus.

trigger—Directs QuicKeys to start an Action

URL—Uniform Resource Locator. The World
(WWW) consists of URLs that take you to sp
For example, CE Software’s URL is http://w

volume—The level of sound on your compu
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	2. Select Toolbar Button Wizard from the context menu that appears.
	3. Read the introduction page of the wizard that appears and click Next.
	Figure 56: The Toolbar Button Wizard introduction page

	4. Select the check box(es) for each program you would like to display in your toolbar.
	5. Click Next.
	6. Select the check box(es) for each QuicKeys Action you would like to display in your toolbar. I...
	7. Click Next.
	8. Select the check box(es) for each QuicKeys Action menu you would like to display on your toolbar
	9. Click Next.
	10. Read the final wizard page and click Finish. The toolbar displays with the additional buttons...

	Adjusting Toolbar Button Size
	Changing Button Icons
	Using Icons Supplied with QuicKeys
	To select sample icons:
	1. Right-click a button on an open toolbar.
	2. Select Set icon from file.
	3. Select an icon collection from the Icon File drop-down list. You can choose from workplace ico...
	Figure 57: Choose an icon from one of the icon sets installed with QuicKeys.

	4. Click the icon you want to use. The icon darkens when it is selected.
	5. Click OK when you have selected the icon you want to use on your toolbar. The new icon appears...


	Using Custom Icons
	To select custom icons:
	1. Right-click a button on an open toolbar.
	2. Select Set icon from file.
	3. Click the Browse button.
	4. Navigate to the icon file you want to use.
	5. Choose the icon file you want to use and click Open. The contents of the icon file you selecte...
	Figure 58: The collection of icons shown in this graphic was selected by clicking the Browse butt...

	6. Select an icon from your new icon file and click OK. The new icon appears on the toolbar you s...


	Using Bitmap Images
	Figure 59: In this illustration, the QuicKeys Web Launcher icon is replaced by a custom bitmap gr...
	To select a bitmap file:
	1. Right-click a button on an open toolbar.
	Figure 60: Select a standard bitmap file to use as toolbar icons.

	2. Select Set icon from bitmap.
	3. Navigate to the bitmap graphic you want to use. The graphic must use the .bmp extension in the...
	4. Choose the graphic you want to use and click Open.


	Restoring Icons


	Deleting Toolbar Buttons
	Figure 61: To delete a toolbar button, right-click the toolbar button and select Delete Button fr...


	Chapter�5
	Controlling The QuicKeys Program
	QuicKeys Controller
	Setting Up QuicKeys Controller Actions
	Using the Setup Wizard
	Figure 62: This dialog appears when you click the QuicKeys Controller button in the Setup Wizards...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit a QuicKeys Controller Action, follow these ...
	1. Select Create>QuicKeys Tools>QuicKeys Controller.
	Figure 63: The QuicKeys Controller Action Properties dialog appears when you select the QuicKeys ...

	2. Choose an option from the Action-specific properties pane of the dialog. The available options...
	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	4. If you want to choose a hot key to trigger this Action, click in the Hot key box and press the...
	5. Click OK. Your new Action immediately appears in the My Actions tab.
	6. Close the QuicKeys Editor and press the hot key you selected. The Action-specific option you s...



	QuicKeys Controller Options
	Deleting QuicKeys Controller Actions
	To delete a QuicKeys Controller Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is immediately cleared from the Actions list.



	Chapter�6


	Typing with QuicKeys
	Using Advanced Text Tools
	Setting Up Advanced Text Tools Actions
	Using the Setup Wizard
	Figure 64: This dialog appears when you click the Advanced Text Tools button in the Setup Wizards...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit an Advanced Text Tools Action, follow these...
	1. Select Create>Text Tools>Advanced Text Tools.
	2. Select an Action from the Action drop-down list.
	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	Figure 65: The Advanced Text Tools Action Properties dialog appears when you select the Advanced ...

	4. If you want to choose a hot key to trigger this Action, click in the Hot key box and press the...
	5. Click OK. Your new Action appears in the My Actions tab.
	6. Close the QuicKeys Editor and open a word processing program. Select a block of text and press...



	Advanced Text Tools Options
	Figure 66: The graphic on the left illustrates text copied from a Web page before it is reformatt...
	Figure 67: The top graphic shows an E-mail message that contains quote marks. The bottom graphic ...

	Deleting Advanced Text Tools Actions
	To delete an Advanced Text Tools Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is cleared from the Actions list.



	Using Quick Type
	Setting Up Quick Type Actions
	Using the Setup Wizard
	Figure 68: This dialog appears when you click the Quick Type button in the Setup Wizards tab and ...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit a Quick Type Action, follow these steps:
	1. Select Create>Text Tools>Quick Type.
	2. Select an Action from the Action drop-down list.
	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	Figure 69: The Quick Type Action Properties dialog appears when you select the Quick Type Action ...

	4. Assign a trigger to the Action.
	5. Click OK. Your new Action appears in the My Actions tab.
	6. Close the QuicKeys Editor.



	Quick Type Options
	The Quick Type Glossary
	To add text to your glossary:
	1. Click the Edit glossary button in the Quick Type Setup Wizard or Action Properties dialog. (Se...
	2. In the Quick Type Glossary window, click the Add button.
	Figure 70: The Quick Type Glossary window

	3. In the Edit Glossary Entry dialog, specify the text key that will trigger the Action, the appl...
	Figure 71: The Edit Glossary Entry dialog

	4. Click OK to return to the Quick Type Glossary window.
	5. Click Done in the Quick Type Glossary window when you are finished.



	Deleting Quick Type Actions
	To delete a Quick Type Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is cleared from the Actions list.



	Using Check Spelling
	Setting Up Check Spelling Actions
	Using the Setup Wizard
	Figure 72: This dialog appears when you click the Check Spelling button in the Setup Wizards tab ...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit a Check Spelling Action, follow these steps:
	1. Select Create>Text Tools>Check Spelling.
	2. Select an Action and a dictionary.
	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	Figure 73: The Check Spelling Action Properties dialog appears when you select the Check Spelling...

	4. Assign a trigger to the Action.
	5. Click OK. Your new Action appears in the My Actions tab.



	Check Spelling Options
	Figure 74: The Personal Dictionaries dialog
	Figure 75: The Language Options window

	Deleting Check Spelling Actions
	To delete a Check Spelling Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is cleared from the Actions list.



	Special Characters
	Setting Up Special Characters Actions
	Using the Setup Wizard
	Figure 76: This dialog appears when you click the Special Characters button in the Setup Wizards ...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit a Special Characters Action, follow these s...
	1. Select Create>Text Tools>Special Characters.
	2. Select the font you want to view.
	3. Select the character you want to type.
	4. In the General tab of the Action Properties dialog, type a name for this Action in the Name box.
	Figure 77: Select the character you want to type in the Action-specific properties pane. If you w...

	5. If you want to choose a hot key to trigger this Action, click in the Hot key box and press the...
	6. Click OK. Your new Action appears in the My Actions tab.
	7. Close the QuicKeys Editor and open a word processing program. Position your cursor in the docu...



	Special Characters Options
	Deleting Special Characters Actions
	To delete a Special Characters Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is cleared from the Actions list.



	Typing the Date and Time
	Setting Up Type Date/Time Actions
	Using the Setup Wizard
	Figure 78: This dialog appears when you click the Type Date/Time button in the Setup Wizards tab ...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit a Type Date/Time Action, follow these steps:
	1. Select Create>Text Tools>Type Date/Time.
	2. Select the Date/Time format you want to use from the Format drop-down list.
	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	Figure 79: The Type Date/Time Action Properties dialog appears when you select the Type Date/Time...

	4. If you want to trigger this Action from the QuicKeys menu, click the Include in QuicKeys menu ...
	5. Click OK. Your new Action appears in the My Actions tab.
	6. Close the QuicKeys Editor.
	7. Open a document in a word processing program.
	8. Trigger the Type Date/Time Action you created. The date and time you specified is typed into t...



	Type Date/Time Options

	Date/Time Abbreviation
	Meaning
	Figure 80: Use the Custom Date/Time Builder to build your own date and time formats.

	If you combine these custom formats in the Custom Date/ Time Builder...
	Your Date/Time Action types something similar to this...
	Deleting Type Date/Time Actions
	To delete a Type Date/Time Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is cleared from the Actions list.


	Typing Text
	Setting Up Type Text Actions
	Using the Setup Wizard
	Figure 81: This dialog appears when you click the Type Text button in the Setup Wizards tab and c...

	Using the Action Properties Dialog
	To use the My Actions tab to create or edit a Type Text Action, follow these steps:
	1. Select Create>Text Tools>Type Text.
	2. Type the text you want to use when you trigger this Action.
	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	Figure 82: The Type Text Action Properties dialog appears when you select the Type Text Action fr...

	4. If you want to choose a hot key to trigger this Action, click in the Hot key box and press the...
	5. Click OK. Your new Action appears in the My Actions tab.
	6. Close the QuicKeys Editor and open your E-mail program. Position your cursor in the document a...


	Using Drag-and-Drop Functionality
	Cutting and Pasting Text
	To create a Type Text Action using cut and paste:
	1. Select a block of text.
	2. Copy it to the Clipboard.
	3. Right-click in the Setup Wizards tab, the My Keyboard tab, or the My Actions tab of the QuicKe...



	Editing Type Text Actions
	To edit a Type Text Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Double-click the Action you want to edit.
	3. Make the necessary changes in the Action Properties dialog and click OK.


	Deleting Type Text Actions
	To delete a Type Text Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is cleared from the Actions list.




	Chapter�7

	Working With Files and Folders
	File Handler
	Setting Up File Handler Actions
	Using the Setup Wizard
	Figure 83: This dialog appears when you click the File Handler button in the Setup Wizards tab an...

	Using the Action Properties Dialog
	To use the Actions Properties dialog to create or edit a File Handler Action, follow these steps:
	1. Select Create>File & Folder Tools>File Handler.
	2. Choose an option from the Action-specific properties pane of the dialog. For example, choose t...
	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	Figure 84: The File Handler Action Properties dialog appears when you select the File Handler but...

	4. If you want to choose a hot key to trigger this Action, click in the Hot key box and press the...
	5. Click OK. Your new Action appears in the My Actions tab.
	6. Close the QuicKeys Editor.
	7. Select a group of files or folders and press the hot key or other trigger you assigned to this...



	Triggering File Handler Actions
	File Handler Options
	Figure 85: Use the lower half of the Action Properties dialog to specify Action-specific options.
	Figure 86: This dialog appears when you have the “Ask for extension” check box selected.
	Figure 87: Action-specific properties for moving files or folders
	Figure 88: Action-specific properties for copying files or folders
	Using the Rename Files or Folders Action
	To rename files and folders using prefix text:
	1. Select Rename Files or Folders in the Action drop-down list of the File Handler’s Action Prope...
	2. Select Prefix Text in the Style drop-down menu.
	3. Type the text you want to use as a prefix in the names of the selected files or folders. An ex...
	Figure 89: Prefix text options

	4. Click OK when you are finished.

	To rename files and folders using a prefix variable:
	1. Select Rename Files or Folders in the Action drop-down list of the File Handler’s Action Prope...
	2. Select Prefix Variable in the Style drop-down list.
	3. Choose the variable you want to use as a prefix in the names of the selected files or folders....
	Figure 90: The Prefix Variable option

	4. Click OK when you are finished.

	To rename files and folders using a variable and text:
	1. Select Rename Files or Folders in the Action drop-down list of the File Handler’s Action Prope...
	2. Select Variable & Text in the Style drop-down list.
	3. Type the text you want to use in the Text box.
	4. Choose the variable you want to use from one of the Variable radio buttons. An example of what...
	Figure 91: The Variable Text option

	5. Click OK when you are finished.

	To rename files and folders using text and a variable:
	1. Select Rename Files or Folders in the Action drop-down list of the File Handler’s Action Prope...
	2. Select Text & Variable in the Style drop-down list.
	3. Type the text you want to use in the Text box.
	4. Choose the variable you want to use from one of the Variable radio buttons.
	Figure 92: The Text & Variable option

	5. Click OK when you are finished.

	To rename files and folders by appending text:
	1. Select Rename Files or Folders in the Action drop-down list of the File Handler’s Action Prope...
	2. Select Append Text in the Style drop-down list.
	3. In the Text box, type the text you want to add to the end of the file or folder name. An examp...
	Figure 93: The Append Text option

	4. Click OK when you are finished.

	To rename files and folders by appending a variable:
	1. Select Rename Files or Folders in the Action drop-down list of the File Handler’s Action Prope...
	2. Select Append Variable in the Style drop-down list.
	3. Select the variable you want to add to the end of the file or folder name from the Variable ra...
	Figure 94: The Append Variable option

	4. Click OK when you are finished.

	To rename files and folders using a fixed name:
	1. Select Rename Files or Folders in the Action drop-down list of the File Handler’s Action Prope...
	2. Select Fixed Name in the Style drop-down menu.
	3. Type the name you want to use for the currently selected or pre-specified file or folder.
	Figure 95: Fixed name options

	4. Click OK when you are finished.



	Deleting File Handler Actions
	To delete a File Handler Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is cleared from the Actions list.



	Folders
	Pre-defined Actions
	User-defined Actions
	Setting Up Folders Actions
	Using the Setup Wizard
	Figure 96: This dialog appears when you click the Folders button in the Setup Wizards tab and cho...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit a Folders Action, follow these steps:
	1. Select Create>File & Folder Tools>Folders.
	2. Choose an option from the Action-specific properties pane of the dialog.
	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	Figure 97: The Folders Action Properties dialog appears when you select the Folders Action from t...

	4. If you want to choose a hot key to trigger this Action, click in the Hot key box and press the...
	5. Click OK. Your new Action appears in the My Actions tab.
	6. Close the QuicKeys Editor.
	7. Open a word processing program and select the Save As option.
	8. Press the Folders hot key. The folder you selected appears within the standard Save dialog or ...



	Triggering Folders Actions
	Folders Options
	Figure 98: The Folders options in the Action Properties dialog

	Deleting Folders Actions
	To delete a QuicKeys Folders Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is cleared from the Actions list.


	The Open Action
	Setting Up the Open Action
	Using the Setup Wizard
	Figure 99: This dialog appears when you click the Open button in the Setup Wizards tab and choose...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit an Open Action, follow these steps:
	1. Select Create>File & Folder Tools>Open.
	2. Choose option(s) from the Action-specific properties pane of the dialog. For example, choose P...
	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	4. Click in the Hot key box and press the key(s) you want to use to trigger the Open Action. For ...
	Figure 100: The Open Action Properties dialog appears when you select the Open button from the Cr...

	5. Click OK. Your new Action appears in the My Actions tab.
	6. Close the QuicKeys Editor and press the hot key you assigned to this Action. The file or progr...


	Using Drag-and-Drop Functionality
	Copying and Pasting Files and Folders
	To create an Open Action using cut and paste:
	1. Select one or several files or folders.
	2. Right-click the selected file and folders and choose Copy from the context menu that appears.
	3. Right-click in the Setup Wizards tab, the My Keyboard tab, or the My Actions tab in the QuicKe...



	Open Options
	Deleting Open Actions
	To delete a QuicKeys Open Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is cleared from the Actions list.



	Recent Files
	Setting Up Recent Files Actions
	Using the Setup Wizard
	Figure 101: This dialog appears when you right-click the Recent Files button in the Setup Wizards...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit a Recent Files Action, follow these steps:
	1. Select Create>File & Folder Tools>Recent Files.
	2. Choose an option from the Action-specific properties pane of the dialog. For example, choose I...
	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	Figure 102: The Recent Files Action Properties dialog appears when you select Recent Files from t...

	4. If you want to trigger this Action from the QuicKeys menu, click the Include in QuicKeys menu ...
	5. Click OK. Your new Action appears in the My Actions tab.
	6. Close the QuicKeys Editor and select the Recent Files Action from the QuicKeys menu. All the f...



	Deleting Recent Files Actions
	To delete a QuicKeys Recent Files Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is cleared from the Actions list.



	Zip Files
	Setting Up Zip Files Actions
	Using the Setup Wizard
	Figure 103: This dialog appears when you click the Zip Files button in the Setup Wizards tab and ...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit a Zip Files Action, follow these steps:
	1. Select Create>File & Folder Tools>Zip Files.
	2. Choose an option from the Action-specific properties pane of the dialog. For example, choose A...
	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	Figure 104: The Zip Files Action Properties dialog appears when you select Zip Files from the Cre...

	4. Select a trigger for the Action.
	5. Click OK. Your new Action appears in the My Actions tab.
	6. Close the QuicKeys Editor and trigger the Zip Files Action.



	Zip Files Options
	Deleting Zip Files Actions
	To delete a QuicKeys Zip Files Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is cleared from the Actions list.




	Chapter�8

	Using System Tools
	Button Click
	Setting Up Button Click Actions
	To insert a Button Click Action in a Sequence:
	1. Open the Sequence Editor.
	2. Position the insert arrow where you want to insert the Button Click in the Sequence.
	3. Select Create>System Tools>Button Click.
	4. Complete the Sequence Action Properties dialog that is shown in Figure�105 and click OK.
	Figure 105: The Action Properties dialog for the Button Click Sequence tool



	Button Click Options
	Figure 106: This is an illustration of how QuicKeys defines which buttons are “on” and which are ...

	Deleting Button Click Actions
	To delete a QuicKeys Button Click Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.



	Mouse Click
	Setting Up a Mouse Click Action
	To insert a Mouse Click Action in a Sequence:
	1. Open the Sequence in which you want to insert a Mouse Click.
	2. Position the insert arrow where you want to insert the Mouse Click in the Sequence.
	3. Select Create>System Tools>Mouse Click.
	4. Complete the Sequence Action Properties dialog that is shown in Figure�107 and click OK.
	Figure 107: The Action Properties dialog for the Mouse Click Sequence tool



	Mouse Click Options
	Deleting Mouse Click Actions
	To delete a Mouse Click Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.



	Mouse Position
	Setting Up a Mouse Position Action
	To create a Mouse Position Action:
	1. Open the Sequence in which you want to insert a Mouse Position.
	2. Position the insert arrow where you want to insert the Mouse Position in the Sequence.
	3. Select Create>System Tools>Mouse Position.
	4. Complete the Mouse Position Action Properties dialog that is shown in Figure�108 and click OK.
	Figure 108: The Action Properties dialog for the Mouse Position Sequence tool



	Mouse Position Options
	Deleting Mouse Position Actions
	To delete a Mouse Position Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.



	QuicKeys Clipbook
	Figure 109: To use the QuicKeys Clipbook, you first add Clipboard items to your Clipbook collection.
	Figure 110: When you have items in your Clipbook, you can then paste them into your documents wit...

	QuicKeys Clipbook vs. the System Clipboard
	Setting Up the QuicKeys Clipbook Action
	Using the Setup Wizard
	Figure 111: Use the “Create/Edit Multiple Actions” option in the Setup Wizard to set up several A...
	If you are setting up the QuicKeys Clipbook for the first time, follow these steps:
	1. Click the QuicKeys Clipbook button in the Setup Wizards tab.
	2. Read the introduction page and click Next.
	3. Select Create/edit multiple Actions and click Next.
	4. Click the check box for Copy selection to clipbook, Open Clipbook Editor, and Prompt for list ...
	5. Click in the Menu column for each of these options so they can be triggered from the QuicKeys ...
	6. Click Finish.


	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit a QuicKeys Clipbook Action, follow these st...
	1. Select Create>System Tools>QuicKeys Clipbook.
	2. Choose an option from the Action-specific properties pane of the dialog.
	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	Figure 112: You must add items to your Clipbook using the “Copy selection...” Action before anyth...

	4. If you want to trigger the QuicKeys Clipbook Actions from the QuicKeys menu, select the Includ...
	5. Click OK. Your new Action appears in the My Actions tab.
	6. Close the QuicKeys Editor and trigger one of the QuicKeys Clipbook Actions. The Action-specifi...



	Using the QuicKeys Clipbook Action
	The Clipbook Editor
	Figure 113: The Clipbook Editor

	QuicKeys Clipbook Options
	Figure 114: When you trigger the Paste function of the Clipbook Action this window appears. Selec...
	Figure 115: When you trigger the “Copy selection” function of the Clipbook Action this window app...

	Deleting Clipbook Actions
	To delete a QuicKeys Clipbook Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is cleared from the Actions list.


	Deleting Clips from the Clipbook Editor
	Run Script
	Setting Up the Run Script Action
	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit a Run Script Action, follow these steps:
	1. Select Create>System Tools>Run Script.
	2. Choose a script for QuicKeys to launch. Use the Browse button to navigate through your directo...
	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	Figure 116: The Run Script Action Properties dialog

	4. If you want to choose a hot key to trigger this Action, click on the Hot key box and press the...
	5. Click OK. Your new Action appears in the My Actions tab.
	6. Close the QuicKeys Editor and press the hot key or other trigger you assigned to this Action. ...



	Run Script Options
	Deleting Run Script Actions
	To delete a QuicKeys Run Script Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is cleared from the Actions list.



	Select Menu
	Setting Up Select Menu Actions
	Using the Setup Wizard
	Figure 117: This dialog appears when you click the Select Menu button in the Setup Wizards tab an...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit a Select Menu Action, follow these steps:
	1. Select Create>System Tools>Select Menu.
	2. Specify the menu item you want QuicKeys to locate when this Action is triggered.
	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	Figure 118: The Select Menu Action Properties dialog appears when you choose the Select Menu Acti...

	4. If you want to choose a hot key to trigger this Action, click on the Hot key box and press the...
	5. Click OK. Your new Action appears in the My Actions tab.
	6. Close the QuicKeys Editor and press the hot key or other trigger you assigned to this Action. ...



	Select Menu Options
	Figure 119: In this illustration, the Select Menu Action is being used to select the Word Wrap op...
	Figure 120: This is an example of the program system menu for Microsoft Excel.
	Figure 121: This is an example of the document system menu for Microsoft Excel.
	Figure 122: The Windows Start menu

	Deleting Select Menu Actions
	To delete a Select Menu Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is cleared from the Actions list.



	Set System Clock
	Setting Up Set System Clock Actions
	Using the Setup Wizard
	Figure 123: This dialog appears when you click the Set System Clock button in the Setup Wizards t...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit a Set System Clock Action, follow these steps:
	1. Select Create>System Tools>Set System Clock.
	2. Specify how you want to set your system clock. You can choose to set it by a selected remote t...
	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	Figure 124: The Set System Clock Action Properties dialog appears when you choose the Set System ...

	4. If you want to choose a hot key to trigger this Action, click on the Hot key box and press the...
	5. Click OK. Your new Action appears in the My Actions tab.
	6. Close the QuicKeys Editor and press the hot key or other trigger you assigned to this Action. ...



	Set System Clock Options
	Figure 125: The Remote Time Servers dialog

	Deleting a Set System Clock Action
	To delete a QuicKeys Set System Clock Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is cleared from the Actions list.



	Using System Specials
	Setting Up System Specials Actions
	Using the Setup Wizard
	Figure 126: This dialog appears when you click the System Specials button in the Setup Wizards ta...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit a System Specials Action, follow these steps:
	1. Select Create>System Tools>System Specials.
	2. Specify which basic computer task you want to automate.
	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	Figure 127: The System Specials Action Properties dialog appears when you choose the System Speci...

	4. Select a trigger for this Action.
	5. Click OK.
	6. Close the QuicKeys Editor and press the hot key or other trigger you assigned to this Action.



	System Specials Options
	Deleting a System Specials Action
	To delete a System Specials Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is cleared from the Actions list.



	Type Keystroke
	Setting Up Type Keystroke Actions
	Using the Setup Wizard
	Figure 128: This dialog appears when you click the Type Keystroke button in the Setup Wizards tab...

	Using the Action Properties Dialog
	To use the Actions Properties dialog to create or edit a Type Keystroke Action, follow these steps:
	1. Select Create>System Tools>Type Keystroke.
	Figure 129: The Type Keystroke Action Properties dialog appears when you select the Type Keystrok...

	2. Type the keystroke you want to replace in the Action- specific properties pane of the dialog.
	3. In the Name box of the Action Properties dialog, a name is automatically assigned to the Actio...
	4. Click on the Hot key box and press the key(s) you want to use to trigger this Action.
	5. Click OK. Your new Action appears in the My Actions tab.
	6. Close the QuicKeys Editor and press the hot key you assigned to this Action. The hot key you s...



	Type Keystroke Options
	Deleting a Type Keystroke Action
	To delete a Type Keystroke Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is cleared from the Actions list.



	Window Handler
	Setting Up Window Handler Actions
	Using the Setup Wizard
	Figure 130: This dialog appears when you click the Window Handler button in the Setup Wizards tab...

	Using the Action Properties Dialog
	To use the Actions Properties dialog to create or edit a Window Handler Action, follow these steps:
	1. Select Create>System Tools>Window Handler.
	Figure 131: The Window Handler Action Properties dialog appears when you select the Window Handle...

	2. Select the type of window you want to manipulate and then choose the Action you want to perfor...
	3. In the Name box of the Action Properties dialog, a name is automatically assigned to the Actio...
	4. Click on the Hot key box and press the key(s) you want to use to trigger this Action.
	5. Click OK. Your new Action appears in the My Actions tab.
	6. Close the QuicKeys Editor and press the hot key you assigned to this Action.



	Window Handler Options
	All Windows
	Figure 132: Cascading windows
	Figure 133: Horizontally tiled windows
	Figure 134: Vertically tiled windows

	Active Window
	Specified Window

	Deleting Window Handler Actions
	To delete a QuicKeys Window Handler Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is cleared from the Actions list.




	Chapter�9

	Using Screen Tools
	Screen Capture
	Setting Up the Screen Capture Action
	Using the Setup Wizard
	Figure 135: This dialog appears when you click the Screen Capture button in the Setup Wizards tab...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit a Screen Capture Action, follow these steps:
	1. Select Create>Screen Tools>Screen Capture.
	2. Choose what part of the screen you want to capture and then choose how you want to save the im...
	Figure 136: This dialog appears when you click the Screen Capture button in the Setup Wizards tab...

	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	4. If you want to trigger this Action from the QuicKeys menu, click the Include in QuicKeys menu ...
	5. Click OK. Your new Action immediately appears in the My Actions tab.
	6. Close the QuicKeys Editor and select the Screen Capture Action from the QuicKeys menu.



	Screen Capture Options
	Deleting Screen capture Actions
	To delete a Screen Capture Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.



	Screen Saver
	Setting Up the Screen Saver Action
	Using the Setup Wizard
	Figure 137: This dialog appears when you click the Screen Saver button in the Setup Wizards tab a...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit a Screen Saver Action, follow these steps:
	1. Select Create>Screen Tools>Screen Saver.
	2. Choose a Screen Saver option. If you choose Select screen saver, you must specify which screen...
	Figure 138: This dialog appears when you click the Screen Saver button in the Setup Wizards tab a...

	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	4. If you want to trigger this Action from the QuicKeys menu, click the Include in QuicKeys menu ...
	5. Click OK. Your new Action immediately appears in the My Actions tab.
	6. Close the QuicKeys Editor and select the Screen Saver Action from the QuicKeys menu.



	Screen Saver Options
	Deleting Screen Saver Actions
	To delete a Screen Saver Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.



	Screen Settings
	Setting Up the Screen Settings Action
	Using the Setup Wizard
	Figure 139: This dialog appears when you click the Screen Settings button in the Setup Wizards ta...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit a Screen Settings Action, follow these steps:
	1. Select Create>Screen Tools>Screen Settings.
	2. Choose a screen setting from the Action-specific properties pane of the dialog.
	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	4. If you want to trigger this Action from the QuicKeys menu, click the Include in QuicKeys menu ...
	Figure 140: The Screen Settings Action Properties dialog appears when you select the Screen Setti...

	5. Click OK. Your new Action immediately appears in the My Actions tab.
	6. Close the QuicKeys Editor and select the Screen Settings Action from the QuicKeys menu. The sc...



	Screen Settings Options
	Deleting Screen Setting Actions
	To delete a QuicKeys Screen Settings Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is immediately cleared from the Actions list.



	Chapter�10

	Using Multimedia Tools
	CD/DVD
	Setting Up a CD/DVD Action
	Using the Setup Wizard
	Figure 141: This dialog appears when you click the CD/DVD button in the Setup Wizards tab and cho...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit a CD/ DVD Action, follow these steps:
	1. Select Create>Multimedia Tools>CD/DVD.
	2. Choose an option from the Action-specific properties pane of the dialog. For example, select P...
	Figure 142: The CD/DVD Action Properties dialog appears when you select the CD/DVD Action from th...

	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	4. If you want to choose a hot key to trigger this Action, click in the Hot key box and press the...
	5. Click OK. Your new Action appears in the My Actions tab.
	6. Close the QuicKeys Editor and press the hot key or other trigger you assigned to this Action.



	CD/DVD Options
	Deleting CD/DVD Actions
	To delete a QuicKeys CD/DVD Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is cleared from the Actions list.



	Play Sound
	Setting Up a Play Sound Action
	Using the Setup Wizard
	To use the Setup Wizard with the Play Sound Action:
	1. Select View>Options.
	2. Verify the Always use Setup Wizards for editing check box is selected in the Options dialog an...
	Figure 143: This dialog appears when you have “Always use Setup Wizards for editing” checked in t...

	3. Back in the QuicKeys Editor, select Multimedia from the Create menu.
	4. Select Play Sound in the Multimedia submenu.
	5. The Setup Wizard appears to lead you through the process of setting up the Play Sound Action.


	Using the Advance Properties Dialog
	To use the Action Properties dialog to create or edit a Play Sound Action, follow these steps:
	1. Select Create>Multimedia Tools>Play Sound.
	Figure 144: The Play Sound Action Properties dialog appears when you select the Play Sound Action...

	2. Choose a sound file using the Browse button in the Action- specific properties pane of the dia...
	3. Click the Test button if you want to try out the select sound file.
	4. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	5. If you want to trigger the Play Sound Action from the QuicKeys menu, click the Include in Quic...
	6. Click OK. Your new Action appears in the My Actions tab.
	7. Close the QuicKeys Editor and select the new Play Sound Action using the trigger you specified.



	Play Sound Options
	Deleting Play Sound Actions
	To delete a QuicKeys Play Sound Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is cleared from the Actions list.



	Set Audio Volume
	Setting Up a Set Audio Volume Action
	Using the Setup Wizard
	Figure 145: This dialog appears when you click the Set Audio Volume button in the Setup Wizards t...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit a Set Audio Volume Action, follow these steps:
	1. Select Create>Multimedia Tools>Set Audio Volume.
	2. Choose an option from the Action-specific properties pane of the dialog. For example, choose M...
	Figure 146: The Set Audio Volume Action Properties dialog appears when you select the Set Audio V...

	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	4. If you want to choose a hot key to trigger this Action, click in the Hot key box and press the...
	5. Click OK. Your new Action appears in the My Actions tab.
	6. Close the QuicKeys Editor and press the hot key or other trigger you assigned to this Action.



	Set Audio Volume Options
	Deleting Audio Volume Actions
	To delete a QuicKeys Set Audio Volume Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is cleared from the Actions list.



	Chapter�11

	Using Network Tools
	Choose Printer
	Setting Up the Choose Printer Actions
	Using the Setup Wizard
	Figure 147: This dialog appears when you click the Choose Printer button in the Setup Wizards tab...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit a Choose Printer Action, follow these steps:
	1. Select Create>Network Tools>Choose Printer.
	2. Choose a printer from the Action-specific properties pane of the dialog.
	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	4. If you want to choose a hot key to trigger this Action, click in the Hot key box and press the...
	Figure 148: The Action Properties dialog

	5. Click OK. Your new Action immediately appears in the My Actions tab.
	6. Close the QuicKeys Editor and press the hot key or other trigger you assigned to this Action. ...



	Choose Printer Options
	Deleting Choose Printer Actions
	To delete a QuicKeys Choose Printer Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is immediately cleared from the Actions list.



	Dial-Up Networking
	Setting Up Dial-Up Networking Actions
	Using the Setup Wizard
	Figure 149: This dialog appears when you click the Dial-Up Networking button in the Setup Wizards...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit a Dial- Up Networking Action, follow these ...
	1. Select Create>Network Tools>Dial-Up Networking.
	Figure 150: The Dial-Up Networking Action Properties dialog appears when you select the Dial-Up N...

	2. Choose an option from the Action-specific properties pane of the dialog. For example, select C...
	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	4. If you want to trigger this Action from the QuicKeys menu, select the Include in QuicKeys menu...
	5. Click OK. Your new Action immediately appears in the My Actions tab.
	6. Close the QuicKeys Editor and trigger the Action from the QuicKeys menu or with whatever trigg...



	Dial-Up Networking Options
	Deleting Dial-Up Networking Actions
	To delete a QuicKeys Dial-Up Networking Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is immediately cleared from the Actions list.



	Network Drives
	Setting Up the Network Drives Action
	Using the Setup Wizard
	Figure 151: This dialog appears when you click the Network Drives button in the Setup Wizards tab...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit a Network Drives Action, follow these steps:
	1. Select Create>Network Tools>Network Drives.
	2. Choose a network drive from the Action-specific properties pane of the dialog.
	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	Figure 152: The Network Drives Action Properties dialog appears when you select the Network Drive...

	4. If you want to trigger this Action from the QuicKeys menu, select the Include in QuicKeys menu...
	5. Click OK. Your new Action immediately appears in the My Actions tab.
	6. Close the QuicKeys Editor and trigger the Network Drives Action from the QuicKeys menu or with...



	Network Drives Options
	More About Network Drive Actions

	Deleting Network Drive Actions
	To delete a QuicKeys Network Drives Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is immediately cleared from the Actions list.




	Chapter�12
	Instant E-mail
	Setting Up Instant E-mail Actions
	Using the Setup Wizard
	Figure 153: This dialog appears when you click the Instant E-mail button in the Setup Wizards tab...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit an Instant E-mail Action, follow these steps:
	1. Select Create>Internet Tools>Instant E-mail.
	2. Select an option from the Action-specific properties pane of the dialog. For example, choose C...
	Figure 154: The Instant E-mail Action Properties dialog appears when you select the Instant QuicK...

	3. If you would like to restrict the functionality of this Action to your E-mail program, select ...
	4. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	5. If you want to choose a hot key to trigger this Action, click in the Hot key box and press the...
	6. Click OK. Your new Action immediately appears in the My Actions tab.
	7. Close the QuicKeys Editor.
	8. Press the hot key or other trigger you assigned to the Instant E-mail Action. Your E-mail soft...



	More About Instant E-mail
	Instant E-mail Options
	Deleting Instant E-mail Actions
	To delete an Instant E-mail Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is immediately cleared from the Actions list.



	Web Launcher
	Setting Up Web Launcher Actions
	Using the Setup Wizard
	Figure 155: This dialog appears when you click the Web Launcher button in the Setup Wizards tab a...

	Using the Action Properties Dialog
	To use the Action Properties dialog to create or edit a Web Launcher Action, follow these steps:
	1. Select Create>Internet Tools>Web Launcher.
	2. Select the option you want to use in the Action-specific properties pane of the dialog. For ex...
	Figure 156: The Web Launcher Action Properties dialog appears when you select the Web Launcher Ac...

	3. In the General tab of the Action Properties dialog, a name is automatically assigned to the Ac...
	4. If you want to choose a hot key to trigger this Action, click in the Hot key box and press the...
	5. Click OK. Your new Action immediately appears in the My Actions tab.
	6. Close the QuicKeys Editor.
	7. Press the hot key or other trigger you assigned to this Action. The Web site you specified sho...


	Cut and Paste URLs
	1. Copy a URL to the system clipboard using the Control+C key combination.
	2. Open the QuicKeys Editor.
	3. Paste the URL into QuicKeys by pressing the Control+V key combination. A pre-filled Web Launch...
	4. Select a trigger for the Action and click OK.


	Web Launcher Options
	Figure 157: Open an Internet Explorer Favorite or a Netscape Bookmark from the Web Launcher brows...

	Deleting Web Launcher Actions
	To delete a Web Launcher Action:
	1. Select the My Actions tab in the QuicKeys Editor.
	2. Right-click the Action you want to delete.
	3. Select Delete from the context menu that appears.
	4. Choose Yes at the Confirm Delete prompt. The Action is immediately cleared from the Actions list.



	Chapter�13


	Building Sequences
	Figure 158: This example illustrates how QuicKeys Sequences can simplify routine, multi-step tasks.
	Overview of Sequences
	Using Sequences in Information Systems
	Figure 159: A Sequence for system administrators.
	How the Sequence Was Created
	Create an Open Action
	1. Create an Open Action and choose to open Outlook Express with a hot key trigger.
	1. Open Outlook Express with the hot key you just assigned to it. Select Start Recording from the...
	2. Press Alt+T to display the Tools menu.
	3. Use your mouse to select Accounts from the Tools menu.
	4. Click on the Mail tab in the Internet Accounts dialog.
	5. Select the account you want to change and click the Properties button.
	6. Click the Stop button on the Recording toolbar. The Sequence Editor appears.
	7. Name the Sequence Change E-mail Identity and click the Save & exit button. At this point, the ...
	1. Select Start Recording from the QuicKeys menu.
	2. When you see the Recording toolbar, type a different server name in the Mail account box of th...
	3. Press the Tab key to move down to the Name box. Type the name you want to use as your “new” id...
	4. Press the Tab key twice to move down to the E-mail address box. Type the E-mail address you wa...
	5. Press the Enter key to select the OK button.
	6. Click the Close button in the Internet Accounts dialog.
	7. Press the Stop recording button on the Recording toolbar. The Sequence Editor appears.
	8. Click the Save & exit button. By default, the second recording you created is called New Recor...
	1. Now, it’s time to put the final Sequence together. Open the QuicKeys Editor so the Actions tab...
	2. Open the Change E-mail Identity Sequence by double-clicking it in the Actions tab.
	3. In the Sequence Editor, position the insertion line at the first step of the Sequence.
	4. Position the My Actions tab so it’s tiled vertically alongside the Sequence Editor.
	5. Drag-and-drop the Open Outlook Express Action from the QuicKeys Editor Actions tab to the Sequ...
	6. Move the insertion line to the last step of the Sequence.
	7. Drag-and-drop the New Recording Sequence you recorded last to the last step of the Sequence Ed...
	8. Assign F3 as the hot key that triggers the Change E-mail Identity Sequence.
	9. Close out of Outlook Express and press F3. QuicKeys should launch the program and change the A...



	Using Sequences as a Webmaster

	The Typical Webmaster Toolkit
	Solutions for Webmasters
	Figure 160: This Sequence launches CuteFTP and logs into a commonly- used FTP directory.

	How the Sequence Was Created
	1. Create an Open Action and choose to open CuteFTP. Use the instructions on page�87 if you need ...
	2. Name the Action and assign it a trigger.
	1. Open CuteFTP with the trigger you just assigned to it.
	2. Select Start Recording from the QuicKeys menu.
	3. In the Site Manager window, open the Personal FTP Sites directory in the left pane.
	4. In the right pane of the Site Manager, select the FTP site you want open.
	5. Press Enter to connect to the site.
	6. Click the OK button in the Login Messages window to close the window. The main CuteFTP dialog ...
	7. Press the Stop button on the Recording toolbar.
	8. The Sequence Editor appears. Name the FTP Sequence FTP Login and assign it a trigger.
	9. Click the Save & Exit button to save your new Sequence and close the Sequence Editor.
	1. Now, it’s time to put the final Sequence together. Open the QuicKeys Editor so the My Actions ...
	2. Display the Sequence Editor by double-clicking the FTP Login Sequence in the My Actions tab.
	3. In the Sequence Editor, position the insertion line at the first step of the Sequence.
	4. Position the My Actions tab so it’s tiled vertically alongside the Sequence Editor.
	5. Drag-and-drop the Open CuteFTP Action from the QuicKeys Editor My Actions tab to the first ste...
	6. Click the Save & Exit button in the Sequence Editor to save your changes.
	7. Close out of CuteFTP and press the trigger you assigned to this Sequence. QuicKeys should laun...

	Using Sequences with Database Programs
	Figure 161: A Sequence that automates logging into a database program.
	How the Sequence Was Created

	Recording Sequences
	Figure 162: The Recording palette

	The Sequence Editor
	Figure 163: The Sequence Editor
	The Actions Toolbar
	The Result Column
	The Repeat Tab
	Figure 164: The Repeat tab appears in the upper half of the Sequence Editor.

	Printing Sequence Steps
	Closing the Sequence Editor

	Creating Sequences Without Recording
	Using the Result Handling Feature

	Sequence Icon
	Definition
	Result Handling Example
	Figure 165: A Sequence that uses Result Handling to add or delete information in a database.
	How this Sequence Was Created

	Editing Sequences
	Figure 166: This error dialog reveals which Sequence step failed.
	Inserting Steps
	The Create Menu

	Rearranging Steps in the Sequence
	Renaming Sequences
	Deleting Sequence Steps
	Sequence Tips

	Subordinate Sequences
	Creating Subordinate Sequences
	How a Sub-Sequence Works
	Figure 167: This Sequence contains two Sub-Sequences.
	1. Press F11. A window appears with instructions to click OK to go to Sequence One or Cancel to g...
	2. Click OK to start the Sequence. Click Cancel to start Sequence Two.
	Figure 168: This window appears when you trigger a Sequence like the one shown in Figure�167. Dep...


	Sub-Sequence Editor
	Figure 169: Open the Sub-Sequence Editor by selecting Sequence from the Create menu in the Sequen...
	General Tab
	Repeat Tab
	Step Results Tab


	Saving Sequences
	Triggering Sequences
	Figure 170: The Playback toolbar
	Figure 171: This dialog appears when your Sequence has completed successfully.
	Editing Failed Sequences
	Figure 172: This dialog appears when a sequence fails.

	Playback Options
	Deleting Sequences

	Sequence Tools
	Check Condition
	To insert a Check Condition Action into a Sequence:
	1. Open the Sequence in which you want to insert a Check Condition Action.
	2. Click the step where you want to insert the Check Condition Action.
	3. Select Create>Sequence Tools>Check Condition.
	4. Complete the Sequence Action Properties dialog that appears and click OK. See the Check Condit...

	Check Condition Options
	Figure 173: The Check file Action Properties
	Figure 174: The Check folder Action Properties
	To use the Window Finder:
	1. Open the window you want to examine in your Sequence.
	2. Open the dialog shown in Figure�175. The window you opened in step�1 should now be behind the ...
	3. Click your mouse on the Window Finder tool in the Action Properties dialog, and when your curs...
	4. Release the Window Finder cursor when it is positioned over the window you want to use in your...
	Figure 175: The Check window Action Properties
	Figure 176: The Check window control Action Properties
	Figure 177: The Check clipboard Action Properties
	Figure 178: The Check program Action Properties
	Figure 179: Check for specific date and/or time
	Figure 180: Run an executable from an installed file or from a specified file.


	To create the QKScripts directory and install your script(s):
	1. Create a folder called “QKScripts” in your QuicKeys directory. The path of the folder should b...
	2. Copy your executable(s) into the QKScripts folder.
	3. Click the Installed file option and select the executable file you wish to use for this condit...



	Message
	To insert a Message Action into a Sequence:
	1. Open the Sequence in which you want to insert a Message Action.
	Figure 181: The Action Properties dialog for the Message Sequence tool

	2. Position the insertion line in the location you want to insert the Message Action.
	3. Select Create>Sequence Tools>Message.
	4. Complete the Sequence Action Properties dialog that appears and click OK.

	Message Options

	Password Vault
	Using Password Vault
	To insert a Password Vault Action into a Sequence:
	1. Open the Sequence in which you want to insert a Password Vault Action.
	2. Position the insertion line in the location you want to insert the Password Vault Action.
	3. Select Create>Sequence Tools>Password Vault.
	4. Complete the Sequence Action Properties dialog shown in Figure�182 and click OK.
	Figure 182: The Action Properties dialog for the Password Vault Sequence tool



	Password Vault Options

	Pause
	Using Pause
	1. Open the Sequence in which you want to insert a Pause Action.
	2. Position the insertion line in the location you want to insert the Pause.
	3. Select Create>Sequence Tools>Pause.
	4. Complete the Sequence Action Properties dialog shown in Figure�183 and click OK.
	Figure 183: The Action Properties dialog for the Pause Sequence tool


	Pause Options

	QuicKeys Event Logger
	Figure 184: The QuicKeys Event Logger Action Properties

	Select Items in Dropdown List
	Figure 185: The Dropdown list Action Properties
	Select Items in Dropdown List Options

	Select Items in List
	Figure 186: The Select Items Action Properties
	Select Items in List Options

	Switch Tabs
	Figure 187: The Switch Tabs Action Properties
	Switch Tabs Options

	Wait for User Input
	Figure 188: The Wait for User Input Action Properties

	Wait for Window
	Using Wait for Window
	To insert a Wait for Window Action into a Sequence:
	1. Open the Sequence in which you want to insert a Wait for Window Action.
	Figure 189: The Action Properties dialog for the Wait for window Sequence tool.

	2. Position the insertion line in the location you want to insert the Wait for Window Action.
	3. Select Create>Sequence Tools>Wait for window.
	4. Complete the Sequence Action Properties and click OK.


	Wait for Window Options
	Figure 190: The Window Properties dialog


	Window Selector
	To insert a Window Selector Action into a Sequence:
	1. Open the Sequence in which you want to insert a Window Selector Action.
	Figure 191: The Action Properties dialog for the Window Selector Sequence tool.

	2. Position the insertion line in the location you want to insert the Window Selector Action.
	3. Select Create>Sequence Tools>Window Selector.
	4. Complete the Sequence Action Properties dialog and click OK.

	Window Selector Options


	Clearing Selected Hot Keys

	Appendix�a:

	Tips and Troubleshooting
	Tips
	Troubleshooting
	Multi-User Workstations
	Appendix�b:

	Creating Custom Toolbar Icons
	Using Bitmap Images
	1. Right-click the icon you want to replace on the toolbar and select Set icon from bitmap. A sta...
	2. Navigate to the bitmap image you want to use
	3. Select the bitmap image and click Open. The bitmap image appears as a button on your QuicKeys ...
	Restoring Default Icons

	Creating an Icon
	To create an icon:
	1. Open the Paint program that is installed with standard installations of Windows.
	2. Select Attributes from the Image menu.
	Figure 192: The Attributes dialog

	3. In the Attributes dialog, type 32 in the Width and Height fields.
	4. Select Pels in the Units area to use Pixels as your unit of measurement.
	5. Select whether you want to use black and white or colors in your icon.
	6. Click OK when you are done. A blank square appears in the Paint dialog.
	7. Use the tools in the Paint program’s tool palette to create an image.
	Figure 193: The icon in this example was created with the circle tool, the line tool, and the pen...

	8. Select Save as from the File menu.
	9. Navigate to the location on your hard drive where you want to save this icon.
	10. Type a name for the icon in the File name box. For example, type greenface.ico to mark the fi...
	11. Select 24-bit Bitmap from the Save as type drop-down list.
	12. Click Save. The new icon is saved to the location you specified.


	Setting the Icon in Quickeys
	To set a custom toolbar icon:
	1. Right-click a button on an open toolbar.
	Figure 194: The toolbar button menu

	2. Select Set icon from file.
	3. Click the Browse button in the Select Icon dialog.
	4. Navigate to the custom icon you just created.
	5. Choose the icon and click Open. The Select Icon dialog appears.
	6. Select the icon in the Select Icon dialog and click OK. The new icon appears immediately on th...
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